summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-28 19:43:45 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-29 09:17:49 -0400
commit98410ba1c30bb7d22d2f234a7205e7c189592f04 (patch)
tree996f393a93d3f0c48e4a18574c559bbdb33d2ecf /x11-plugins
parentx11-themes/fvwm-themes: bump EAPI and drop eutils (diff)
downloadgentoo-98410ba1c30bb7d22d2f234a7205e7c189592f04.tar.gz
gentoo-98410ba1c30bb7d22d2f234a7205e7c189592f04.tar.bz2
gentoo-98410ba1c30bb7d22d2f234a7205e7c189592f04.zip
x11-plugins/wmbio: bump EAPI and drop eutils
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmbio/wmbio-1.02.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/x11-plugins/wmbio/wmbio-1.02.ebuild b/x11-plugins/wmbio/wmbio-1.02.ebuild
index b6fcce6d4152..b2be120eed9c 100644
--- a/x11-plugins/wmbio/wmbio-1.02.ebuild
+++ b/x11-plugins/wmbio/wmbio-1.02.ebuild
@@ -1,8 +1,7 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit eutils
+EAPI=6
DESCRIPTION="A Window Maker applet that shows your biorhythm"
HOMEPAGE="http://wmbio.sourceforge.net/"
@@ -22,18 +21,15 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P}/src
src_prepare() {
+ default
# Honour Gentoo CFLAGS
- sed -i "s/-g -O2/\$(CFLAGS)/" Makefile
+ sed -i "s/-g -O2/\$(CFLAGS)/" Makefile || die "sed for CFLAGS failed"
# Honour Gentoo LDFLAGS
- sed -i "s/-o wmbio/\$(LDFLAGS) -o wmbio/" Makefile
-}
-
-src_compile() {
- emake || die "emake failed"
+ sed -i "s/-o wmbio/\$(LDFLAGS) -o wmbio/" Makefile || die "sed for LDFLAGS failed"
}
src_install () {
- dobin wmbio || die "dobin failed"
- dodoc ../{AUTHORS,Changelog,NEWS,README} || die
+ dobin wmbio
+ dodoc ../{AUTHORS,Changelog,NEWS,README}
}