summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-12-02 10:45:10 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2016-12-02 12:04:55 +0100
commitc9833991643bab2a33e7a2e0271e32dd476aeaff (patch)
tree76dedf8d40da731daa427ec0f57ad9ad79de993a /x11-plugins
parentdev-python/soappy: x86 stable wrt bug #534546 (diff)
downloadgentoo-c9833991643bab2a33e7a2e0271e32dd476aeaff.tar.gz
gentoo-c9833991643bab2a33e7a2e0271e32dd476aeaff.tar.bz2
gentoo-c9833991643bab2a33e7a2e0271e32dd476aeaff.zip
x11-plugins/wmbiff: version bump to 0.4.30
EAPI bump, update for new dockapps.net homepage Package-Manager: portage-2.3.2
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmbiff/Manifest1
-rw-r--r--x11-plugins/wmbiff/wmbiff-0.4.30.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/x11-plugins/wmbiff/Manifest b/x11-plugins/wmbiff/Manifest
index b4cadf8454dd..8cabb83867ab 100644
--- a/x11-plugins/wmbiff/Manifest
+++ b/x11-plugins/wmbiff/Manifest
@@ -1 +1,2 @@
DIST wmbiff-0.4.28.tar.gz 111398 SHA256 6e2acd3268dad93c596e4eae6ccf4407667f07226cf61dd7cfa312ae5e42dbc1 SHA512 a17fd4b4c3de09a907b7ffccc50f4560a7fddd5cb4dd01c72460806dc55259ba0b587d75f7505171a2a833f6735ddc4ded0a484d4227bfd552cc7343d79d7720 WHIRLPOOL c4a0c54f41a3ae33785364ea3bca808bc5b0c801a87ea33bd569f8fac9bb7632155af5d666bc7b3dbfe10fbebb8b2202fccb49266ded3fd299f2e0ac2749785c
+DIST wmbiff-0.4.30.tar.gz 269315 SHA256 0dae00ebe377ffc0f37565cf6fdc84a4fc9896a2421826909b0ab5abd5fa4f2a SHA512 10b5a6673763a48694cb9cd87f5972c09b0fc50acedde7658133830a06dea8c98ffb9943591cbef802330862d7ccf7a7322d7e9e25ee82209b5a0e40a22353b4 WHIRLPOOL 37e1b34f21daf2d51c2960151f7601056316dcba71b0ec850edc0ea3fe3925ca669fe846b44307a2c304f5c92dec12845ca33a8a3c64a49455844bc6cc7626b6
diff --git a/x11-plugins/wmbiff/wmbiff-0.4.30.ebuild b/x11-plugins/wmbiff/wmbiff-0.4.30.ebuild
new file mode 100644
index 000000000000..181a5afa0966
--- /dev/null
+++ b/x11-plugins/wmbiff/wmbiff-0.4.30.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils
+
+DESCRIPTION="WMBiff is a dock applet for WindowMaker which can monitor up to 5 mailboxes"
+HOMEPAGE="http://www.dockapps.net/wmbiff"
+SRC_URI="http://www.dockapps.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="crypt"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ crypt? (
+ >=dev-libs/libgcrypt-1.2.1:0
+ >=net-libs/gnutls-2.2.0
+ )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xextproto
+ x11-proto/xproto"
+
+DOCS="ChangeLog FAQ NEWS README TODO wmbiff/sample.wmbiffrc"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${PN}-0.4.27-invalid-strncpy.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable crypt crypto)
+}