summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-05-29 22:02:10 +0200
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2016-05-29 22:02:10 +0200
commit96f5c8d5caa235bc072898e45c70d184a95c0d10 (patch)
treec9b234cd48de845bc755e1969a65fb81108cce10 /x11-proto/xcb-proto/xcb-proto-1.12-r1.ebuild
parentmedia-plugins/vdr-dvbapi: version bump (diff)
downloadgentoo-96f5c8d5caa235bc072898e45c70d184a95c0d10.tar.gz
gentoo-96f5c8d5caa235bc072898e45c70d184a95c0d10.tar.bz2
gentoo-96f5c8d5caa235bc072898e45c70d184a95c0d10.zip
x11-proto/xcb-proto: fix python-3 build
Bug: https://bugs.freedesktop.org/show_bug.cgi?id=95490 Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-proto/xcb-proto/xcb-proto-1.12-r1.ebuild')
-rw-r--r--x11-proto/xcb-proto/xcb-proto-1.12-r1.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/x11-proto/xcb-proto/xcb-proto-1.12-r1.ebuild b/x11-proto/xcb-proto/xcb-proto-1.12-r1.ebuild
new file mode 100644
index 000000000000..8ef85b60245c
--- /dev/null
+++ b/x11-proto/xcb-proto/xcb-proto-1.12-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+XORG_MULTILIB=yes
+
+inherit python-r1 xorg-2
+
+DESCRIPTION="X C-language Bindings protocol headers"
+HOMEPAGE="https://xcb.freedesktop.org/"
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xcb/proto"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="https://xcb.freedesktop.org/dist/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="${PYTHON_DEPS}"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-make-whitespace-usage-consistent.patch
+ "${FILESDIR}"/${P}-print-is-a-function-and-needs-parentheses.patch
+)
+
+src_configure() {
+ python_setup
+ xorg-2_src_configure
+}
+
+multilib_src_configure() {
+ autotools-utils_src_configure
+
+ if multilib_is_native_abi; then
+ python_foreach_impl autotools-utils_src_configure
+ fi
+}
+
+multilib_src_compile() {
+ default
+
+ if multilib_is_native_abi; then
+ python_foreach_impl autotools-utils_src_compile -C xcbgen \
+ top_builddir="${BUILD_DIR}"
+ fi
+}
+
+src_install() {
+ xorg-2_src_install
+
+ # pkg-config file hardcodes python sitedir, bug 486512
+ sed -i -e '/pythondir/s:=.*$:=/dev/null:' \
+ "${ED}"/usr/lib*/pkgconfig/xcb-proto.pc || die
+}
+
+multilib_src_install() {
+ default
+
+ if multilib_is_native_abi; then
+ python_foreach_impl autotools-utils_src_install -C xcbgen \
+ top_builddir="${BUILD_DIR}"
+ fi
+}