summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-07-12 12:08:33 -0700
committerMatt Turner <mattst88@gentoo.org>2021-07-12 12:13:39 -0700
commit20047628201a6cea2804ce7164b79e026480c638 (patch)
tree6e7594bcdf5bd2e98dd4a81f1dff45a0ba268e35 /x11-terms/gnome-terminal
parentapp-xemacs/ebuild-mode: Version bump to 1.53 (diff)
downloadgentoo-20047628201a6cea2804ce7164b79e026480c638.tar.gz
gentoo-20047628201a6cea2804ce7164b79e026480c638.tar.bz2
gentoo-20047628201a6cea2804ce7164b79e026480c638.zip
x11-terms/gnome-terminal: Version bump to 3.40.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-terms/gnome-terminal')
-rw-r--r--x11-terms/gnome-terminal/Manifest1
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-3.40.3.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/x11-terms/gnome-terminal/Manifest b/x11-terms/gnome-terminal/Manifest
index a1da201b1c06..05c9bfafcefc 100644
--- a/x11-terms/gnome-terminal/Manifest
+++ b/x11-terms/gnome-terminal/Manifest
@@ -1,3 +1,4 @@
DIST gnome-terminal-3.40.1-cntr-ntfy-autottl-ts.patch.xz 33548 BLAKE2B 50952d21a6a5758b500665aed21b95d8b4295240e24ea69dd806321a32338aeb904c60cd7dbb713d3d456bdc9199c7c4b4e2d65bc7078fa9bbf6a7d94c227265 SHA512 0efc106b35c25199ed8d4edc5c36a10a1013e62100c0b3397a5bb04386d7d2f548e811451c8577bc123ffbe935cea2a8f10d08473de5fadc4d07db0f301ab3bc
DIST gnome-terminal-3.40.1.tar.xz 2596912 BLAKE2B 6b199941a2d30a8bd06d779d8d5a1fc9096b7183718705b74842566033ddd36c18a32a68014b5c7ab545bf0bb4f780fa950c7d6d04149f89f640f0db6f105b59 SHA512 8e16b3c8513cf3c503a4a35e2c238ea41b087d426787402e0db5ef7e4bc5303d5a34a6455f651760327560f73edf3256177bbe3633e8a5b8abe8edab2bda7698
DIST gnome-terminal-3.40.2.tar.xz 2608032 BLAKE2B 8d7a355623d6eee9f4e3d4ff219dbd12c34987ea1ab1b7dc960c5bf19772d57de3bd81f63ceae61e87e932f05d47208390738dd8df30cbca71d8d0ad5d4b7887 SHA512 d3c75dcf46775492149f98c0c1a9739ac8c8e816487160c1e859034bc8cbcaeb0ff81f7e87e577e248f662db64ee914974bda0cb3e548ab12fb4b431d82af100
+DIST gnome-terminal-3.40.3.tar.xz 2609060 BLAKE2B cc0ef61b2ffbe7dd93117acad6ad2b1f737fb74417c2c84a98cdf3c28d29a7aaeaae4461a0160549eaac8bf9fdc1852e67ffb2e2570b456132bc1726a7033486 SHA512 a4de627f88069f3a1cc69a53dfe4c29ebdd22ee604b0e0b1702dd1c7a14a5fb877968c020bece7f0d5d7dc496019ffef0f9b2d15cb17c80c0a99b331a64f8346
diff --git a/x11-terms/gnome-terminal/gnome-terminal-3.40.3.ebuild b/x11-terms/gnome-terminal/gnome-terminal-3.40.3.ebuild
new file mode 100644
index 000000000000..b16c95d6f7e6
--- /dev/null
+++ b/x11-terms/gnome-terminal/gnome-terminal-3.40.3.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2 readme.gentoo-r1
+
+DESCRIPTION="The Gnome Terminal"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="debug +gnome-shell +nautilus vanilla"
+SRC_URI+=" !vanilla? ( https://dev.gentoo.org/~mattst88/distfiles/${PN}-3.40.1-cntr-ntfy-autottl-ts.patch.xz )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# FIXME: automagic dependency on gtk+[X], just transitive but needs proper control, bug 624960
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.22.27:3
+ >=x11-libs/vte-0.64.0:2.91[!vanilla?]
+ >=dev-libs/libpcre2-10
+ >=gnome-base/dconf-0.14
+ >=gnome-base/gsettings-desktop-schemas-0.1.0
+ sys-apps/util-linux
+ gnome-shell? ( gnome-base/gnome-shell )
+ nautilus? ( >=gnome-base/nautilus-3.28.0 )
+"
+DEPEND="${RDEPEND}"
+# itstool required for help/* with non-en LINGUAS, see bug #549358
+# xmllint required for glib-compile-resources, see bug #549304
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="To get previous working directory inherited in new opened tab, or
+ notifications of long-running commands finishing, you will need
+ to add the following line to your ~/.bashrc:\n
+ . /etc/profile.d/vte-2.91.sh"
+
+src_prepare() {
+ if ! use vanilla; then
+ # https://bugzilla.gnome.org/show_bug.cgi?id=695371
+ # Fedora patches:
+ # Restore transparency support (with compositing WMs only)
+ # OSC 777 desktop notification support (notifications on tabs for long-running commands completing)
+ # Restore "Set title" support
+ # Automatic title updating based on currently running foreground process
+ # https://src.fedoraproject.org/rpms/gnome-terminal/raw/f31/f/gnome-terminal-cntr-ntfy-autottl-ts.patch
+ # Depends on vte[-vanilla] for OSC 777 and the preexec/precmd/etc patches in VTE
+ eapply "${WORKDIR}"/${PN}-3.40.1-cntr-ntfy-autottl-ts.patch
+ fi
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable gnome-shell search-provider) \
+ $(use_with nautilus nautilus-extension)
+}
+
+src_install() {
+ DOCS=( AUTHORS ChangeLog HACKING NEWS )
+ gnome2_src_install
+ if ! use vanilla; then
+ # Separate "New Window/Tab" menu entries by default, instead of unified "New Terminal"
+ insinto /usr/share/glib-2.0/schemas
+ newins "${FILESDIR}"/separate-new-tab-window.gschema.override org.gnome.Terminal.gschema.override
+ fi
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}