summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-27 21:08:12 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-27 21:21:08 -0700
commit6a9c98bc41d447d4ec6c5cf33775281826efda51 (patch)
treeca8f98f42ba29569e88bf73f089e62dea4a777e6 /x11-terms/gnome-terminal
parentx11-libs/vte: Version bump to 0.68.0 (diff)
downloadgentoo-6a9c98bc41d447d4ec6c5cf33775281826efda51.tar.gz
gentoo-6a9c98bc41d447d4ec6c5cf33775281826efda51.tar.bz2
gentoo-6a9c98bc41d447d4ec6c5cf33775281826efda51.zip
x11-terms/gnome-terminal: Version bump to 3.44.0
Closes: https://bugs.gentoo.org/829399 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-terms/gnome-terminal')
-rw-r--r--x11-terms/gnome-terminal/Manifest2
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-3.44.0.ebuild93
2 files changed, 95 insertions, 0 deletions
diff --git a/x11-terms/gnome-terminal/Manifest b/x11-terms/gnome-terminal/Manifest
index d5162e387b45..b6035cd5058b 100644
--- a/x11-terms/gnome-terminal/Manifest
+++ b/x11-terms/gnome-terminal/Manifest
@@ -1,2 +1,4 @@
DIST gnome-terminal-3.42.2-cntr-ntfy-autottl-ts.patch.xz 33980 BLAKE2B e0400f960064907c84a059b2210a9299e353b280e4bbe2fb98a887f9806fc2eb5f7de9d3e6dee243f6297275479ec546d47292bb30ea02e8f4a887fafbe04e71 SHA512 4afab38bff15963e88bc756914b5c379634c68d59f0be1189d969ea0a8b7f3f6c0a077199455cc4c2eca96e5c3df06bddebdc32b786aaba3a885e21cb710f210
DIST gnome-terminal-3.42.2.tar.xz 1806388 BLAKE2B 9e3068d9731689dd5dc012405384073a6ea07d59370340bcccdc3383e24f5a5424a14b5e903a01b4cca3925758f9b2f5cd7861b30658324297f817807fefbb66 SHA512 001504539adbcdac609f22ee8120455d2a2db8f4208ca2715c6bb271b5488bfdbe78deca3c997cd4d2293f2e7e51db66746af56f5ba46792542654972dbc739e
+DIST gnome-terminal-3.44.0-cntr-ntfy-autottl-ts.patch.xz 37248 BLAKE2B b3599386e7272fc5b742c11663f09bbfafa84cc855bd13fd602d679601fbb4126f36cdb157db37db335bf9edfe7d2b85e534baf837c5817984ec17baa4cdbb6c SHA512 6422a774abfee18b2681115344f508b72ead1bb9f27b5b1596b419a9ce5a137d41e2d749b6d784170225e7f21f15c109f7eb74cc3164371d53dee7790bf99187
+DIST gnome-terminal-3.44.0.tar.xz 1810124 BLAKE2B 041aa7400cbf0f075c37f6276d06dbffb0b87da13d8bcb9d13e62b13a1e16ae612970d1ec6462c7c257f7bcf2da222b48df1d8d28ce24b216ae3d11c76f05341 SHA512 0cf039c0aa364a9ac63d9f24d466506a919cf733f2ee8dc1c6f42459e6c742bad678f7ad7cec3721e9512b8f414dc4c4c1f29057c73e5e4a870a04d6bcd98ed6
diff --git a/x11-terms/gnome-terminal/gnome-terminal-3.44.0.ebuild b/x11-terms/gnome-terminal/gnome-terminal-3.44.0.ebuild
new file mode 100644
index 000000000000..a5297be2d0ec
--- /dev/null
+++ b/x11-terms/gnome-terminal/gnome-terminal-3.44.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} )
+inherit gnome.org gnome2-utils meson python-any-r1 readme.gentoo-r1 xdg
+
+DESCRIPTION="A terminal emulator for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/ https://gitlab.gnome.org/GNOME/gnome-terminal"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="debug +gnome-shell +nautilus vanilla"
+SRC_URI+=" !vanilla? ( https://dev.gentoo.org/~mattst88/distfiles/${PN}-3.44.0-cntr-ntfy-autottl-ts.patch.xz )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# FIXME: automagic dependency on gtk+[X], just transitive but needs proper control, bug 624960
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.22.27:3
+ >=x11-libs/vte-0.68.0:2.91[!vanilla?]
+ >=dev-libs/libpcre2-10
+ >=gnome-base/dconf-0.14
+ >=gnome-base/gsettings-desktop-schemas-0.1.0
+ sys-apps/util-linux
+ gnome-shell? ( gnome-base/gnome-shell )
+ nautilus? ( >=gnome-base/nautilus-3.28.0 )
+"
+DEPEND="${RDEPEND}"
+# itstool required for help/* with non-en LINGUAS, see bug #549358
+# xmllint required for glib-compile-resources, see bug #549304
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="To get previous working directory inherited in new opened tab, or
+ notifications of long-running commands finishing, you will need
+ to add the following line to your ~/.bashrc:\n
+ . /etc/profile.d/vte-2.91.sh"
+
+src_prepare() {
+ if ! use vanilla; then
+ # https://bugzilla.gnome.org/show_bug.cgi?id=695371
+ # Fedora patches:
+ # Restore transparency support (with compositing WMs only)
+ # OSC 777 desktop notification support (notifications on tabs for long-running commands completing)
+ # Restore "Set title" support
+ # Automatic title updating based on currently running foreground process
+ # https://src.fedoraproject.org/rpms/gnome-terminal/raw/f31/f/gnome-terminal-cntr-ntfy-autottl-ts.patch
+ # Depends on vte[-vanilla] for OSC 777 and the preexec/precmd/etc patches in VTE
+ eapply "${WORKDIR}"/${PN}-3.44.0-cntr-ntfy-autottl-ts.patch
+ fi
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use debug dbg)
+ -Ddocs=false
+ $(meson_use nautilus nautilus_extension)
+ $(meson_use gnome-shell search_provider)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if ! use vanilla; then
+ # Separate "New Window/Tab" menu entries by default, instead of unified "New Terminal"
+ insinto /usr/share/glib-2.0/schemas
+ newins "${FILESDIR}"/separate-new-tab-window.gschema.override org.gnome.Terminal.gschema.override
+ fi
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+ readme.gentoo_print_elog
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}