summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-11-26 14:17:53 +0100
committerMarek Szuba <marecki@gentoo.org>2021-11-26 14:40:50 +0100
commit0221ba7ea500906e84f015e6f366ccb0705037eb (patch)
treebbcbac95e7958484736298d4c6ac48e9b470c04d /x11-terms
parentx11-terms/rxvt-unicode: drop 9.22-r9 (diff)
downloadgentoo-0221ba7ea500906e84f015e6f366ccb0705037eb.tar.gz
gentoo-0221ba7ea500906e84f015e6f366ccb0705037eb.tar.bz2
gentoo-0221ba7ea500906e84f015e6f366ccb0705037eb.zip
x11-terms/rxvt-unicode: add 9.29
Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/rxvt-unicode/Manifest2
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9.29.ebuild113
2 files changed, 115 insertions, 0 deletions
diff --git a/x11-terms/rxvt-unicode/Manifest b/x11-terms/rxvt-unicode/Manifest
index 1cae105e7af0..8eaa3597db5d 100644
--- a/x11-terms/rxvt-unicode/Manifest
+++ b/x11-terms/rxvt-unicode/Manifest
@@ -1,2 +1,4 @@
DIST rxvt-unicode-9.26.tar.bz2 904950 BLAKE2B 1790d02eeadf630cc9bc718288af2f6bd19c3e320d3dbfa44c8cef516c8e790e0abfbfe4e557795749ddd3ec41b8358f6eac623c060240f091b3e84a549151ad SHA512 35560b57730e17c9542ea4a615fd86ce703c4e6421323e8fe1570007737a880fde90d17943e5af9e170be4111b9769f4aa7e57efca5428421fdc1c299112f8e0
DIST rxvt-unicode-9.26_24-bit-color_aur-20210516+eautoreconf.patch.xz 11716 BLAKE2B 7e18b0f884dbb9574515db8cfb4e1521e1e3287ac194750db288409c7e4d0bb120964e4559ce7e3b91e169935ded93f3af3045fc7c1737a5a6de2710ee2e107b SHA512 8cbcc1c04bdb83996ce08ece559ef9e7f5f530140a2a66291e0ffd049808da60787a68520b4a990dc12e1272de861a85b199ddd10ac8b245eafbfe16dc521199
+DIST rxvt-unicode-9.29.tar.bz2 876330 BLAKE2B 79ad6f4d60f0b6e99ca9d820c2af54ed142cffab444500885e04c36199724bdf124dbd53595358d3358b5bfa235a567b2eddd850da1b81ae7aa4ef9a453d0f4d SHA512 8af7f1e8c3f2c6bf5fa131b6ef61e836ac7c83ac2b31ccb183d7481191f55a8e87e7f9f6d93f2ae1855ca339f71b2d682471ee41ef706b7ccc21c6c8ea4b44f9
+DIST rxvt-unicode-9.29_24-bit-color_aur-9.26-20210712.patch.xz 7568 BLAKE2B 8ea5d813e00fd4012d145acf70e3d9b0974dddffd203fbec4bf06a0da1c9368ec316fc2903dccae3a5d71d684fd93b2a09ed208f26be1e85f77c702494db4e54 SHA512 baa226ca9adf6025a72dea925ec3be16186502bb4aab21dd61ef1f7c3e2eb793e7a1dc9619ed8228166758daa2879a465da2ace3f3b14545808955388bd2b74b
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9.29.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9.29.ebuild
new file mode 100644
index 000000000000..e3eaeeddc8d2
--- /dev/null
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9.29.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools desktop flag-o-matic systemd prefix
+
+COLOUR_PATCH_NAME="${PN}-9.29_24-bit-color_aur-9.26-20210712.patch"
+
+DESCRIPTION="rxvt clone with xft and unicode support"
+HOMEPAGE="http://software.schmorp.de/pkg/rxvt-unicode.html"
+SRC_URI="http://dist.schmorp.de/rxvt-unicode/Attic/${P}.tar.bz2
+ https://dev.gentoo.org/~marecki/dists/${PN}/${COLOUR_PATCH_NAME}.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+IUSE="24-bit-color 256-color blink fading-colors +font-styles gdk-pixbuf iso14755 +mousewheel
+ +perl startup-notification unicode3 xft"
+
+RDEPEND=">=sys-libs/ncurses-5.7-r6:=
+ dev-libs/libptytty
+ media-libs/fontconfig
+ x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXt
+ gdk-pixbuf? ( x11-libs/gdk-pixbuf )
+ kernel_Darwin? ( dev-perl/Mac-Pasteboard )
+ perl? ( dev-lang/perl:= )
+ startup-notification? ( x11-libs/startup-notification )
+ xft? ( x11-libs/libXft )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-9.06-case-insensitive-fs.patch
+ "${FILESDIR}"/${PN}-9.21-xsubpp.patch
+)
+DOCS=(
+ Changes
+ README.FAQ
+ doc/README.xvt
+ doc/changes.txt
+ doc/etc/${PN}.term{cap,info}
+ doc/rxvt-tabbed
+)
+
+src_prepare() {
+ default
+
+ # Current patch is too aggressive to apply unconditionally, see Bug #801571
+ if use 24-bit-color; then
+ eapply "${WORKDIR}"/${COLOUR_PATCH_NAME}
+ eautoreconf
+ fi
+
+ # kill the rxvt-unicode terminfo file - #192083
+ sed -i -e "/rxvt-unicode.terminfo/d" doc/Makefile.in || die "sed failed"
+
+ # use xsubpp from Prefix - #506500
+ hprefixify -q '"' -w "/xsubpp/" src/Makefile.in
+}
+
+src_configure() {
+ # --enable-everything goes first: the order of the arguments matters
+ local myconf=(
+ --enable-everything
+ $(use_enable 256-color)
+ $(use_enable blink text-blink)
+ $(use_enable fading-colors fading)
+ $(use_enable font-styles)
+ $(use_enable gdk-pixbuf pixbuf)
+ $(use_enable iso14755)
+ $(use_enable mousewheel)
+ $(use_enable perl)
+ $(use_enable startup-notification)
+ $(use_enable unicode3)
+ $(use_enable xft)
+ )
+ if use 24-bit-color; then
+ myconf+=( --enable-24-bit-color )
+ fi
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ default
+
+ sed -i \
+ -e 's/RXVT_BASENAME = "rxvt"/RXVT_BASENAME = "urxvt"/' \
+ "${S}"/doc/rxvt-tabbed || die
+}
+
+src_install() {
+ default
+
+ systemd_douserunit "${FILESDIR}"/urxvtd.service
+ systemd_douserunit "${FILESDIR}"/urxvtd.socket
+
+ make_desktop_entry urxvt rxvt-unicode utilities-terminal \
+ "System;TerminalEmulator"
+}
+
+pkg_postinst() {
+ if use 24-bit-color; then
+ ewarn
+ ewarn "You have enabled 24-bit colour support in ${PN}, which is UNOFFICIAL and INCOMPLETE."
+ ewarn "You may or may not encounter visual glitches or stability issues. When in doubt,"
+ ewarn "rebuild =${CATEGORY}/${PF} with USE=-24-bit-color (the default setting)."
+ ewarn
+ fi
+}