summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Smith <matt@offtopica.uk>2021-05-06 12:21:58 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-06-03 10:01:12 +0300
commit3e735f140315cd36730dbc58cffa8431f1a88aae (patch)
tree63d461e19b039b1663f869b173e34c1c1ed42ce7 /x11-terms
parentmedia-plugins/vdr-epgsearch: version bump and gcc-11 fix (diff)
downloadgentoo-3e735f140315cd36730dbc58cffa8431f1a88aae.tar.gz
gentoo-3e735f140315cd36730dbc58cffa8431f1a88aae.tar.bz2
gentoo-3e735f140315cd36730dbc58cffa8431f1a88aae.zip
x11-terms/zutty: Bump to 0.9
Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Matt Smith <matt@offtopica.uk> Closes: https://github.com/gentoo/gentoo/pull/20699 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/zutty/Manifest1
-rw-r--r--x11-terms/zutty/zutty-0.9.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/x11-terms/zutty/Manifest b/x11-terms/zutty/Manifest
index 8c132647bf20..71b171d7f877 100644
--- a/x11-terms/zutty/Manifest
+++ b/x11-terms/zutty/Manifest
@@ -1 +1,2 @@
DIST zutty-0.8.tar.gz 307235 BLAKE2B 897fea3735785ba1e8c811adbc90b96598c04f3ec19d9d3027745e5b9d3c1d21c55343b9409e48327139545e2675346be90d84af422d3ce97b1737cc287bb96b SHA512 75c5637fe8f0c8aff41e394a05f304f56bf03faf1dfa78807ca930a722536a93f54012f051f411b4e8ff478dd991f5b8ca1285fcd674879eac568c8971004317
+DIST zutty-0.9.tar.gz 336534 BLAKE2B 61d2ae02e2c0b08a9c536190f61f14300b0cd1bacb83f5da33e92a6c8502df6adda72805e58f3d679c7258c30338178b4488c0f7bfbfaf8b5e922401e6442427 SHA512 590cf090c0d80e683d4473828cdb8bbe4f60bc5bc3c5e9e63039a59757e281ecefc774709f08777fe36ab596fb102f392c8bf643449e62914e5b88d0ebc728c0
diff --git a/x11-terms/zutty/zutty-0.9.ebuild b/x11-terms/zutty/zutty-0.9.ebuild
new file mode 100644
index 000000000000..6d1da930375a
--- /dev/null
+++ b/x11-terms/zutty/zutty-0.9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="X terminal emulator rendering through OpenGL ES Compute Shaders"
+HOMEPAGE="https://tomscii.sig7.se/zutty/ https://github.com/tomszilagyi/zutty"
+SRC_URI="https://github.com/tomszilagyi/zutty/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ media-libs/freetype:2
+ media-libs/libglvnd[X]
+ x11-libs/libXmu
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+DOCS=( doc/KEYS.org doc/USAGE.org )