summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-10-14 14:47:28 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-10-14 14:48:59 +0200
commit50c50c1d42b45ab64af19fd5836e43e374da6136 (patch)
tree08bde5011bc45f4864e4ec6f21d19737dfcfed9e /x11-terms
parentmedia-sound/twolame: Bump to version 0.4.0 (diff)
downloadgentoo-50c50c1d42b45ab64af19fd5836e43e374da6136.tar.gz
gentoo-50c50c1d42b45ab64af19fd5836e43e374da6136.tar.bz2
gentoo-50c50c1d42b45ab64af19fd5836e43e374da6136.zip
x11-terms/xterm: Bump to version 349
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/xterm/Manifest1
-rw-r--r--x11-terms/xterm/xterm-349.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/x11-terms/xterm/Manifest b/x11-terms/xterm/Manifest
index 249bc4d4d871..0e46b25abd8e 100644
--- a/x11-terms/xterm/Manifest
+++ b/x11-terms/xterm/Manifest
@@ -2,3 +2,4 @@ DIST xterm-327.tgz 1240131 BLAKE2B 7f009ec995fa9f8007cd5497d13f1120440df40ef0801
DIST xterm-337.tgz 1336781 BLAKE2B 6878154cc5d2f8547b8b8ffac0bff7603dce6d58c294b4153e169654fc441f1209c97a6d17bf3f880d0160a42e102ca8fd4a291c2b7d373269290a7bbebeeb8d SHA512 fad31aa971a42cf38d3e3db2edc615b408d92226c305654b9276592c6dee075f31c7f082a3f549284f1685a31d5d9dedbda99c2c308a90bd741958f862806609
DIST xterm-347.tgz 1371955 BLAKE2B 8144afe48fac33ed7fec50dc8863af992440ca045fd5bef0db15176aa0b550daa26cda8f6a06fd4e340ec5aaf562a1cbdb7e9da21d0f42c0ef1966b5b2c91d93 SHA512 4b90094c21b7af3042591939308538dc767d42718e9a6112115e6df12a974f8e3b7fba8d791d7c9557863fd07d08f2365fa7f759f7797f859a6fe5fe0852ab4e
DIST xterm-348.tgz 1375431 BLAKE2B 29313e5a9ae0f92faa1faa4fb641244716fabcdaf9b17b8898c75cf2d4ad2e19bc44702cc4510c4a9413e1a8b811ed61deb5934b93c3cd0eb101c998b1bbc9e4 SHA512 852896c0aba885bafc80baad899fc56910dce66bf5df6b3fef3f998efc33af9d30b68cfb0c92c7028365ac4944af3d3c198bc0e408ca09e949b993a79c1e6dd9
+DIST xterm-349.tgz 1381911 BLAKE2B 24486676741f138a5b9e98e5b3e213ddd29d83cfed16072f5a1f825f6fe40f72a121bef8e0dfed0aa4c0a912ec4b1ec83f9c9ab2a24a405d7d8de5f3ad1c2451 SHA512 d350671a262973b6486dd9785f84c1f09b6a5e52898ce38d39ed2b11cd8208c473c63c3504533e7e9004af4e690d9032828a14fe6c5474523cfb8ec4badcbd0f
diff --git a/x11-terms/xterm/xterm-349.ebuild b/x11-terms/xterm/xterm-349.ebuild
new file mode 100644
index 000000000000..2055f8804100
--- /dev/null
+++ b/x11-terms/xterm/xterm-349.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop flag-o-matic multilib
+
+DESCRIPTION="Terminal Emulator for X Windows"
+HOMEPAGE="https://invisible-island.net/xterm/"
+SRC_URI="ftp://ftp.invisible-island.net/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+openpty sixel toolbar truetype unicode Xaw3d xinerama"
+
+BDEPEND="virtual/pkgconfig
+ x11-base/xorg-proto"
+DEPEND="kernel_linux? ( sys-libs/libutempter )
+ kernel_FreeBSD? ( || ( >=sys-freebsd/freebsd-lib-9.0 sys-libs/libutempter ) )
+ media-libs/fontconfig:1.0
+ >=sys-libs/ncurses-5.7-r7:0=
+ x11-apps/xmessage
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXft
+ x11-libs/libxkbfile
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ unicode? ( x11-apps/luit )
+ Xaw3d? ( x11-libs/libXaw3d )
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${DEPEND}
+ media-fonts/font-misc-misc
+ x11-apps/rgb"
+
+DOCS=( README{,.i18n} ctlseqs.txt )
+
+pkg_setup() {
+ DEFAULTS_DIR="${EPREFIX}"/usr/share/X11/app-defaults
+}
+
+src_configure() {
+ # 454736
+ # Workaround for ncurses[tinfo] until upstream fixes their buildsystem using
+ # something sane like pkg-config or ncurses5-config and stops guessing libs
+ # Everything gets linked against ncurses anyways, so don't shout
+ append-libs $(pkg-config --libs ncurses)
+
+ local myeconfargs=(
+ --disable-full-tgetent
+ --disable-imake
+ --disable-setgid
+ --disable-setuid
+ --enable-256-color
+ --enable-broken-osc
+ --enable-broken-st
+ --enable-dabbrev
+ --enable-exec-xterm
+ --enable-i18n
+ --enable-load-vt-fonts
+ --enable-logging
+ --enable-screen-dumps
+ --enable-warnings
+ --enable-wide-chars
+ --libdir="${EPREFIX}"/etc
+ --with-app-defaults="${DEFAULTS_DIR}"
+ --with-utempter
+ --with-x
+ $(use_enable openpty)
+ $(use_enable sixel sixel-graphics)
+ $(use_enable toolbar)
+ $(use_enable truetype freetype)
+ $(use_enable unicode luit)
+ $(use_enable unicode mini-luit)
+ $(use_with Xaw3d)
+ $(use_with xinerama)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc xterm.log.html
+ domenu *.desktop
+
+ # Fix permissions -- it grabs them from live system, and they can
+ # be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
+ # respectively (#69510).
+ # (info from Thomas Dickey) - Donnie Berkholz <spyderous@gentoo.org>
+ fperms 0755 /usr/bin/xterm
+
+ # restore the navy blue
+ sed -i -e 's:blue2$:blue:' "${ED}${DEFAULTS_DIR}"/XTerm-color || die
+}