summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-09-11 19:09:13 +0200
committerJeroen Roovers <jer@gentoo.org>2018-09-11 19:09:13 +0200
commit77766779ec401543be785e47f814d38afcf247b6 (patch)
treeddd6eb2e3f9231d6cea700d174b22ffafaa3c842 /x11-terms
parentapp-crypt/bestcrypt: version bump (diff)
downloadgentoo-77766779ec401543be785e47f814d38afcf247b6.tar.gz
gentoo-77766779ec401543be785e47f814d38afcf247b6.tar.bz2
gentoo-77766779ec401543be785e47f814d38afcf247b6.zip
x11-terms/sakura: Version 3.6.0.
Package-Manager: Portage-2.3.49, Repoman-2.3.10
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/sakura/Manifest1
-rw-r--r--x11-terms/sakura/sakura-3.6.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/x11-terms/sakura/Manifest b/x11-terms/sakura/Manifest
index 1ac194a7bd75..e6c31dce20d9 100644
--- a/x11-terms/sakura/Manifest
+++ b/x11-terms/sakura/Manifest
@@ -1 +1,2 @@
DIST sakura-3.5.0.tar.bz2 55432 BLAKE2B 9accd09eac359b64637ff5c318e50e32f5bfa27cf7fb5d4a99c91391e14f145020bd19077e20585b78149e5ac5f281abaf1098dbbaf111e54fd5ad5fbb2f4887 SHA512 20c691342c68a2a6f7397da754c83b19c7622e25984ae9fe9fef47492e19cd7589dd9d1bd2ccb82bd9c6ab82f92c97c1b742795434a101a0e169c6f901f40d9e
+DIST sakura-3.6.0.tar.bz2 56044 BLAKE2B 746de744ad562c4202acf4cb6803917530bde6edb13799630124e64e3e423ee423770cdebd5f8f42b5c2bd56b8863c82eb2015c65b2f168933c87337026c1313 SHA512 4b9d2c15305a2b9a193031194afc0b50deeb32ae52f8b13967801cd57aa71424d7dedf0a9aedf7470aef8b58d8341c85ae37ef67b941b8b97912eb845c5df08f
diff --git a/x11-terms/sakura/sakura-3.6.0.ebuild b/x11-terms/sakura/sakura-3.6.0.ebuild
new file mode 100644
index 000000000000..db76e0ca9c4c
--- /dev/null
+++ b/x11-terms/sakura/sakura-3.6.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit cmake-utils eutils flag-o-matic gnome2-utils xdg-utils
+
+DESCRIPTION="sakura is a terminal emulator based on GTK and VTE"
+HOMEPAGE="http://www.pleyades.net/david/projects/sakura/"
+SRC_URI="https://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+
+RDEPEND="
+ >=dev-libs/glib-2.20:2
+ x11-libs/gtk+:3[X]
+ x11-libs/libX11
+ >x11-libs/vte-0.50:2.91
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-lang/perl-5.10.1
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.3-flags.patch
+)
+
+DOCS=(
+ AUTHORS
+)
+
+src_prepare() {
+ sed -i "/FILES INSTALL/d" CMakeLists.txt || die
+
+ strip-linguas -i po/
+ local lingua
+ for lingua in po/*.po; do
+ lingua="${lingua/po\/}"
+ lingua="${lingua/.po}"
+ if ! has ${lingua} ${LINGUAS}; then
+ rm po/${lingua}.po || die
+ fi
+ done
+
+ cmake-utils_src_prepare
+ # sakura.c:1740:3: warning: implicit declaration of function ‘readlink’
+ # [-Wimplicit-function-declaration]
+ append-cppflags -D_DEFAULT_SOURCE
+
+ # sakura.c:1348:9: error: ‘for’ loop initial declarations are only allowed
+ # in C99 or C11 mode
+ append-cflags -std=c99
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}