summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-02-03 13:26:53 +0100
committerJeroen Roovers <jer@gentoo.org>2019-02-03 13:27:18 +0100
commit562514f8b12d256ca794da6c304448bc21ab22d6 (patch)
tree111f6f0ba1f10ad717fb8a7952f7b019f9eeea8a /x11-themes/greybird
parentnet-analyzer/net-snmp: Live ebuild (diff)
downloadgentoo-562514f8b12d256ca794da6c304448bc21ab22d6.tar.gz
gentoo-562514f8b12d256ca794da6c304448bc21ab22d6.tar.bz2
gentoo-562514f8b12d256ca794da6c304448bc21ab22d6.zip
x11-themes/greybird: Version 3.22.9
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-themes/greybird')
-rw-r--r--x11-themes/greybird/Manifest1
-rw-r--r--x11-themes/greybird/greybird-3.22.9.ebuild55
-rw-r--r--x11-themes/greybird/greybird-9999.ebuild17
-rw-r--r--x11-themes/greybird/metadata.xml17
4 files changed, 76 insertions, 14 deletions
diff --git a/x11-themes/greybird/Manifest b/x11-themes/greybird/Manifest
index e7e6f533bf91..383a3d460159 100644
--- a/x11-themes/greybird/Manifest
+++ b/x11-themes/greybird/Manifest
@@ -1,2 +1,3 @@
DIST greybird-3.20.1.tar.gz 193824 BLAKE2B d4e5cba92e9acf2fd084ee5b1bb5db332bb541193980ee7c74ba98da3b1bb675efd171078fac6051be21d2c2fd03b88f45bf7dff3101ec91578dc28bed212ec9 SHA512 9fe8662fa1c3c9b51aa1ba6d9cb9a54a8e7640386dc43cb695e87ed733a40893067bd86277a03d1c17c48596ba0897a0a41ed48db985727b0d65f2ce2de2227e
DIST greybird-3.22.8.tar.gz 211084 BLAKE2B 958b1dd837bbf91c40ef9ec3e5944d24d83d984e46b53cee8297dbf93931efd3f2efbda496929c3ced875f7a1d9046804b48b870bdca37a7bcffd57271e80470 SHA512 c6ac0dafc926ec2a0b01b4d44f602e533f97f806be32096208c08461502cadcda3f1e63012ad78ffaaa9c791c5af72ce2b7e0578b1f7c0d3ab407763bc40f94b
+DIST greybird-3.22.9.tar.gz 211750 BLAKE2B bfce416c55cc03d1f98c4d14916bcecb6cdc857ed3f813d90cae2a9e92f607d4ae3798d0eb39b0e548f7b4c7964b60d4970c442b91eb78db02772b9a2c02f3a2 SHA512 d09638c78d74e26a428edfbbe00719208fac5e574db11eac2e538d25fa9f3270c9c7b636f770061807a59b200c8afa4252a9513cffe1f4af3d186425b6a14744
diff --git a/x11-themes/greybird/greybird-3.22.9.ebuild b/x11-themes/greybird/greybird-3.22.9.ebuild
new file mode 100644
index 000000000000..3c636128df5a
--- /dev/null
+++ b/x11-themes/greybird/greybird-3.22.9.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+MY_PN=${PN/g/G}
+
+DESCRIPTION="The default theme from Xubuntu"
+HOMEPAGE="http://shimmerproject.org/project/greybird/ https://github.com/shimmerproject/Greybird"
+SRC_URI="https://github.com/shimmerproject/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# README says "dual-licensed as GPLv2 or later and CC-BY-SA 3.0 or later"
+LICENSE="CC-BY-SA-3.0 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ayatana gnome xfce"
+
+RDEPEND="
+ >=x11-libs/gtk+-3.22:3
+ >=x11-themes/gtk-engines-murrine-0.90
+"
+DEPEND="
+ ${RDEPEND}
+ dev-lang/sassc
+ dev-libs/glib:2
+ dev-ruby/sass:3.5
+"
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+
+ pushd "${ED}"/usr/share/themes/${MY_PN} > /dev/null || die
+ use ayatana || rm -rf unity
+ use gnome || rm -rf metacity-1
+ use xfce || rm -rf xfce* xfwm4*
+ popd > /dev/null || die
+}
+
+pkg_postinst() {
+ if ! has_version x11-themes/elementary-xfce-icon-theme ; then
+ elog "For upstream's default icon theme, please emerge"
+ elog "x11-themes/elementary-xfce-icon-theme"
+ fi
+ if ! has_version x11-themes/vanilla-dmz-xcursors ; then
+ elog "For upstream's default cursor theme, please emerge"
+ elog "x11-themes/vanilla-dmz-xcursors"
+ fi
+}
diff --git a/x11-themes/greybird/greybird-9999.ebuild b/x11-themes/greybird/greybird-9999.ebuild
index 395fa8e0a143..5c63ed8b7137 100644
--- a/x11-themes/greybird/greybird-9999.ebuild
+++ b/x11-themes/greybird/greybird-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools git-r3
MY_PN=${PN/g/G}
@@ -14,28 +14,31 @@ EGIT_REPO_URI="https://github.com/shimmerproject/${MY_PN}"
LICENSE="CC-BY-SA-3.0 GPL-2+"
SLOT="0"
KEYWORDS=""
-IUSE="ayatana gnome"
+IUSE="ayatana gnome xfce"
RDEPEND="
>=x11-libs/gtk+-3.22:3
>=x11-themes/gtk-engines-murrine-0.90
"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
+ dev-lang/sassc
dev-libs/glib:2
dev-ruby/sass:3.5
"
src_prepare() {
- eapply_user
+ default
eautoreconf
}
src_install() {
- emake DESTDIR="${D}" install
+ default
- pushd "${ED}"usr/share/themes/${MY_PN} > /dev/null || die
+ pushd "${ED}"/usr/share/themes/${MY_PN} > /dev/null || die
use ayatana || rm -rf unity
use gnome || rm -rf metacity-1
+ use xfce || rm -rf xfce* xfwm4*
popd > /dev/null || die
}
diff --git a/x11-themes/greybird/metadata.xml b/x11-themes/greybird/metadata.xml
index be797ac505ab..ada89e0a62a0 100644
--- a/x11-themes/greybird/metadata.xml
+++ b/x11-themes/greybird/metadata.xml
@@ -1,11 +1,14 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="project">
- <email>desktop-misc@gentoo.org</email>
- <name>Gentoo Desktop Miscellaneous Project</name>
- </maintainer>
- <upstream>
- <remote-id type="github">shimmerproject/Greybird</remote-id>
- </upstream>
+<maintainer type="project">
+<email>desktop-misc@gentoo.org</email>
+<name>Gentoo Desktop Miscellaneous Project</name>
+</maintainer>
+<use>
+<flag name='xfce'>Install theme for <pkg>xfce-base/xfwm4</pkg></flag>
+</use>
+<upstream>
+<remote-id type="github">shimmerproject/Greybird</remote-id>
+</upstream>
</pkgmetadata>