summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-12-03 13:26:20 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-12-03 13:26:31 +0300
commit4e31732cf4886447fbe2915a211adaa9014411d4 (patch)
treef27baf5a77b8fd0ab6a2ccab8a016894e7d51cef /x11-themes
parentdev-python/tox: Fix missing revision in self-dep (diff)
downloadgentoo-4e31732cf4886447fbe2915a211adaa9014411d4.tar.gz
gentoo-4e31732cf4886447fbe2915a211adaa9014411d4.tar.bz2
gentoo-4e31732cf4886447fbe2915a211adaa9014411d4.zip
x11-themes/papirus-icon-theme: Version bump (v20191201)
Package-Manager: Portage-2.3.79, Repoman-2.3.16 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/papirus-icon-theme/Manifest1
-rw-r--r--x11-themes/papirus-icon-theme/papirus-icon-theme-20191201.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/x11-themes/papirus-icon-theme/Manifest b/x11-themes/papirus-icon-theme/Manifest
index 9037927f2dbd..762216791221 100644
--- a/x11-themes/papirus-icon-theme/Manifest
+++ b/x11-themes/papirus-icon-theme/Manifest
@@ -1,2 +1,3 @@
DIST papirus-icon-theme-20191009.tar.gz 18636796 BLAKE2B cb1797468ffb1542fb6b732a0e54cf18b4158bf15ee0fd7f2c7616cba8568876bdfff0247fc1f311d15f064836d7a17916ac14887c3f4132983ebc7e75736668 SHA512 09d259783439721baf68bb5c65cc9cb51af148356e8c8c277ba2f45b5c96358f14defe1bb34db0281cb0cf77023ab54017e0d348de2910648a918a1638ae334f
DIST papirus-icon-theme-20191101.tar.gz 20072061 BLAKE2B 457d47e16ce2c4465c8d23e46bbbc0753351442415be0a8293880d33909beb06b53d4ceb4e13eb2fb4fc1c453c0cc71bb313f7506deba3fec0f98cd47cf75150 SHA512 abbf3c6b248abd6945e7397ea53fe92e645d74918f6fa6f54e3701e560d75e94ac75c2e9d01d5bed7c989af8e14ea9dff4dba018956aaff43291d45fc7ab9e4d
+DIST papirus-icon-theme-20191201.tar.gz 20576688 BLAKE2B 50edc8609b37728ab70e8d5914c37b7860927e7123905546d52ce83a5b8a0bc5a706a536a9734a0fc875504c49b7036ab832f8f6b2587bb31b83213857651cfa SHA512 2faeeea2f0b3efe9b2f18783d5e081199295e03bda021243460daa28bde701b6f0aefb0fa6ba196bc32f44e4af72b7efadedbc377a56b315c2d1c3519c7934a1
diff --git a/x11-themes/papirus-icon-theme/papirus-icon-theme-20191201.ebuild b/x11-themes/papirus-icon-theme/papirus-icon-theme-20191201.ebuild
new file mode 100644
index 000000000000..8afbb557b0ce
--- /dev/null
+++ b/x11-themes/papirus-icon-theme/papirus-icon-theme-20191201.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2-utils
+
+DESCRIPTION="icon theme for Linux"
+HOMEPAGE="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme"
+SRC_URI="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/icons
+ doins -r ePapirus Papirus{,-Dark,-Light}
+
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }