summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2016-12-21 21:13:15 +0000
committerJames Le Cuirot <chewi@gentoo.org>2016-12-21 21:13:15 +0000
commitb088e71ecadd30cd8a358be747dc8c84a2297b87 (patch)
tree24cc35bf7336187a29b63a442c2324ddbb123a4b /x11-themes
parentsys-devel/clang-runtime: Bump to 3.9.1 (diff)
downloadgentoo-b088e71ecadd30cd8a358be747dc8c84a2297b87.tar.gz
gentoo-b088e71ecadd30cd8a358be747dc8c84a2297b87.tar.bz2
gentoo-b088e71ecadd30cd8a358be747dc8c84a2297b87.zip
x11-themes/arc-theme: Version bump to 20161119
Package-Manager: portage-2.3.3
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/arc-theme/Manifest1
-rw-r--r--x11-themes/arc-theme/arc-theme-20161119.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/x11-themes/arc-theme/Manifest b/x11-themes/arc-theme/Manifest
index 6ee9e18d1d20..557c045f1d11 100644
--- a/x11-themes/arc-theme/Manifest
+++ b/x11-themes/arc-theme/Manifest
@@ -1 +1,2 @@
DIST arc-theme-20161005.tar.gz 1457943 SHA256 09167228e286c3decedd2197ed6915d70d8601e7274f81cd368ac097f6c4f7e4 SHA512 cbdb73424f85532d756f2b7ed781fbc49598be44e01715490c0f95a60d7e1ab1c4f58a02f1a60bc9aec7f9625a9b7190ed680888af9c6fdf8a192b935c2ebe33 WHIRLPOOL a0473437ccf23a3634d9bb4c38a77dffa5c6e3295fe4a49e37a3429925496332a5c7f362e892b5f470d227326fa1c10f47de3034aaa8f0fe95a94d1625b705be
+DIST arc-theme-20161119.tar.gz 1534183 SHA256 a470ab33b1ad2b4ba280e61f0e1c4f8d4973ceccc84dc2db1e37fae66b5770cd SHA512 996d8583c4de654dc5979703c85ad3a0eeebef435a264df1b2c8044b9e62f4f74561294a16c5ebf9a213ec5ff7c23f94a360a76502321836bbb83b7396765da0 WHIRLPOOL def6901b2d918afaa95e5630420cb0c65fedb343d49c8900440f6fb888a23b2befd6a47f6802d6012c0dd359edc56ba9a6b75f7f0d6960b97da4f95c489ecc40
diff --git a/x11-themes/arc-theme/arc-theme-20161119.ebuild b/x11-themes/arc-theme/arc-theme-20161119.ebuild
new file mode 100644
index 000000000000..bdf5f23dc93f
--- /dev/null
+++ b/x11-themes/arc-theme/arc-theme-20161119.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A flat theme with transparent elements for GTK+3, GTK+2 and GNOME Shell"
+HOMEPAGE="https://github.com/horst3180/arc-theme"
+SRC_URI="https://github.com/horst3180/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="cinnamon gnome-shell +gtk2 +gtk3 mate xfce"
+
+# Supports various GTK+3 versions and uses pkg-config to determine which
+# set of files to install. Updates will break it but only this fix will
+# help. https://github.com/horst3180/arc-theme/pull/436
+DEPEND="gtk3? ( >=x11-libs/gtk+-3.14:3
+ virtual/pkgconfig )"
+
+# gnome-themes-standard is only needed by GTK+2 for the Adwaita
+# engine. This engine is built into GTK+3.
+RDEPEND="gtk2? ( x11-themes/gnome-themes-standard
+ x11-themes/gtk-engines-murrine )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-unity \
+ $(use_enable cinnamon) \
+ $(use_enable gtk2) \
+ $(use_enable gtk3) \
+ $(use_enable gnome-shell) \
+ $(use_enable mate metacity) \
+ $(use_enable xfce xfwm)
+}