summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/dwm
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/dwm')
-rw-r--r--x11-wm/dwm/Manifest1
-rw-r--r--x11-wm/dwm/dwm-6.0.ebuild79
-rw-r--r--x11-wm/dwm/files/dwm-session211
-rw-r--r--x11-wm/dwm/files/dwm.desktop7
-rw-r--r--x11-wm/dwm/metadata.xml11
5 files changed, 109 insertions, 0 deletions
diff --git a/x11-wm/dwm/Manifest b/x11-wm/dwm/Manifest
new file mode 100644
index 000000000000..228e2786dfe7
--- /dev/null
+++ b/x11-wm/dwm/Manifest
@@ -0,0 +1 @@
+DIST dwm-6.0.tar.gz 20810 SHA256 b2b9483de69259eeea56844899bb2385158d3e79a42d82b10c142099fc8eeb56 SHA512 895d1d363b3756c9ba19dbf06af34be753c1ae5971d540113d7f8901ad174c2e5944ef769b43e65f7b700f34832bb24082bc91d999b287610c9925182ce70c00 WHIRLPOOL bac35d2cb41df313bda2dfd2ca5b12467ec22e41c1640d8d65e67f1e7231baffc96151de03e18d8823918ddd2bdf905a6e0d984592da5cd525e87fb638f0b3dd
diff --git a/x11-wm/dwm/dwm-6.0.ebuild b/x11-wm/dwm/dwm-6.0.ebuild
new file mode 100644
index 000000000000..a5f1dcd0436e
--- /dev/null
+++ b/x11-wm/dwm/dwm-6.0.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils savedconfig toolchain-funcs
+
+DESCRIPTION="a dynamic window manager for X11"
+HOMEPAGE="http://dwm.suckless.org/"
+SRC_URI="http://dl.suckless.org/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
+IUSE="xinerama"
+
+RDEPEND="
+ x11-libs/libX11
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="
+ ${RDEPEND}
+ xinerama? ( x11-proto/xineramaproto )
+"
+
+src_prepare() {
+ sed -i \
+ -e "s/CFLAGS = -std=c99 -pedantic -Wall -Os/CFLAGS += -std=c99 -pedantic -Wall/" \
+ -e "/^LDFLAGS/{s|=|+=|g;s|-s ||g}" \
+ -e "s/#XINERAMALIBS =/XINERAMALIBS ?=/" \
+ -e "s/#XINERAMAFLAGS =/XINERAMAFLAGS ?=/" \
+ -e "s@/usr/X11R6/include@${EPREFIX}/usr/include/X11@" \
+ -e "s@/usr/X11R6/lib@${EPREFIX}/usr/lib@" \
+ -e "s@-I/usr/include@@" -e "s@-L/usr/lib@@" \
+ config.mk || die
+ sed -i \
+ -e '/@echo CC/d' \
+ -e 's|@${CC}|$(CC)|g' \
+ Makefile || die
+
+ restore_config config.h
+ epatch_user
+}
+
+src_compile() {
+ if use xinerama; then
+ emake CC=$(tc-getCC) dwm
+ else
+ emake CC=$(tc-getCC) XINERAMAFLAGS="" XINERAMALIBS="" dwm
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/dwm-session2 dwm
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/dwm.desktop
+
+ dodoc README
+
+ save_config config.h
+}
+
+pkg_postinst() {
+ einfo "This ebuild has support for user defined configs"
+ einfo "Please read this ebuild for more details and re-emerge as needed"
+ einfo "if you want to add or remove functionality for ${PN}"
+ if ! has_version x11-misc/dmenu; then
+ elog "Installing ${PN} without x11-misc/dmenu"
+ einfo "To have a menu you can install x11-misc/dmenu"
+ fi
+ einfo "You can custom status bar with a script in HOME/.dwm/dwmrc"
+ einfo "the ouput is redirected to the standard input of dwm"
+ einfo "Since dwm-5.4, status info in the bar must be set like this:"
+ einfo "xsetroot -name \"\`date\` \`uptime | sed 's/.*,//'\`\""
+}
diff --git a/x11-wm/dwm/files/dwm-session2 b/x11-wm/dwm/files/dwm-session2
new file mode 100644
index 000000000000..f886ce9465f5
--- /dev/null
+++ b/x11-wm/dwm/files/dwm-session2
@@ -0,0 +1,11 @@
+#!/bin/sh
+DIR=${HOME}/.dwm
+if [ -f "${DIR}"/dwmrc ]; then
+ /bin/sh "${DIR}"/dwmrc &
+else
+ while true; do
+ xsetroot -name "`date`"
+ sleep 1
+ done &
+fi
+exec /usr/bin/dwm
diff --git a/x11-wm/dwm/files/dwm.desktop b/x11-wm/dwm/files/dwm.desktop
new file mode 100644
index 000000000000..c31a41297eee
--- /dev/null
+++ b/x11-wm/dwm/files/dwm.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=dwm
+Comment=dynamic window manager
+Exec=/etc/X11/Sessions/dwm
+TryExec=dwm
+Icon=
+Type=Application
diff --git a/x11-wm/dwm/metadata.xml b/x11-wm/dwm/metadata.xml
new file mode 100644
index 000000000000..b6af2b7ba15c
--- /dev/null
+++ b/x11-wm/dwm/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+ <email>michael.stahn.42@gmail.com</email>
+ <name>Michael Stahn</name>
+ <description>Maintainer. Assign bugs to him</description>
+</maintainer>
+<longdescription>dwm is a dynamic window manager for X. It manages windows in tiling and floating modes. Either mode can be applied dynamically, optimizing the environment for the application in use and the task performed.</longdescription>
+</pkgmetadata>