summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-11-17 10:52:33 +0100
committerJohannes Huber <johu@gentoo.org>2018-11-17 10:52:33 +0100
commitc3da12df17dfa8f7959b80fa2cf7c1bb4d269de3 (patch)
treed67d9e912f56a27d368806ce4471eb625e190b3f /x11-wm/i3-gaps
parentdev-libs/qcustomplot: use HTTPS (diff)
downloadgentoo-c3da12df17dfa8f7959b80fa2cf7c1bb4d269de3.tar.gz
gentoo-c3da12df17dfa8f7959b80fa2cf7c1bb4d269de3.tar.bz2
gentoo-c3da12df17dfa8f7959b80fa2cf7c1bb4d269de3.zip
x11-wm/i3-gaps: Version bump 4.16
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Johannes Huber <johu@gentoo.org>
Diffstat (limited to 'x11-wm/i3-gaps')
-rw-r--r--x11-wm/i3-gaps/Manifest1
-rw-r--r--x11-wm/i3-gaps/files/i3-gaps-4.16-musl.patch86
-rw-r--r--x11-wm/i3-gaps/i3-gaps-4.16.ebuild87
3 files changed, 174 insertions, 0 deletions
diff --git a/x11-wm/i3-gaps/Manifest b/x11-wm/i3-gaps/Manifest
index fe96407b1134..302cf42bc0ea 100644
--- a/x11-wm/i3-gaps/Manifest
+++ b/x11-wm/i3-gaps/Manifest
@@ -1 +1,2 @@
DIST i3-gaps-4.15.0.1.tar.gz 3965631 BLAKE2B ea65886c40f377125bafbd80e2d56c1d66a4c5c06d942d645b2cb226323a0903e98aa58b67da9c31c60240b5d99d10ecc20864aeede95a5039ea0ffdff8dcb8b SHA512 76ff860e4ca0edd0e22bdff9ae9b1bc150df2b5bc15b0d7ea7a63d373e8d156a43bd91f8a40c48b4c771603f7de7c18c6d16c53fef582e53f51c53a197fa7a0a
+DIST i3-gaps-4.16.tar.gz 3985226 BLAKE2B da61ab6b476a30a4acab24590cd5ca51f0f51318988890e66530fdd76d99236378d9c678e1e37da99e22e70b0e5e0e5895b8146bd5a93b23957cb1e0178e08b1 SHA512 64a392d2b4175e063f0740ee04885156dbd2571262c22df6276e8eaac36765cd03822723208118a1998ff6cbbcd973fb7f6305df9744c477262d5d33b792ee23
diff --git a/x11-wm/i3-gaps/files/i3-gaps-4.16-musl.patch b/x11-wm/i3-gaps/files/i3-gaps-4.16-musl.patch
new file mode 100644
index 000000000000..1e67ec2a3c4f
--- /dev/null
+++ b/x11-wm/i3-gaps/files/i3-gaps-4.16-musl.patch
@@ -0,0 +1,86 @@
+From: Natanael Copa <ncopa@alpinelinux.org>
+Patch-Source: https://git.alpinelinux.org/cgit/aports/tree/community/i3wm/musl.patch
+Project-Bug-URL: https://github.com/i3/i3/issues/1859
+Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=609306
+
+Musl doesn't implement GLOB_TILDE, which is used by i3 when expanding paths.
+
+This patch replaces usage of GLOB_TILDE in glob() by replacing tilde
+with the content of $HOME - if set - manually.
+
+As mentioned in the i3 bugtracker this is an issue that should be solved by musl.
+
+A patch has been sent to musl upstream, but it hasn't been merged yet:
+http://www.openwall.com/lists/musl/2017/01/17/1
+---
+--- a/i3bar/src/main.c
++++ b/i3bar/src/main.c
+@@ -48,14 +48,20 @@ void debuglog(char *fmt, ...) {
+ *
+ */
+ static char *expand_path(char *path) {
+- static glob_t globbuf;
+- if (glob(path, GLOB_NOCHECK | GLOB_TILDE, NULL, &globbuf) < 0) {
+- ELOG("glob() failed\n");
+- exit(EXIT_FAILURE);
++ char *home, *expanded;
++
++ if (strncmp(path, "~/", 2) == 0) {
++ home = getenv("HOME");
++ if (home != NULL) {
++ /* new length: sum - 1 (omit '~') + 1 (for '\0') */
++ expanded = scalloc(strlen(home)+strlen(path), 1);
++ strcpy(expanded, home);
++ strcat(expanded, path+1);
++ return expanded;
++ }
+ }
+- char *result = sstrdup(globbuf.gl_pathc > 0 ? globbuf.gl_pathv[0] : path);
+- globfree(&globbuf);
+- return result;
++
++ return sstrdup(path);
+ }
+
+ void print_usage(char *elf_name) {
+--- a/libi3/resolve_tilde.c
++++ b/libi3/resolve_tilde.c
+@@ -19,28 +19,18 @@
+ *
+ */
+ char *resolve_tilde(const char *path) {
+- static glob_t globbuf;
+- char *head, *tail, *result;
++ char *home, *expanded;
+
+- tail = strchr(path, '/');
+- head = sstrndup(path, tail ? (size_t)(tail - path) : strlen(path));
+-
+- int res = glob(head, GLOB_TILDE, NULL, &globbuf);
+- free(head);
+- /* no match, or many wildcard matches are bad */
+- if (res == GLOB_NOMATCH || globbuf.gl_pathc != 1)
+- result = sstrdup(path);
+- else if (res != 0) {
+- err(EXIT_FAILURE, "glob() failed");
+- } else {
+- head = globbuf.gl_pathv[0];
+- result = scalloc(strlen(head) + (tail ? strlen(tail) : 0) + 1, 1);
+- strcpy(result, head);
+- if (tail) {
+- strcat(result, tail);
++ if (strncmp(path, "~/", 2) == 0) {
++ home = getenv("HOME");
++ if (home != NULL) {
++ /* new length: sum - 1 (omit '~') + 1 (for '\0') */
++ expanded = scalloc(strlen(home)+strlen(path), 1);
++ strcpy(expanded, home);
++ strcat(expanded, path+1);
++ return expanded;
+ }
+ }
+- globfree(&globbuf);
+
+- return result;
++ return sstrdup(path);
+ }
diff --git a/x11-wm/i3-gaps/i3-gaps-4.16.ebuild b/x11-wm/i3-gaps/i3-gaps-4.16.ebuild
new file mode 100644
index 000000000000..d3e62d0fb172
--- /dev/null
+++ b/x11-wm/i3-gaps/i3-gaps-4.16.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="i3 fork with gaps and some more features"
+HOMEPAGE="https://github.com/Airblader/i3"
+SRC_URI="https://github.com/Airblader/i3/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/libev
+ dev-libs/libpcre
+ dev-libs/yajl
+ x11-libs/cairo[X,xcb]
+ x11-libs/libxcb[xkb]
+ x11-libs/libxkbcommon[X]
+ x11-libs/pango[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+"
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ dev-perl/AnyEvent-I3
+ dev-perl/JSON-XS
+ !x11-wm/i3
+"
+
+S=${WORKDIR}/i3-${PV}
+
+DOCS=( RELEASE-NOTES-$(ver_cut 1-2) )
+
+PATCHES=( "${FILESDIR}/${PN}-$(ver_cut 1-2)-musl.patch" )
+
+src_prepare() {
+ default
+ sed -e '/AC_PATH_PROG(\[PATH_ASCIIDOC/d' -i configure.ac || die
+ eautoreconf
+ cat <<- EOF > "${T}"/i3wm
+ #!/bin/sh
+ exec /usr/bin/i3
+ EOF
+}
+
+src_configure() {
+ # disable sanitizer: otherwise injects -O0 -g
+ local myeconfargs=(
+ --enable-debug=no
+ --disable-sanitizers
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake -C "${CBUILD}"
+}
+
+src_install() {
+ emake -C "${CBUILD}" DESTDIR="${D}" install
+ einstalldocs
+
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/i3wm
+}
+
+pkg_postinst() {
+ einfo "There are several packages that you may find useful with ${PN} and"
+ einfo "their usage is suggested by the upstream maintainers, namely:"
+ einfo " x11-misc/dmenu"
+ einfo " x11-misc/i3lock"
+ einfo " x11-misc/i3status"
+ einfo "Please refer to their description for additional info."
+}