summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-02-08 17:47:18 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-02-08 17:48:20 +0100
commit09ba37cd1123866be583206c63df106e54adab5b (patch)
tree1877bd112ddda718fa14ba84c724c09c76eecb75 /x11-wm/icewm
parentmedia-radio/js8call: bump (diff)
downloadgentoo-09ba37cd1123866be583206c63df106e54adab5b.tar.gz
gentoo-09ba37cd1123866be583206c63df106e54adab5b.tar.bz2
gentoo-09ba37cd1123866be583206c63df106e54adab5b.zip
x11-wm/icewm: Bump to version 1.5.2
Package-Manager: Portage-2.3.59, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-wm/icewm')
-rw-r--r--x11-wm/icewm/Manifest1
-rw-r--r--x11-wm/icewm/icewm-1.5.2.ebuild116
2 files changed, 117 insertions, 0 deletions
diff --git a/x11-wm/icewm/Manifest b/x11-wm/icewm/Manifest
index 6211d8e9072f..b3a4b16c3b1e 100644
--- a/x11-wm/icewm/Manifest
+++ b/x11-wm/icewm/Manifest
@@ -1,3 +1,4 @@
DIST icewm-1.4.2.tar.gz 1709850 BLAKE2B 1a9dde495345f1601b3ae901b3e98554b60a9b9a8e94b7079f3c766971eb31bde5a3cd3972f5c96d86b5e02e413811df2a0689efc15a461bca39a70842f3df69 SHA512 c01661a7b07b4f42a32b20ecc9e45fb1e9c84c27d33105ec165e75aa9ac84129d55e992cac0d53fb10298bae28bc93ef07f68e874c1c2fccd9adecceb987a872
DIST icewm-1.5.0.tar.xz 1660616 BLAKE2B edfcde56b77e57ed1cddb615238d13d568e2e9166a1e487d17693fff8fa6d7e61b17cd0cb7be0611ffcafa03eeea1cdaa2a4dce30cd9a60f760b1302efc1ebe5 SHA512 49d3f6fc8b2073731ae499375352bda73cf0c166067339d5bf09ad900decddf483c60da140ea6a5a607271b7d9cfac44a04dd8c56df18243e35d2ceb100ddff9
DIST icewm-1.5.1.tar.xz 1666056 BLAKE2B 2cd417a9d3097f57cef1bf44b8c4ef4237db962ea5edd8b902338de90d9b28a46aa7f0a720abe87361847836ffd8feb9e0269124260b324ed14b27f0ba7d94b2 SHA512 e7329ccf87da5ad12402c70a3946303f58c76563d25319b9e8f6d153b34a67df0e17612874f8af3bea701b52d15168557842e8ffce0a5a255c59e67bd2022a01
+DIST icewm-1.5.2.tar.xz 1662664 BLAKE2B 612cf919a685a50844b0085d63855a7fdbbd322cb9792fe250420566b1188efc390cfe79fef40386d9328b896f60ba94cc7cc7d87b78866433e2234666ec4206 SHA512 f2a542d162e984dcc6f7b8e3fc2dbd7df46510f961431b4c3b6651351f7b236ef4724a07ce01dfa163b08c9a130e7ee3ed62e1c5b1f364340998d31290323614
diff --git a/x11-wm/icewm/icewm-1.5.2.ebuild b/x11-wm/icewm/icewm-1.5.2.ebuild
new file mode 100644
index 000000000000..abaa3c67fdf2
--- /dev/null
+++ b/x11-wm/icewm/icewm-1.5.2.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Ice Window Manager with Themes"
+HOMEPAGE="https://ice-wm.org/ https://github.com/ice-wm/icewm"
+LICENSE="GPL-2"
+SRC_URI="https://github.com/ice-wm/icewm/releases/download/${PV}/${P}.tar.xz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="+alsa ao bidi debug nls truetype uclibc xinerama"
+
+# Tests broken in all versions, patches welcome, bug #323907, #389533
+RESTRICT="test"
+
+REQUIRED_USE="|| ( alsa ao )"
+
+#fix for icewm preversion package names
+S="${WORKDIR}/${P/_}"
+
+RDEPEND="
+ media-libs/fontconfig
+ x11-libs/gdk-pixbuf:2[X]
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ alsa? (
+ media-libs/alsa-lib
+ media-libs/libsndfile[alsa]
+ )
+ ao? (
+ media-libs/libao
+ media-libs/libsndfile
+ )
+ bidi? ( dev-libs/fribidi )
+ truetype? ( x11-libs/libXext )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="
+ ${RDEPEND}
+ app-text/asciidoc
+ gnome-base/librsvg
+ x11-base/xorg-proto
+ nls? ( >=sys-devel/gettext-0.19.6 )
+ truetype? ( >=media-libs/freetype-2.0.9 )
+"
+
+src_prepare() {
+ # Fix bug #486710 - TODO: Still needed?
+ #use uclibc && PATCHES+=( "${FILESDIR}/${PN}-1.3.8-uclibc.patch" )
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local icesound
+ if use alsa && use ao ; then
+ icesound="alsa,ao"
+ elif use alsa ; then
+ icesound="alsa"
+ elif use ao ; then
+ icesound="ao"
+ fi
+
+ local myconf=(
+ --enable-gdk-pixbuf
+ --enable-logevents
+ --enable-xrandr
+ --enable-xrender
+ --with-cfgdir=/etc/icewm
+ --with-docdir=/usr/share/doc/${PF}/html
+ --with-icesound="${icesound}"
+ --with-libdir=/usr/share/icewm
+ $(use_enable bidi fribidi)
+ $(use_enable debug)
+ $(use_enable nls i18n)
+ $(use_enable nls)
+ $(use_enable xinerama)
+ )
+ if use truetype ; then
+ myconf+=(
+ --enable-shape
+ )
+ else
+ myconf+=(
+ --disable-xfreetype
+ --enable-corefonts
+ )
+ fi
+
+ CXXFLAGS="${CXXFLAGS}" econf "${myconf[@]}"
+
+ sed -i "s:/icewm-\$(VERSION)::" src/Makefile || die
+ sed -i "s:ungif:gif:" src/Makefile || die "libungif fix failed"
+}
+
+src_install(){
+ local DOCS=( AUTHORS ChangeLog NEWS README.md TODO VERSION )
+
+ default
+
+ docinto html
+ dodoc doc/icewm.html
+ dodoc man/*.html
+
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}/icewm"
+}