summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-07-20 12:22:07 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-07-20 12:59:20 -0400
commit1ef43e01397df5cfc6b0c6dd5bc5a259f65df93b (patch)
treeaa92817e3a8fb6342d78798bc03a5dea246fd214 /x11-wm/sawfish
parentprofiles: drop mask for removed sys-auth/pam_keystore (diff)
downloadgentoo-1ef43e01397df5cfc6b0c6dd5bc5a259f65df93b.tar.gz
gentoo-1ef43e01397df5cfc6b0c6dd5bc5a259f65df93b.tar.bz2
gentoo-1ef43e01397df5cfc6b0c6dd5bc5a259f65df93b.zip
x11-wm/sawfish: new version 1.11.90.
We had a few requests for a new version of this (maintainer-needed) package. This commit adds the latest version, and also tries to work around bug 573664 by disabling the kde4session support at configure time. It would have been nice to support kde5session instead, but there's currently a bug (noted in the ebuild) preventing that from happening. Gentoo-Bug: 493110 Gentoo-Bug: 546526 Gentoo-Bug: 573664 Package-Manager: portage-2.2.28
Diffstat (limited to 'x11-wm/sawfish')
-rw-r--r--x11-wm/sawfish/Manifest1
-rw-r--r--x11-wm/sawfish/sawfish-1.11.90.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/x11-wm/sawfish/Manifest b/x11-wm/sawfish/Manifest
index 2a2817dda25..f39fb643997 100644
--- a/x11-wm/sawfish/Manifest
+++ b/x11-wm/sawfish/Manifest
@@ -1 +1,2 @@
DIST sawfish-1.9.1.tar.xz 2616612 SHA256 c1751abf46a52dead8a50fa4b91c09ff0540cb9cc988c76ebfea0bee9edd0618 SHA512 243a818e2cc2546c040f33fbc076bbcc4033b88f0b4be573f9daa80b2dcfd8d9dc97384d236b9b71d6efe08ad39bfd3f3f31b5c055b9b268418efb7668e27a42 WHIRLPOOL 9293221e4a1c7cfddbf5dd619ac9fcd6e8da02723b651e4b62f9baa9e7d7c66d6f0967a960b097c6d9c9f7b7b79de94070733b0e80a1954d9ce477a6187d89fc
+DIST sawfish_1.11.90.tar.xz 2751684 SHA256 734ac2b2781889793e2d846d81f52b8a90707e136bce7b5691c4d12e90ce7cfa SHA512 24735438167c1146e57f82a58876b68b1126d45f237751828ae9603a8eea966058fb6d8fbfddc28e1a96ab774a044b4b9b70b1e299f958b77eb32c987684925e WHIRLPOOL 95ee12896cda57992b2f5cc86ed536a584e265ef793af0840d4738728610f48e235f82b6bc3043d5f2c92d55d2461720725bbc4f292baec8b93fcffe294ecfef
diff --git a/x11-wm/sawfish/sawfish-1.11.90.ebuild b/x11-wm/sawfish/sawfish-1.11.90.ebuild
new file mode 100644
index 00000000000..dc1cd4195b5
--- /dev/null
+++ b/x11-wm/sawfish/sawfish-1.11.90.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils elisp-common
+
+MY_P="${P/-/_}"
+DESCRIPTION="Extensible window manager using a Lisp-based scripting language"
+HOMEPAGE="http://sawfish.wikia.com/"
+SRC_URI="http://download.tuxfamily.org/sawfish/${MY_P}.tar.xz"
+
+LICENSE="GPL-2 Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="emacs nls xinerama"
+
+RDEPEND="emacs? ( virtual/emacs !app-emacs/sawfish )
+ >=dev-libs/librep-0.92.1
+ >=x11-libs/rep-gtk-0.90.7
+ x11-libs/pangox-compat
+ >=x11-libs/gtk+-2.24.0:2
+ x11-libs/libXtst
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( AUTHORS ChangeLog CONTRIBUTING doc/AUTOSTART doc/KEYBINDINGS
+ doc/OPTIONS doc/XSettings MAINTAINERS NEWS README README.IMPORTANT
+ TODO )
+
+src_configure() {
+ # The configure script tries to use kde4-config (bug #573664) or
+ # kf5-config (from kdelibs4support) to detect where it should put
+ # its session files. This could probably be enabled for kde5 going
+ # forward (behind USE=kde), but there's currently a bug in the
+ # configure script preventing that from working nicely:
+ #
+ # https://github.com/SawfishWM/sawfish/issues/22
+ #
+ # For now, we just disable the kde[45] session support entirely.
+ set -- \
+ $(use_with xinerama) \
+ --with-gdk-pixbuf \
+ --without-kde4session \
+ --without-kde5session \
+ --disable-static
+
+ if ! use nls; then
+ # Use a space because configure script reads --enable-linguas=""
+ # as "install everything". Don't use --disable-linguas, because
+ # that means --enable-linguas="no", which means "install
+ # Norwegian translations".
+ set -- "$@" --enable-linguas=" "
+ elif [[ "${LINGUAS+set}" == "set" ]]; then
+ strip-linguas -i po
+ set -- "$@" --enable-linguas=" ${LINGUAS} "
+ else
+ set -- "$@" --enable-linguas=""
+ fi
+
+ econf "$@"
+}
+
+src_compile() {
+ default
+ use emacs && elisp-compile sawfish.el
+}
+
+src_install() {
+ default
+ prune_libtool_files --modules
+
+ if use emacs; then
+ elisp-install ${PN} sawfish.{el,elc}
+ elisp-site-file-install "${FILESDIR}"/50${PN}-gentoo.el
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}