summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2016-02-22 12:57:31 +0100
committerMichael Weber <xmw@gentoo.org>2016-02-22 14:36:15 +0100
commitb15238283f3421b1f749605b2e15fad112beae5e (patch)
tree33d4e1794cc7f9de88d00af1f5dee480a3190a72 /x11-wm/xpra
parentMerge github#905: Update 9 dev-perl/L* ebuilds. (diff)
downloadgentoo-b15238283f3421b1f749605b2e15fad112beae5e.tar.gz
gentoo-b15238283f3421b1f749605b2e15fad112beae5e.tar.bz2
gentoo-b15238283f3421b1f749605b2e15fad112beae5e.zip
x11-wm/xpra: drop old versions.
Package-Manager: portage-2.2.27
Diffstat (limited to 'x11-wm/xpra')
-rw-r--r--x11-wm/xpra/Manifest4
-rw-r--r--x11-wm/xpra/xpra-0.15.10.ebuild115
-rw-r--r--x11-wm/xpra/xpra-0.15.6.ebuild115
-rw-r--r--x11-wm/xpra/xpra-0.15.7.ebuild115
-rw-r--r--x11-wm/xpra/xpra-0.15.8.ebuild115
-rw-r--r--x11-wm/xpra/xpra-0.15.9.ebuild115
6 files changed, 0 insertions, 579 deletions
diff --git a/x11-wm/xpra/Manifest b/x11-wm/xpra/Manifest
index c63a5002f7f..0df381d1683 100644
--- a/x11-wm/xpra/Manifest
+++ b/x11-wm/xpra/Manifest
@@ -1,6 +1,2 @@
DIST xpra-0.14.27.tar.xz 1123504 SHA256 9d51d6e656a9afc6559ec4b671a706ba134257c8e6d909d2514a3ca653502efb SHA512 5f195b211b8e78091ba42661c08f367d66e2a34ebcea9e5df57f0408cf1c4232294d38692171abbfe7396a1da28b2cc4100252dc034872a278530c48282db5cf WHIRLPOOL b14d58cddd03093a598e99d69fb145a5a04347f48fc0ec0b0311efa7bc75f5a51be5db93a361032ead2e021d2c8ead13986a3bd7434108506bbc4b601556141b
DIST xpra-0.15.10.tar.xz 1200040 SHA256 1403aaf571c486bb4a67bc9e9d431e5f863c9b7912bd65e6aec62fcea2d9d4e0 SHA512 add1e63da75b7e29163a7e0957e3f841019c557ba42b15f437ed385de99905cb28a3760386570b72c5d2ba305c5b7779a85ca39d4452ccd6133c26f0a7983d9a WHIRLPOOL a5c50b68b39786aad6c50332340bf421ac17f38948880acb49d55769e8a9b4fb48b068a0fea0e5e660e9621b460eb60d19131600173b826b54a4f7d2e623fb5f
-DIST xpra-0.15.6.tar.xz 1196700 SHA256 cebd8d22d4173610258c835f175ad3781cf49bf91b3d6d3c36c35a825228fa32 SHA512 750b24d06b6af93757e54651c0e5e55192280715c4439e56881824da90dcea25460631c993bf239c6f9023e74dce5063e32688e31c616d036da16fa3da8c304a WHIRLPOOL 66cdc20662ba4251506e03a969332996870e37fe6f60becd3f2feed7b24e1410bc793f5f4679a0dc58940bda52d26563f9db10f8ae3fd83fb60cb89988be38a0
-DIST xpra-0.15.7.tar.xz 1197012 SHA256 b07ed8708023583788de6b5fec579505c2d13fbe96243e9bd0fd696b66ead8e2 SHA512 a75c3299b1f3074556440cc2822557564cf48e6a9c2ea061073ccca0ea204578713ece1e43389d0b808bd02cba9646bd161399661b1d52161e497e4406d029fa WHIRLPOOL e187d25bb6f947b36934f02682ce0d4e091df874f9e3ef25fd261435fd79d3ad5167417ae8e75f167470ac57285d07aa11b6d7d8b51573321569a3a86e2db150
-DIST xpra-0.15.8.tar.xz 1198496 SHA256 e6ca124c89cfa81c8ee69dd2d746cdb0b4d896af6b369e60abc50d2fd2d2a0d2 SHA512 0c23bda2ad2ac2355da1e867f3909e13c2146a5f1b0c4903628e1177edb143fb10a57e8cfaada901bf1df0ec71f87356444856405f0f32f99abc1b655d2de636 WHIRLPOOL abc1e6691f459eea0454df870c0c96bf06b628816e2c283090eac467b6c1fbaf0df6e4f7b229c9eb719acdb8630cb441119ce95b6be2b95ac7385c8a0f5bd2e8
-DIST xpra-0.15.9.tar.xz 1199224 SHA256 bdf51ae3d4114050ff23f7a88fc10af0eb55dd6f74412a6b2c10efeaf6499116 SHA512 83b3452b45a3fa3ea095cef5d2ed901d754903b9aed20cb5a42e0172e9f7058abd88f8635b36adbf314114a4c396a6478e64611273ac61c369332d8590bcef76 WHIRLPOOL 900f5325ebe4ae78b3da214a153961a2c1925ce52f7645ecfcd5254a38f6f942accb263cccfa41eb3b305bef28692ade610e78e17d0c87c1c15b8354656e192b
diff --git a/x11-wm/xpra/xpra-0.15.10.ebuild b/x11-wm/xpra/xpra-0.15.10.ebuild
deleted file mode 100644
index c5ca308f940..00000000000
--- a/x11-wm/xpra/xpra-0.15.10.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI=5
-
-# PyCObject_Check and PyCObject_AsVoidPtr vanished with python 3.3, and setup.py not python3.2 copmat
-PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1 eutils
-
-DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based on wimpiggy"
-HOMEPAGE="http://xpra.org/ http://xpra.org/src/"
-SRC_URI="http://xpra.org/src/${P}.tar.xz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="+client +clipboard csc cups dec_av2 libav opengl pulseaudio server sound vpx webp x264 x265"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- clipboard? ( || ( server client ) )
- opengl? ( client )
- || ( client server )"
-
-# x264/old-libav.path situation see bug 459218
-COMMON_DEPEND=""${PYTHON_DEPS}"
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- x11-libs/gtk+:2
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXdamage
- x11-libs/libXfixes
- x11-libs/libXrandr
- x11-libs/libXtst
- csc? (
- !libav? ( >=media-video/ffmpeg-1.2.2:0= )
- libav? ( media-video/libav:0= )
- )
- dec_av2? (
- !libav? ( >=media-video/ffmpeg-2:0= )
- libav? ( media-video/libav:0= )
- )
- opengl? ( dev-python/pygtkglext )
- pulseaudio? ( media-sound/pulseaudio )
- sound? ( media-libs/gstreamer:0.10
- media-libs/gst-plugins-base:0.10
- dev-python/gst-python:0.10 )
- vpx? ( media-libs/libvpx virtual/ffmpeg )
- webp? ( media-libs/libwebp )
- x264? ( media-libs/x264
- !libav? ( >=media-video/ffmpeg-1.0.4:0= )
- libav? ( media-video/libav:0= )
- )
- x265? ( media-libs/x265
- !libav? ( >=media-video/ffmpeg-2:0= )
- libav? ( media-video/libav:0= )
- )"
-
-RDEPEND="${COMMON_DEPEND}
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/rencode[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- virtual/ssh
- x11-apps/setxkbmap
- x11-apps/xmodmap
- server? ( x11-base/xorg-server[-minimal,xvfb]
- x11-drivers/xf86-input-void
- x11-drivers/xf86-video-dummy
- )"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- >=dev-python/cython-0.16[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- rm -rf rencode || die
-
- epatch \
- "${FILESDIR}"/${PN}-0.13.1-ignore-gentoo-no-compile.patch \
- "${FILESDIR}"/${PN}-0.15.0-prefix.patch
-
- if use libav ; then
- if ! has_version ">=media-video/libav-9" ; then
- epatch patches/old-libav.patch
- fi
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- mydistutilsargs=(
- $(use_with client)
- $(use_with clipboard)
- $(use_with csc csc_swscale)
- $(use_with cups printing)
- $(use_with dec_av2 dec_avcodec2)
- $(use_with opengl)
- $(use_with server shadow)
- $(use_with server)
- $(use_with sound)
- $(use_with vpx)
- $(use_with webp)
- $(use_with x264 enc_x264)
- $(use_with x265 enc_x265)
- --with-Xdummy
- --with-gtk2
- --without-gtk3
- --with-strict
- --with-warn
- --with-x11
- --without-PIC
- --without-debug )
-}
diff --git a/x11-wm/xpra/xpra-0.15.6.ebuild b/x11-wm/xpra/xpra-0.15.6.ebuild
deleted file mode 100644
index 60c3a614a9f..00000000000
--- a/x11-wm/xpra/xpra-0.15.6.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI=5
-
-# PyCObject_Check and PyCObject_AsVoidPtr vanished with python 3.3, and setup.py not python3.2 copmat
-PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1 eutils
-
-DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based on wimpiggy"
-HOMEPAGE="http://xpra.org/ http://xpra.org/src/"
-SRC_URI="http://xpra.org/src/${P}.tar.xz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="+client +clipboard csc cups dec_av2 libav opengl pulseaudio server sound vpx webp x264 x265"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- clipboard? ( || ( server client ) )
- opengl? ( client )
- || ( client server )"
-
-# x264/old-libav.path situation see bug 459218
-COMMON_DEPEND=""${PYTHON_DEPS}"
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- x11-libs/gtk+:2
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXdamage
- x11-libs/libXfixes
- x11-libs/libXrandr
- x11-libs/libXtst
- csc? (
- !libav? ( >=media-video/ffmpeg-1.2.2:0= )
- libav? ( media-video/libav:0= )
- )
- dec_av2? (
- !libav? ( >=media-video/ffmpeg-2:0= )
- libav? ( media-video/libav:0= )
- )
- opengl? ( dev-python/pygtkglext )
- pulseaudio? ( media-sound/pulseaudio )
- sound? ( media-libs/gstreamer:0.10
- media-libs/gst-plugins-base:0.10
- dev-python/gst-python:0.10 )
- vpx? ( media-libs/libvpx virtual/ffmpeg )
- webp? ( media-libs/libwebp )
- x264? ( media-libs/x264
- !libav? ( >=media-video/ffmpeg-1.0.4:0= )
- libav? ( media-video/libav:0= )
- )
- x265? ( media-libs/x265
- !libav? ( >=media-video/ffmpeg-2:0= )
- libav? ( media-video/libav:0= )
- )"
-
-RDEPEND="${COMMON_DEPEND}
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/rencode[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- virtual/ssh
- x11-apps/setxkbmap
- x11-apps/xmodmap
- server? ( x11-base/xorg-server[-minimal,xvfb]
- x11-drivers/xf86-input-void
- x11-drivers/xf86-video-dummy
- )"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- >=dev-python/cython-0.16[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- rm -rf rencode || die
-
- epatch \
- "${FILESDIR}"/${PN}-0.13.1-ignore-gentoo-no-compile.patch \
- "${FILESDIR}"/${PN}-0.15.0-prefix.patch
-
- if use libav ; then
- if ! has_version ">=media-video/libav-9" ; then
- epatch patches/old-libav.patch
- fi
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- mydistutilsargs=(
- $(use_with client)
- $(use_with clipboard)
- $(use_with csc csc_swscale)
- $(use_with cups printing)
- $(use_with dec_av2 dec_avcodec2)
- $(use_with opengl)
- $(use_with server shadow)
- $(use_with server)
- $(use_with sound)
- $(use_with vpx)
- $(use_with webp)
- $(use_with x264 enc_x264)
- $(use_with x265 enc_x265)
- --with-Xdummy
- --with-gtk2
- --without-gtk3
- --with-strict
- --with-warn
- --with-x11
- --without-PIC
- --without-debug )
-}
diff --git a/x11-wm/xpra/xpra-0.15.7.ebuild b/x11-wm/xpra/xpra-0.15.7.ebuild
deleted file mode 100644
index c5ca308f940..00000000000
--- a/x11-wm/xpra/xpra-0.15.7.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI=5
-
-# PyCObject_Check and PyCObject_AsVoidPtr vanished with python 3.3, and setup.py not python3.2 copmat
-PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1 eutils
-
-DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based on wimpiggy"
-HOMEPAGE="http://xpra.org/ http://xpra.org/src/"
-SRC_URI="http://xpra.org/src/${P}.tar.xz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="+client +clipboard csc cups dec_av2 libav opengl pulseaudio server sound vpx webp x264 x265"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- clipboard? ( || ( server client ) )
- opengl? ( client )
- || ( client server )"
-
-# x264/old-libav.path situation see bug 459218
-COMMON_DEPEND=""${PYTHON_DEPS}"
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- x11-libs/gtk+:2
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXdamage
- x11-libs/libXfixes
- x11-libs/libXrandr
- x11-libs/libXtst
- csc? (
- !libav? ( >=media-video/ffmpeg-1.2.2:0= )
- libav? ( media-video/libav:0= )
- )
- dec_av2? (
- !libav? ( >=media-video/ffmpeg-2:0= )
- libav? ( media-video/libav:0= )
- )
- opengl? ( dev-python/pygtkglext )
- pulseaudio? ( media-sound/pulseaudio )
- sound? ( media-libs/gstreamer:0.10
- media-libs/gst-plugins-base:0.10
- dev-python/gst-python:0.10 )
- vpx? ( media-libs/libvpx virtual/ffmpeg )
- webp? ( media-libs/libwebp )
- x264? ( media-libs/x264
- !libav? ( >=media-video/ffmpeg-1.0.4:0= )
- libav? ( media-video/libav:0= )
- )
- x265? ( media-libs/x265
- !libav? ( >=media-video/ffmpeg-2:0= )
- libav? ( media-video/libav:0= )
- )"
-
-RDEPEND="${COMMON_DEPEND}
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/rencode[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- virtual/ssh
- x11-apps/setxkbmap
- x11-apps/xmodmap
- server? ( x11-base/xorg-server[-minimal,xvfb]
- x11-drivers/xf86-input-void
- x11-drivers/xf86-video-dummy
- )"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- >=dev-python/cython-0.16[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- rm -rf rencode || die
-
- epatch \
- "${FILESDIR}"/${PN}-0.13.1-ignore-gentoo-no-compile.patch \
- "${FILESDIR}"/${PN}-0.15.0-prefix.patch
-
- if use libav ; then
- if ! has_version ">=media-video/libav-9" ; then
- epatch patches/old-libav.patch
- fi
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- mydistutilsargs=(
- $(use_with client)
- $(use_with clipboard)
- $(use_with csc csc_swscale)
- $(use_with cups printing)
- $(use_with dec_av2 dec_avcodec2)
- $(use_with opengl)
- $(use_with server shadow)
- $(use_with server)
- $(use_with sound)
- $(use_with vpx)
- $(use_with webp)
- $(use_with x264 enc_x264)
- $(use_with x265 enc_x265)
- --with-Xdummy
- --with-gtk2
- --without-gtk3
- --with-strict
- --with-warn
- --with-x11
- --without-PIC
- --without-debug )
-}
diff --git a/x11-wm/xpra/xpra-0.15.8.ebuild b/x11-wm/xpra/xpra-0.15.8.ebuild
deleted file mode 100644
index c5ca308f940..00000000000
--- a/x11-wm/xpra/xpra-0.15.8.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI=5
-
-# PyCObject_Check and PyCObject_AsVoidPtr vanished with python 3.3, and setup.py not python3.2 copmat
-PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1 eutils
-
-DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based on wimpiggy"
-HOMEPAGE="http://xpra.org/ http://xpra.org/src/"
-SRC_URI="http://xpra.org/src/${P}.tar.xz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="+client +clipboard csc cups dec_av2 libav opengl pulseaudio server sound vpx webp x264 x265"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- clipboard? ( || ( server client ) )
- opengl? ( client )
- || ( client server )"
-
-# x264/old-libav.path situation see bug 459218
-COMMON_DEPEND=""${PYTHON_DEPS}"
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- x11-libs/gtk+:2
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXdamage
- x11-libs/libXfixes
- x11-libs/libXrandr
- x11-libs/libXtst
- csc? (
- !libav? ( >=media-video/ffmpeg-1.2.2:0= )
- libav? ( media-video/libav:0= )
- )
- dec_av2? (
- !libav? ( >=media-video/ffmpeg-2:0= )
- libav? ( media-video/libav:0= )
- )
- opengl? ( dev-python/pygtkglext )
- pulseaudio? ( media-sound/pulseaudio )
- sound? ( media-libs/gstreamer:0.10
- media-libs/gst-plugins-base:0.10
- dev-python/gst-python:0.10 )
- vpx? ( media-libs/libvpx virtual/ffmpeg )
- webp? ( media-libs/libwebp )
- x264? ( media-libs/x264
- !libav? ( >=media-video/ffmpeg-1.0.4:0= )
- libav? ( media-video/libav:0= )
- )
- x265? ( media-libs/x265
- !libav? ( >=media-video/ffmpeg-2:0= )
- libav? ( media-video/libav:0= )
- )"
-
-RDEPEND="${COMMON_DEPEND}
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/rencode[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- virtual/ssh
- x11-apps/setxkbmap
- x11-apps/xmodmap
- server? ( x11-base/xorg-server[-minimal,xvfb]
- x11-drivers/xf86-input-void
- x11-drivers/xf86-video-dummy
- )"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- >=dev-python/cython-0.16[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- rm -rf rencode || die
-
- epatch \
- "${FILESDIR}"/${PN}-0.13.1-ignore-gentoo-no-compile.patch \
- "${FILESDIR}"/${PN}-0.15.0-prefix.patch
-
- if use libav ; then
- if ! has_version ">=media-video/libav-9" ; then
- epatch patches/old-libav.patch
- fi
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- mydistutilsargs=(
- $(use_with client)
- $(use_with clipboard)
- $(use_with csc csc_swscale)
- $(use_with cups printing)
- $(use_with dec_av2 dec_avcodec2)
- $(use_with opengl)
- $(use_with server shadow)
- $(use_with server)
- $(use_with sound)
- $(use_with vpx)
- $(use_with webp)
- $(use_with x264 enc_x264)
- $(use_with x265 enc_x265)
- --with-Xdummy
- --with-gtk2
- --without-gtk3
- --with-strict
- --with-warn
- --with-x11
- --without-PIC
- --without-debug )
-}
diff --git a/x11-wm/xpra/xpra-0.15.9.ebuild b/x11-wm/xpra/xpra-0.15.9.ebuild
deleted file mode 100644
index c5ca308f940..00000000000
--- a/x11-wm/xpra/xpra-0.15.9.ebuild
+++ /dev/null
@@ -1,115 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-EAPI=5
-
-# PyCObject_Check and PyCObject_AsVoidPtr vanished with python 3.3, and setup.py not python3.2 copmat
-PYTHON_COMPAT=( python2_7 )
-inherit distutils-r1 eutils
-
-DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based on wimpiggy"
-HOMEPAGE="http://xpra.org/ http://xpra.org/src/"
-SRC_URI="http://xpra.org/src/${P}.tar.xz"
-
-LICENSE="GPL-2 BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="+client +clipboard csc cups dec_av2 libav opengl pulseaudio server sound vpx webp x264 x265"
-
-REQUIRED_USE="${PYTHON_REQUIRED_USE}
- clipboard? ( || ( server client ) )
- opengl? ( client )
- || ( client server )"
-
-# x264/old-libav.path situation see bug 459218
-COMMON_DEPEND=""${PYTHON_DEPS}"
- dev-python/pygobject:2[${PYTHON_USEDEP}]
- dev-python/pygtk:2[${PYTHON_USEDEP}]
- x11-libs/gtk+:2
- x11-libs/libX11
- x11-libs/libXcomposite
- x11-libs/libXdamage
- x11-libs/libXfixes
- x11-libs/libXrandr
- x11-libs/libXtst
- csc? (
- !libav? ( >=media-video/ffmpeg-1.2.2:0= )
- libav? ( media-video/libav:0= )
- )
- dec_av2? (
- !libav? ( >=media-video/ffmpeg-2:0= )
- libav? ( media-video/libav:0= )
- )
- opengl? ( dev-python/pygtkglext )
- pulseaudio? ( media-sound/pulseaudio )
- sound? ( media-libs/gstreamer:0.10
- media-libs/gst-plugins-base:0.10
- dev-python/gst-python:0.10 )
- vpx? ( media-libs/libvpx virtual/ffmpeg )
- webp? ( media-libs/libwebp )
- x264? ( media-libs/x264
- !libav? ( >=media-video/ffmpeg-1.0.4:0= )
- libav? ( media-video/libav:0= )
- )
- x265? ( media-libs/x265
- !libav? ( >=media-video/ffmpeg-2:0= )
- libav? ( media-video/libav:0= )
- )"
-
-RDEPEND="${COMMON_DEPEND}
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/ipython[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/rencode[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- virtual/ssh
- x11-apps/setxkbmap
- x11-apps/xmodmap
- server? ( x11-base/xorg-server[-minimal,xvfb]
- x11-drivers/xf86-input-void
- x11-drivers/xf86-video-dummy
- )"
-DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
- >=dev-python/cython-0.16[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
- rm -rf rencode || die
-
- epatch \
- "${FILESDIR}"/${PN}-0.13.1-ignore-gentoo-no-compile.patch \
- "${FILESDIR}"/${PN}-0.15.0-prefix.patch
-
- if use libav ; then
- if ! has_version ">=media-video/libav-9" ; then
- epatch patches/old-libav.patch
- fi
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_configure_all() {
- mydistutilsargs=(
- $(use_with client)
- $(use_with clipboard)
- $(use_with csc csc_swscale)
- $(use_with cups printing)
- $(use_with dec_av2 dec_avcodec2)
- $(use_with opengl)
- $(use_with server shadow)
- $(use_with server)
- $(use_with sound)
- $(use_with vpx)
- $(use_with webp)
- $(use_with x264 enc_x264)
- $(use_with x265 enc_x265)
- --with-Xdummy
- --with-gtk2
- --without-gtk3
- --with-strict
- --with-warn
- --with-x11
- --without-PIC
- --without-debug )
-}