summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2020-01-16 12:30:15 +0100
committerAndreas K. Hüttel <dilfridge@gentoo.org>2020-01-16 12:30:46 +0100
commitfd2f00eb3b1c022857d05d7e35d81072827897d9 (patch)
tree440f0f96b6c198e8b918aecfb8c567a7d4574958 /x11-wm/xpra
parentapp-mobilephone/gnokii: Fix autotools issues (diff)
downloadgentoo-fd2f00eb3b1c022857d05d7e35d81072827897d9.tar.gz
gentoo-fd2f00eb3b1c022857d05d7e35d81072827897d9.tar.bz2
gentoo-fd2f00eb3b1c022857d05d7e35d81072827897d9.zip
x11-wm/xpra: Fix bug 702310 with a sledgehammer
We don't have the library that it's looking for packaged anyway, so it doesnt matter whether finding it fails. Make the ldconfig call go away. Closes: https://bugs.gentoo.org/702310 Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'x11-wm/xpra')
-rw-r--r--x11-wm/xpra/files/xpra-3.0.2-ldconfig.patch33
-rw-r--r--x11-wm/xpra/xpra-3.0.2.ebuild13
2 files changed, 38 insertions, 8 deletions
diff --git a/x11-wm/xpra/files/xpra-3.0.2-ldconfig.patch b/x11-wm/xpra/files/xpra-3.0.2-ldconfig.patch
new file mode 100644
index 000000000000..8475d47b8b3c
--- /dev/null
+++ b/x11-wm/xpra/files/xpra-3.0.2-ldconfig.patch
@@ -0,0 +1,33 @@
+diff -ruN xpra-3.0.2.orig/xpra/x11/fakeXinerama.py xpra-3.0.2/xpra/x11/fakeXinerama.py
+--- xpra-3.0.2.orig/xpra/x11/fakeXinerama.py 2019-09-24 15:54:02.000000000 +0200
++++ xpra-3.0.2/xpra/x11/fakeXinerama.py 2020-01-16 12:20:22.620519078 +0100
+@@ -23,29 +23,6 @@
+
+ def find_libfakeXinerama():
+ libname = "fakeXinerama"
+- try:
+- from ctypes.util import find_library
+- flibname = find_library("fakeXinerama")
+- if flibname:
+- libname = flibname
+- except Exception:
+- pass
+- if POSIX:
+- for lib_dir in os.environ.get("LD_LIBRARY_PATH", "/usr/lib").split(os.pathsep):
+- lib_path = os.path.join(lib_dir, libname)
+- if not os.path.exists(lib_dir):
+- continue
+- if os.path.exists(lib_path) and os.path.isfile(lib_path):
+- return lib_path
+- if LINUX:
+- try:
+- libpath = find_lib_ldconfig("fakeXinerama")
+- if libpath:
+- return libpath
+- except Exception as e:
+- log("find_libfakeXinerama()", exc_info=True)
+- log.error("Error: cannot launch ldconfig -p to locate libfakeXinerama:")
+- log.error(" %s", e)
+ return find_lib(libname)
+
+ current_xinerama_config = None
diff --git a/x11-wm/xpra/xpra-3.0.2.ebuild b/x11-wm/xpra/xpra-3.0.2.ebuild
index 97a0b1489c04..2d11aede8cae 100644
--- a/x11-wm/xpra/xpra-3.0.2.ebuild
+++ b/x11-wm/xpra/xpra-3.0.2.ebuild
@@ -86,8 +86,11 @@ DEPEND="${COMMON_DEPEND}
RESTRICT="!test? ( test )"
-PATCHES=( "${FILESDIR}"/${PN}-3.0.2_ignore-gentoo-no-compile.patch
- "${FILESDIR}"/${PN}-2.0-suid-warning.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.0.2_ignore-gentoo-no-compile.patch
+ "${FILESDIR}"/${PN}-2.0-suid-warning.patch
+ "${FILESDIR}"/${PN}-3.0.2-ldconfig.patch
+)
pkg_postinst() {
enewgroup ${PN}
@@ -151,9 +154,3 @@ python_configure_all() {
export XPRA_SOCKET_DIRS="${EPREFIX}/run/xpra"
}
-
-src_compile() {
- # xpra calls `ldconfig -p` during compile to locate libraries.
- addpredict /etc
- distutils-r1_src_compile
-}