summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-07-07 13:40:07 +0200
committerJohannes Huber <johu@gentoo.org>2018-07-07 13:40:07 +0200
commit58b9c904790f0c34215d81d2fa65974d811d9da3 (patch)
tree2ba3f7322b4a0920726e7a028a5389050237c744 /x11-wm
parentmedia-plugins/vdr-live: fixed load shared lib (diff)
downloadgentoo-58b9c904790f0c34215d81d2fa65974d811d9da3.tar.gz
gentoo-58b9c904790f0c34215d81d2fa65974d811d9da3.tar.bz2
gentoo-58b9c904790f0c34215d81d2fa65974d811d9da3.zip
x11-wm/dwm: Remove 6.1 (r0)
Uses deprecated EAPI 5 and overshadowed by 6.1-r1. Package-Manager: Portage-2.3.41, Repoman-2.3.9
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/dwm/dwm-6.1.ebuild81
1 files changed, 0 insertions, 81 deletions
diff --git a/x11-wm/dwm/dwm-6.1.ebuild b/x11-wm/dwm/dwm-6.1.ebuild
deleted file mode 100644
index d8a03b2546df..000000000000
--- a/x11-wm/dwm/dwm-6.1.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit eutils savedconfig toolchain-funcs
-
-DESCRIPTION="a dynamic window manager for X11"
-HOMEPAGE="https://dwm.suckless.org/"
-SRC_URI="https://dl.suckless.org/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ppc ppc64 x86 ~x86-fbsd"
-IUSE="xinerama"
-
-RDEPEND="
- media-libs/fontconfig
- x11-libs/libX11
- x11-libs/libXft
- xinerama? ( x11-libs/libXinerama )
-"
-DEPEND="
- ${RDEPEND}
- xinerama? ( x11-base/xorg-proto )
-"
-
-src_prepare() {
- sed -i \
- -e "s/CFLAGS = -std=c99 -pedantic -Wall -Os/CFLAGS += -std=c99 -pedantic -Wall/" \
- -e "/^LDFLAGS/{s|=|+=|g;s|-s ||g}" \
- -e "s/#XINERAMALIBS =/XINERAMALIBS ?=/" \
- -e "s/#XINERAMAFLAGS =/XINERAMAFLAGS ?=/" \
- -e "s@/usr/X11R6/include@${EPREFIX}/usr/include/X11@" \
- -e "s@/usr/X11R6/lib@${EPREFIX}/usr/lib@" \
- -e "s@-I/usr/include@@" -e "s@-L/usr/lib@@" \
- -e "s/\/freetype2/\ -I\/usr\/include\/freetype2/" \
- config.mk || die
- sed -i \
- -e '/@echo CC/d' \
- -e 's|@${CC}|$(CC)|g' \
- Makefile || die
-
- restore_config config.h
- epatch_user
-}
-
-src_compile() {
- if use xinerama; then
- emake CC=$(tc-getCC) dwm
- else
- emake CC=$(tc-getCC) XINERAMAFLAGS="" XINERAMALIBS="" dwm
- fi
-}
-
-src_install() {
- emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
-
- exeinto /etc/X11/Sessions
- newexe "${FILESDIR}"/dwm-session2 dwm
-
- insinto /usr/share/xsessions
- doins "${FILESDIR}"/dwm.desktop
-
- dodoc README
-
- save_config config.h
-}
-
-pkg_postinst() {
- einfo "This ebuild has support for user defined configs"
- einfo "Please read this ebuild for more details and re-emerge as needed"
- einfo "if you want to add or remove functionality for ${PN}"
- if ! has_version x11-misc/dmenu; then
- elog "Installing ${PN} without x11-misc/dmenu"
- einfo "To have a menu you can install x11-misc/dmenu"
- fi
- einfo "You can custom status bar with a script in HOME/.dwm/dwmrc"
- einfo "the ouput is redirected to the standard input of dwm"
- einfo "Since dwm-5.4, status info in the bar must be set like this:"
- einfo "xsetroot -name \"\`date\` \`uptime | sed 's/.*,//'\`\""
-}