summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2016-03-07 20:10:50 -0600
committerKacper Kowalik <xarthisius@gentoo.org>2016-03-07 20:11:57 -0600
commitc28560d3da197cb22026c308aab16a56b87ed4f1 (patch)
tree19398749d001d90adc2a0d95c259b97c16feb755 /x11-wm
parentx11-wm/awesome: bump. (diff)
downloadgentoo-c28560d3da197cb22026c308aab16a56b87ed4f1.tar.gz
gentoo-c28560d3da197cb22026c308aab16a56b87ed4f1.tar.bz2
gentoo-c28560d3da197cb22026c308aab16a56b87ed4f1.zip
x11-wm/i3: fix build without cairo/pango, correct dep on cairo version
Fixes bug #576664 Reported-by: Coacher <itumaykin+gentoo@gmail.com> Package-Manager: portage-2.2.27
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/i3/files/i3-4.12-pango.patch181
-rw-r--r--x11-wm/i3/i3-4.12.ebuild19
2 files changed, 197 insertions, 3 deletions
diff --git a/x11-wm/i3/files/i3-4.12-pango.patch b/x11-wm/i3/files/i3-4.12-pango.patch
new file mode 100644
index 000000000000..6442796cae78
--- /dev/null
+++ b/x11-wm/i3/files/i3-4.12-pango.patch
@@ -0,0 +1,181 @@
+Fixes builds with without pango/cairo
+
+https://github.com/i3/i3/pull/2243
+https://bugs.gentoo.org/show_bug.cgi?id=576664
+
+--- a/include/libi3.h
++++ b/include/libi3.h
+@@ -20,7 +20,7 @@
+ #if PANGO_SUPPORT
+ #include <pango/pango.h>
+ #endif
+-#ifdef CAIRO_SUPPORT
++#if CAIRO_SUPPORT
+ #include <cairo/cairo-xcb.h>
+ #endif
+
+@@ -518,7 +518,7 @@ typedef struct placeholder_t {
+ */
+ char *format_placeholders(char *format, placeholder_t *placeholders, int num);
+
+-#ifdef CAIRO_SUPPORT
++#if CAIRO_SUPPORT
+ /* We need to flush cairo surfaces twice to avoid an assertion bug. See #1989
+ * and https://bugs.freedesktop.org/show_bug.cgi?id=92455. */
+ #define CAIRO_SURFACE_FLUSH(surface) \
+@@ -542,7 +542,7 @@ typedef struct surface_t {
+ int width;
+ int height;
+
+-#ifdef CAIRO_SUPPORT
++#if CAIRO_SUPPORT
+ /* A cairo surface representing the drawable. */
+ cairo_surface_t *surface;
+
+--- a/libi3/draw_util.c
++++ b/libi3/draw_util.c
+@@ -11,7 +11,7 @@
+ #include <string.h>
+ #include <xcb/xcb.h>
+ #include <xcb/xcb_aux.h>
+-#ifdef CAIRO_SUPPORT
++#if CAIRO_SUPPORT
+ #include <cairo/cairo-xcb.h>
+ #endif
+
+@@ -50,7 +50,7 @@ void draw_util_surface_init(xcb_connection_t *conn, surface_t *surface, xcb_draw
+ ELOG("Could not create graphical context. Error code: %d. Please report this bug.\n", error->error_code);
+ }
+
+-#ifdef CAIRO_SUPPORT
++#if CAIRO_SUPPORT
+ surface->surface = cairo_xcb_surface_create(conn, surface->id, surface->visual_type, width, height);
+ surface->cr = cairo_create(surface->surface);
+ #endif
+@@ -62,7 +62,7 @@ void draw_util_surface_init(xcb_connection_t *conn, surface_t *surface, xcb_draw
+ */
+ void draw_util_surface_free(xcb_connection_t *conn, surface_t *surface) {
+ xcb_free_gc(conn, surface->gc);
+-#ifdef CAIRO_SUPPORT
++#if CAIRO_SUPPORT
+ cairo_surface_destroy(surface->surface);
+ cairo_destroy(surface->cr);
+
+@@ -81,7 +81,7 @@ void draw_util_surface_free(xcb_connection_t *conn, surface_t *surface) {
+ void draw_util_surface_set_size(surface_t *surface, int width, int height) {
+ surface->width = width;
+ surface->height = height;
+-#ifdef CAIRO_SUPPORT
++#if CAIRO_SUPPORT
+ cairo_xcb_surface_set_size(surface->surface, width, height);
+ #endif
+ }
+@@ -121,7 +121,7 @@ color_t draw_util_hex_to_color(const char *color) {
+ static void draw_util_set_source_color(xcb_connection_t *conn, surface_t *surface, color_t color) {
+ RETURN_UNLESS_SURFACE_INITIALIZED(surface);
+
+-#ifdef CAIRO_SUPPORT
++#if CAIRO_SUPPORT
+ cairo_set_source_rgba(surface->cr, color.red, color.green, color.blue, color.alpha);
+ #else
+ uint32_t colorpixel = color.colorpixel;
+@@ -139,7 +139,7 @@ static void draw_util_set_source_color(xcb_connection_t *conn, surface_t *surfac
+ void draw_util_text(i3String *text, surface_t *surface, color_t fg_color, color_t bg_color, int x, int y, int max_width) {
+ RETURN_UNLESS_SURFACE_INITIALIZED(surface);
+
+-#ifdef CAIRO_SUPPORT
++#if CAIRO_SUPPORT
+ /* Flush any changes before we draw the text as this might use XCB directly. */
+ CAIRO_SURFACE_FLUSH(surface->surface);
+ #endif
+@@ -147,7 +147,7 @@ void draw_util_text(i3String *text, surface_t *surface, color_t fg_color, color_
+ set_font_colors(surface->gc, fg_color, bg_color);
+ draw_text(text, surface->id, surface->gc, surface->visual_type, x, y, max_width);
+
+-#ifdef CAIRO_SUPPORT
++#if CAIRO_SUPPORT
+ /* Notify cairo that we (possibly) used another way to draw on the surface. */
+ cairo_surface_mark_dirty(surface->surface);
+ #endif
+@@ -162,7 +162,7 @@ void draw_util_text(i3String *text, surface_t *surface, color_t fg_color, color_
+ void draw_util_rectangle(xcb_connection_t *conn, surface_t *surface, color_t color, double x, double y, double w, double h) {
+ RETURN_UNLESS_SURFACE_INITIALIZED(surface);
+
+-#ifdef CAIRO_SUPPORT
++#if CAIRO_SUPPORT
+ cairo_save(surface->cr);
+
+ /* Using the SOURCE operator will copy both color and alpha information directly
+@@ -194,7 +194,7 @@ void draw_util_rectangle(xcb_connection_t *conn, surface_t *surface, color_t col
+ void draw_util_clear_surface(xcb_connection_t *conn, surface_t *surface, color_t color) {
+ RETURN_UNLESS_SURFACE_INITIALIZED(surface);
+
+-#ifdef CAIRO_SUPPORT
++#if CAIRO_SUPPORT
+ cairo_save(surface->cr);
+
+ /* Using the SOURCE operator will copy both color and alpha information directly
+@@ -227,7 +227,7 @@ void draw_util_copy_surface(xcb_connection_t *conn, surface_t *src, surface_t *d
+ RETURN_UNLESS_SURFACE_INITIALIZED(src);
+ RETURN_UNLESS_SURFACE_INITIALIZED(dest);
+
+-#ifdef CAIRO_SUPPORT
++#if CAIRO_SUPPORT
+ cairo_save(dest->cr);
+
+ /* Using the SOURCE operator will copy both color and alpha information directly
+--- a/libi3/font.c
++++ b/libi3/font.c
+@@ -397,9 +397,11 @@ static void draw_text_xcb(const xcb_char2b_t *text, size_t text_len, xcb_drawabl
+ void draw_text(i3String *text, xcb_drawable_t drawable, xcb_gcontext_t gc,
+ xcb_visualtype_t *visual, int x, int y, int max_width) {
+ assert(savedFont != NULL);
++#if PANGO_SUPPORT
+ if (visual == NULL) {
+ visual = root_visual_type;
+ }
++#endif
+
+ switch (savedFont->type) {
+ case FONT_TYPE_NONE:
+--- a/src/floating.c
++++ b/src/floating.c
+@@ -11,6 +11,10 @@
+ */
+ #include "all.h"
+
++#ifndef MAX
++#define MAX(x, y) ((x) > (y) ? (x) : (y))
++#endif
++
+ /*
+ * Calculates sum of heights and sum of widths of all currently active outputs
+ *
+--- a/src/util.c
++++ b/src/util.c
+@@ -341,10 +341,12 @@ char *pango_escape_markup(char *input) {
+ if (!font_is_pango())
+ return input;
+
++#if PANGO_SUPPORT
+ char *escaped = g_markup_escape_text(input, -1);
+ FREE(input);
+
+ return escaped;
++#endif
+ }
+
+ /*
+--- a/src/x.c
++++ b/src/x.c
+@@ -12,6 +12,10 @@
+ */
+ #include "all.h"
+
++#ifndef MAX
++#define MAX(x, y) ((x) > (y) ? (x) : (y))
++#endif
++
+ xcb_window_t ewmh_window;
+
+ /* Stores the X11 window ID of the currently focused window */
diff --git a/x11-wm/i3/i3-4.12.ebuild b/x11-wm/i3/i3-4.12.ebuild
index eabd399c705b..361c0a9f5b66 100644
--- a/x11-wm/i3/i3-4.12.ebuild
+++ b/x11-wm/i3/i3-4.12.ebuild
@@ -13,7 +13,8 @@ SRC_URI="http://i3wm.org/downloads/${P}.tar.bz2"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="+pango"
+IUSE="+cairo +pango"
+REQUIRED_USE="pango? ( cairo )"
CDEPEND="dev-libs/libev
dev-libs/libpcre
@@ -25,9 +26,11 @@ CDEPEND="dev-libs/libev
x11-libs/xcb-util-cursor
x11-libs/xcb-util-keysyms
x11-libs/xcb-util-wm
+ cairo? (
+ >=x11-libs/cairo-1.14.4[X,xcb]
+ )
pango? (
>=x11-libs/pango-1.30.0[X]
- >=x11-libs/cairo-1.12.2[X,xcb]
)"
DEPEND="${CDEPEND}
virtual/pkgconfig"
@@ -39,8 +42,18 @@ RDEPEND="${CDEPEND}
DOCS=( RELEASE-NOTES-${PV} )
src_prepare() {
+ epatch "${FILESDIR}"/${P}-pango.patch
+
if ! use pango; then
- sed -i common.mk -e '/PANGO/d' || die
+ sed -e '/^PANGO_.*pangocairo/d' \
+ -e '/PANGO_SUPPORT/ s/1/0/g' \
+ -i common.mk || die
+ fi
+
+ if ! use cairo; then
+ sed -e '/^PANGO_.*cairo/d' \
+ -e '/CAIRO_SUPPORT/ s/1/0/g' \
+ -i common.mk || die
fi
cat <<- EOF > "${T}"/i3wm