summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-01-16 22:32:16 -0500
committerTim Harder <radhermit@gentoo.org>2016-01-16 22:34:21 -0500
commitd1ea5654008d8c8f66c04d68c5ea1f2700ab2e03 (patch)
treebfd9aa67f55f1cf87ae363d2c45bec8bd40e8485 /x11-wm
parentdev-python/cairocffi: add py3.5 support (diff)
downloadgentoo-d1ea5654008d8c8f66c04d68c5ea1f2700ab2e03.tar.gz
gentoo-d1ea5654008d8c8f66c04d68c5ea1f2700ab2e03.tar.bz2
gentoo-d1ea5654008d8c8f66c04d68c5ea1f2700ab2e03.zip
x11-wm/qtile: version bump to 0.10.2
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/qtile/Manifest1
-rw-r--r--x11-wm/qtile/qtile-0.10.2.ebuild56
-rw-r--r--x11-wm/qtile/qtile-9999.ebuild4
3 files changed, 59 insertions, 2 deletions
diff --git a/x11-wm/qtile/Manifest b/x11-wm/qtile/Manifest
index 1d8be709b203..30d4494f4acb 100644
--- a/x11-wm/qtile/Manifest
+++ b/x11-wm/qtile/Manifest
@@ -1,5 +1,6 @@
DIST qtile-0.10.0.tar.gz 300186 SHA256 d340b1f6df8d78e1f8868ad22862056ed38267fd2e44538361449e6079412948 SHA512 198d572b27f1e1c7636c7cb0ff5751494c72e919259c67e08eecc0c8c64018d1b64df66840146fada4f128ac69a9fa6b8c39572473ff6c4addee609011b7bc28 WHIRLPOOL 05564ec65d7d96b0dc6085e346f071b7d803017d1c23ce24d1312b036c5c36dbf24308ad634553c8c462695f423d52c30f00d21d572e3609d32ea446bf2489a1
DIST qtile-0.10.1.tar.gz 300217 SHA256 24fc598ca73d2e95ddf4bc29cbfb638253696dafba0ffaaadb103392d248fe96 SHA512 dec5555107d5b99dea21cf95ba3a79fb1a0c6a7628d26abab5bcedbd1898664b477c4e2fe03885d7d27abd757908878d46ace33ca20e94ba04dba41e742dd52b WHIRLPOOL 455f5bb6bf885e7e403100cae7c839482a6e9236f237ae0d71a52e9064ec15a335462653a6ed8dd9c128606090fc4bfe230e54492efe47f1bc65460e0a781dac
+DIST qtile-0.10.2.tar.gz 310115 SHA256 ce4cc2661d089c21aa4537302cdc72ddce02d1ce07c62002080f4fa6c50f2ce2 SHA512 047fed98c447c65bdc3499adc678f49920f47f5167f65a85407f60d4e180159a8657f8483b8e19db4de1db876e621182e691aa70728ac7cc4abfa096b67a45e6 WHIRLPOOL 37f81d2eb60249168c94c29be8fafc611f4b7f1ed43c5288df9f7033e917425a04c96c40dba70d09045da18bae8ac6ec8b2700add61820bd66654c65a485da74
DIST qtile-0.5.tar.gz 317041 SHA256 f80cd73d6655ab53baa6ae11afb9561f724515052e4ba570e6e978abc78c1167 SHA512 2af8a13dcc355b4f556e77a7c78235eb39e9112631750d6680cc1d96c7895ffd3c8ac937ec8b796f4e3f841d39b10aafb930b440addfd8e2fc951e2010e3dc98 WHIRLPOOL d88f70906de570d129aae38ff9ca7a829aa1d9b6d61a179a0cf4ad798d9314c9364a905739168a60b9c37384c13034172920c76cef0981a26df04544e94fe472
DIST qtile-0.6.tar.gz 257000 SHA256 73508a5ff18579091434131c54aaa3fd4413abe9df4b56962dcbcb6196f1bb36 SHA512 512961f6a47d52d055fe1f7889a5e0c00fe95c55c25f88d1c0d0d3b0253a65579dcbe2cd5c17e04d8a5533e0befc7548c459d64961e2f11f3944803de29e1c25 WHIRLPOOL 5daa3c1464f714c633ac58bb5d56ddcfb8949850475ed155e03eb1ec444c002e4b4f47a3637d2c4e510fea94d69ef1cdc4c8e647bc29dcd62cffb1b95c2326fe
DIST qtile-0.7.0.tar.gz 265068 SHA256 12bb01dd30d65ed44994f17c2a0e2803b34c108108ac2085aa81e3cd8f3264d9 SHA512 facd319a979bf5dd2ec9c336a203dce197678bcaf02df3208e0ff49cd254683242a76c884f1dccda1689a421a680834aa4194f250e93bbfcf048119148730171 WHIRLPOOL 18024c465cce95f703e2d9bf25f4d4a68197f0429a2c0edadf2e34807127b8248ed80408515ff9d254eb026853350e9291c1da719fe5144608f35eb002c3b26c
diff --git a/x11-wm/qtile/qtile-0.10.2.ebuild b/x11-wm/qtile/qtile-0.10.2.ebuild
new file mode 100644
index 000000000000..4a120e2442d6
--- /dev/null
+++ b/x11-wm/qtile/qtile-0.10.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 virtualx
+
+if [[ ${PV} == 9999* ]] ; then
+ EGIT_REPO_URI="https://github.com/qtile/qtile.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/qtile/qtile/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A full-featured, hackable tiling window manager written in Python"
+HOMEPAGE="http://qtile.org/"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+# docs require sphinxcontrib-blockdiag and sphinxcontrib-seqdiag
+
+RDEPEND="x11-libs/pango
+ >=dev-python/cairocffi-0.7[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+ >=dev-python/xcffib-0.3.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' 'python2*')
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ x11-base/xorg-server[kdrive]
+ )
+"
+
+RESTRICT="test"
+
+python_test() {
+ VIRTUALX_COMMAND="nosetests" virtualmake
+}
+
+python_install_all() {
+ local DOCS=( CHANGELOG README.rst )
+ distutils-r1_python_install_all
+
+ insinto /usr/share/xsessions
+ doins resources/qtile.desktop
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/${PN}-session ${PN}
+}
diff --git a/x11-wm/qtile/qtile-9999.ebuild b/x11-wm/qtile/qtile-9999.ebuild
index b59d1b106ae2..4a120e2442d6 100644
--- a/x11-wm/qtile/qtile-9999.ebuild
+++ b/x11-wm/qtile/qtile-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} )
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
inherit distutils-r1 virtualx