summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-09-23 18:50:06 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-30 13:52:02 +0200
commite0dcb076974be636827fd2ecb817ba9cfc7f0ee5 (patch)
treeba93d94af83736f9b0875a129b0080a1c4bd7a8a /x11-wm
parentapp-admin/chroot_safe: EAPI7 revbump, improve ebuild (diff)
downloadgentoo-e0dcb076974be636827fd2ecb817ba9cfc7f0ee5.tar.gz
gentoo-e0dcb076974be636827fd2ecb817ba9cfc7f0ee5.tar.bz2
gentoo-e0dcb076974be636827fd2ecb817ba9cfc7f0ee5.zip
x11-wm/larswm: EAPI7 revbump, fix HOMEPAGE, SRC_URI
Closes: https://bugs.gentoo.org/666886 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/9956
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/larswm/larswm-7.5.3-r2.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/x11-wm/larswm/larswm-7.5.3-r2.ebuild b/x11-wm/larswm/larswm-7.5.3-r2.ebuild
new file mode 100644
index 000000000000..84b61cef262f
--- /dev/null
+++ b/x11-wm/larswm/larswm-7.5.3-r2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tiling window manager for X11, based on 9wm by David Hogan"
+HOMEPAGE="http://www.fnurt.net/larswm/"
+SRC_URI="http://www.fnurt.net/larswm/${P}.tar.gz"
+LICENSE="9wm"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-misc/imake
+ x11-misc/gccmakedep
+ app-text/rman"
+
+src_configure() {
+ xmkmf -a || die
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CCOPTIONS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin larsclock larsmenu larsremote larswm
+ newbin sample.xsession larswm-session
+ local x
+ for x in *.man; do
+ newman ${x} ${x/man/1}
+ done
+ dodoc ChangeLog README* sample.*
+
+ insinto /etc/X11
+ newins sample.larswmrc larswmrc
+ exeinto /etc/X11/Sessions
+ newexe sample.xsession larswm
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/larswm.desktop
+}