summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-06-06 09:48:38 +0200
committerMichał Górny <mgorny@gentoo.org>2017-06-07 22:06:31 +0200
commit379df5fa8b1208b3876398def6c15e820701c37e (patch)
tree3c1497c57b3a34b1d2aafac13e45f54268c37e78 /xfce-base/xfconf
parentxfce-extra/tumbler: Bump to 0.1.32 (stable bugfix) (diff)
downloadgentoo-379df5fa8b1208b3876398def6c15e820701c37e.tar.gz
gentoo-379df5fa8b1208b3876398def6c15e820701c37e.tar.bz2
gentoo-379df5fa8b1208b3876398def6c15e820701c37e.zip
xfce-base/xfconf: Bump to 4.13.1, EAPI=6, fix tests
Diffstat (limited to 'xfce-base/xfconf')
-rw-r--r--xfce-base/xfconf/Manifest1
-rw-r--r--xfce-base/xfconf/xfconf-4.13.1.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/xfce-base/xfconf/Manifest b/xfce-base/xfconf/Manifest
index 0f94d4c693dc..5c7ae17b32ab 100644
--- a/xfce-base/xfconf/Manifest
+++ b/xfce-base/xfconf/Manifest
@@ -1,2 +1,3 @@
DIST xfconf-4.12.0.tar.bz2 542544 SHA256 9910eaea8405336415d4d7f3056403f8c67bc23ba0dce251eac35205c603b156 SHA512 60cc37a7207b0486f7f2de665870facf8e339241df344d7540082f3db447b3ac88bddd306d6a09a3868878cb477d1696491c71470052ef56cb649d773bd55b56 WHIRLPOOL 73241764a03c865c3bcda97a481e4ed9c6bfd8a3fdfd1a614291abad32f11157ba50a14d0ef918ad3c397fdd015d3dcf0cd07e24e43fbdd5125d5c273d536c16
DIST xfconf-4.12.1.tar.bz2 564131 SHA256 35f48564e5694faa54fdc180cd3268e16fc2352946a89a3c2fc12cbe400ada36 SHA512 114dba6a78d43b25eebfd9ef78beec75391b0c77e736e66ae2b04fe97dc281f93d05467ddfdd63a5067f44de135347564fe55928ae7de72f0984339db411d77f WHIRLPOOL 17ccadbf9759cf2c84f09f58f0f3c65a49a4dab3965a1deb7a42d5635075b4d60dc96556d0cc80d8b8df8c91bae51d9e3864409020b32058694d15f340d3f9c1
+DIST xfconf-4.13.1.tar.bz2 584229 SHA256 17f1ffff49f8f0cdbd4f3c8fb7869015c57a5bc6ba1c842faade6d6ec75fea5b SHA512 94504c71be3e98f635f20ab840a04aea08118962a9415a88bcdabf3960b3ba0b6f90a5c89b515bfef5bd5850738370ac885411ce3f4ecde944ca4e7976728080 WHIRLPOOL 95db672eec632aa3a2b74860ad88293ce7259956e08860c498e7141311224e1630f7d09b0568fb4508e398dffe5b280c837c9fcf7c412979ee235e198a33bd5c
diff --git a/xfce-base/xfconf/xfconf-4.13.1.ebuild b/xfce-base/xfconf/xfconf-4.13.1.ebuild
new file mode 100644
index 000000000000..3e2ada0e1a3c
--- /dev/null
+++ b/xfce-base/xfconf/xfconf-4.13.1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit virtualx xdg-utils
+
+DESCRIPTION="A flexible, easy-to-use configuration management system for Xfce"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="debug perl"
+
+RDEPEND=">=dev-libs/glib-2.30:=
+ >=xfce-base/libxfce4util-4.10:=
+ perl? (
+ dev-lang/perl:=[-build(-)]
+ dev-perl/glib-perl
+ )"
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+ perl? (
+ dev-perl/ExtUtils-Depends
+ dev-perl/ExtUtils-PkgConfig
+ )"
+
+src_configure() {
+ local myconf=(
+ $(use_enable perl perl-bindings)
+ $(use_enable debug checks)
+ --with-perl-options=INSTALLDIRS=vendor
+ )
+
+ xdg_environment_reset
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake OTHERLDFLAGS="${LDFLAGS}"
+}
+
+my_test() {
+ local out=$(./xfconfd/xfconfd --daemon) || return 1
+ eval "${out}"
+
+ local ret=0
+ nonfatal emake check || ret=1
+
+ kill "${XFCONFD_PID}" || ewarn "Unable to kill xfconfd"
+ return "${ret}"
+}
+
+src_test() {
+ virtx my_test
+}
+
+src_install() {
+ default
+ find "${D}" -type f -name '*.la' -delete || die
+
+ if use perl; then
+ find "${ED}" -type f -name perllocal.pod -delete || die
+ find "${ED}" -depth -mindepth 1 -type d -empty -delete || die
+ fi
+}