summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-13 07:35:24 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-13 10:39:14 +0100
commit3335d9f4b7007c12bb75a5f7822e7bf2bb11ec75 (patch)
tree65bb2d9d63276db2607c4d20b69991442d660202 /xfce-base/xfdesktop
parentxfce-base/xfce4-panel: Remove redundant version (diff)
downloadgentoo-3335d9f4b7007c12bb75a5f7822e7bf2bb11ec75.tar.gz
gentoo-3335d9f4b7007c12bb75a5f7822e7bf2bb11ec75.tar.bz2
gentoo-3335d9f4b7007c12bb75a5f7822e7bf2bb11ec75.zip
xfce-base/xfdesktop: Bump to 4.14.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/xfdesktop')
-rw-r--r--xfce-base/xfdesktop/Manifest1
-rw-r--r--xfce-base/xfdesktop/xfdesktop-4.14.2.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/xfce-base/xfdesktop/Manifest b/xfce-base/xfdesktop/Manifest
index a1f8a3f004e0..08dc825fba7c 100644
--- a/xfce-base/xfdesktop/Manifest
+++ b/xfce-base/xfdesktop/Manifest
@@ -1 +1,2 @@
DIST xfdesktop-4.14.1.tar.bz2 1533788 BLAKE2B ea43c57dc9439b5b4799d3859b28287e7cc807a488d57f79ba83424fc1d5257eba6b2d8f9aa712aef68f8aa81d296376fd3ab507cb90566b0b76aab92665c117 SHA512 05e8e79efe9683d46e69375eb5c3f1d923b5e875bc7dbb8f9405338e44ae0c48172af119c5e7b141595c38b8de00c58c21f7b7d218737f5ddc2428fd7aa4bc6c
+DIST xfdesktop-4.14.2.tar.bz2 1513121 BLAKE2B afe5dad03ed4d084bd7578074f91fbc8dc121bf67b8f4793ca5c6abb67dea4f61cfa484404d79d14cf2abf64227cee883bc8f36af05802071f5b9f79300704d4 SHA512 8515fc1c048da50c8c2986ea8590144203fdf3107b81e2d2dd44ee408938fb71281abe52cc098508dc2ae20ef2cbc31903086941206c0cbbc92a661dbfb2c472
diff --git a/xfce-base/xfdesktop/xfdesktop-4.14.2.ebuild b/xfce-base/xfdesktop/xfdesktop-4.14.2.ebuild
new file mode 100644
index 000000000000..c0250e01fe7a
--- /dev/null
+++ b/xfce-base/xfdesktop/xfdesktop-4.14.2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Desktop manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug libnotify +thunar"
+
+RDEPEND=">=x11-libs/cairo-1.12
+ >=dev-libs/glib-2.42
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/libwnck-3.14:3
+ x11-libs/libX11
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/garcon-0.6:=
+ >=xfce-base/libxfce4ui-4.13:=
+ >=xfce-base/libxfce4util-4.13:=
+ >=xfce-base/xfconf-4.12.1:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+ thunar? ( >=xfce-base/thunar-1.7:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable thunar file-icons)
+ $(use_enable thunar thunarx)
+ $(use_enable libnotify notifications)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}