summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-01 09:16:16 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-01 09:56:10 +0200
commit4cb0baa9c54b6f32f4c5aeaaa618d81168eea89f (patch)
treede668f6556d2ce8e0443a05ecdbdb4de9b0fd37e /xfce-base
parentxfce-base/xfce4-panel: Bump to 4.13.6 (diff)
downloadgentoo-4cb0baa9c54b6f32f4c5aeaaa618d81168eea89f.tar.gz
gentoo-4cb0baa9c54b6f32f4c5aeaaa618d81168eea89f.tar.bz2
gentoo-4cb0baa9c54b6f32f4c5aeaaa618d81168eea89f.zip
xfce-base/garcon: Bump to 0.6.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/garcon/Manifest1
-rw-r--r--xfce-base/garcon/garcon-0.6.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/xfce-base/garcon/Manifest b/xfce-base/garcon/Manifest
index 196f30a4001d..8f6e064ad424 100644
--- a/xfce-base/garcon/Manifest
+++ b/xfce-base/garcon/Manifest
@@ -1 +1,2 @@
DIST garcon-0.6.2.tar.bz2 539745 BLAKE2B 1bcbb136cd525f1280f6539ea447b4b84f935297f6bd4391407e31925cf873fdd0cfbeb70dba5ce882e4620f1ce7b89d51c9c26232db88b1202f5a0fca3f6175 SHA512 7a96c33b47302fa989862098bc5b8ed64515a60e19a4b8dbb049398cf847d64584f93f85b1f6e1327653b22f0b44a805b737258bbc9ac69197639ef7f13f20b1
+DIST garcon-0.6.3.tar.bz2 538164 BLAKE2B 98c86491ba833fad261d1a759a33af7fbd69768e0b4a34f5712f2e0a5c8ea7734bdd984df925a50f1948e83e6f09a113e7acdadf428aca9d0aa8d0a764dc50de SHA512 1adc4373728ed19641441e0f38778d7401c78e7db52c76a258c378287c5a324e87e2aa11bca134813de4b1eaa807c62ccdf73a4c5e4d83d6acab27aafa61b5b0
diff --git a/xfce-base/garcon/garcon-0.6.3.ebuild b/xfce-base/garcon/garcon-0.6.3.ebuild
new file mode 100644
index 000000000000..8b1341ce183c
--- /dev/null
+++ b/xfce-base/garcon/garcon-0.6.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Xfce's freedesktop.org specification compatible menu implementation library"
+HOMEPAGE="https://docs.xfce.org/xfce/exo/start"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="+gtk2"
+
+RDEPEND=">=dev-libs/glib-2.30:=
+ gtk2? ( >=x11-libs/gtk+-2.24:2= )
+ >=x11-libs/gtk+-3.20:3=
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/glib-utils
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog HACKING NEWS README STATUS TODO )
+
+src_configure() {
+ local myconf=(
+ $(use_enable gtk2)
+ $(use_enable gtk2 libxfce4ui)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}