summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /xfce-extra/thunar-shares-plugin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'xfce-extra/thunar-shares-plugin')
-rw-r--r--xfce-extra/thunar-shares-plugin/Manifest1
-rw-r--r--xfce-extra/thunar-shares-plugin/metadata.xml8
-rw-r--r--xfce-extra/thunar-shares-plugin/thunar-shares-plugin-0.2.0_p20101105.ebuild40
3 files changed, 49 insertions, 0 deletions
diff --git a/xfce-extra/thunar-shares-plugin/Manifest b/xfce-extra/thunar-shares-plugin/Manifest
new file mode 100644
index 000000000000..661e0588efcf
--- /dev/null
+++ b/xfce-extra/thunar-shares-plugin/Manifest
@@ -0,0 +1 @@
+DIST thunar-shares-plugin-0.2.0_p20101105.tar.bz2 686286 SHA256 cc7ead616f4ed16cf8375f548d1a2a42303fd6c3ab34b4600ae8ca6f469a2054 SHA512 88e171eb1c859938df1c8f7d323456aa1ff2430a6c88928d3614aefbab16e8a9fa3052bdee2d7f7e16c6ba2bbf78301f1c4ac7c2454b8436cde49af716c46986 WHIRLPOOL cdc8fbcf8bb0a201b78cb5d67fb991fea296aadf98189471b42daef5f9dff83c7b63b6785fc6bb26386bbdefb5cf7f34bcd5cb9dd20f51e7702d7f996e03fc8a
diff --git a/xfce-extra/thunar-shares-plugin/metadata.xml b/xfce-extra/thunar-shares-plugin/metadata.xml
new file mode 100644
index 000000000000..008cf479f615
--- /dev/null
+++ b/xfce-extra/thunar-shares-plugin/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/xfce-extra/thunar-shares-plugin/thunar-shares-plugin-0.2.0_p20101105.ebuild b/xfce-extra/thunar-shares-plugin/thunar-shares-plugin-0.2.0_p20101105.ebuild
new file mode 100644
index 000000000000..12fe8baf735a
--- /dev/null
+++ b/xfce-extra/thunar-shares-plugin/thunar-shares-plugin-0.2.0_p20101105.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+EAUTORECONF=yes
+inherit xfconf
+
+# git clone -b thunarx-2 git://git.xfce.org/thunar-plugins/thunar-shares-plugin
+
+DESCRIPTION="Thunar plugin to share files using Samba"
+HOMEPAGE="http://goodies.xfce.org/projects/thunar-plugins/thunar-shares-plugin"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.18
+ >=x11-libs/gtk+-2.12:2
+ >=xfce-base/thunar-1.2"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --disable-static
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README TODO )
+}
+
+src_prepare() {
+ # http://bugzilla.xfce.org/show_bug.cgi?id=10032
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.in || die
+ xfconf_src_prepare
+}