summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2018-05-18 00:53:33 -0600
committerDenis Dupeyron <calchan@gentoo.org>2018-05-18 00:54:00 -0600
commita9daa9d71e1349f221ea3498296124db103b1f2b (patch)
tree77d37ca76e8df2f57b8b5e2c7d0cab14abc2a8b1 /xfce-extra/xfce4-cpufreq-plugin
parentvirtual/editor: Allow only display editors as providers. (diff)
downloadgentoo-a9daa9d71e1349f221ea3498296124db103b1f2b.tar.gz
gentoo-a9daa9d71e1349f221ea3498296124db103b1f2b.tar.bz2
gentoo-a9daa9d71e1349f221ea3498296124db103b1f2b.zip
xfce-extra/xfce4-cpufreq-plugin: bump to 1.2.0
Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'xfce-extra/xfce4-cpufreq-plugin')
-rw-r--r--xfce-extra/xfce4-cpufreq-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpufreq-plugin/Manifest b/xfce-extra/xfce4-cpufreq-plugin/Manifest
index 3cbab1bfe17a..f3856cbab03b 100644
--- a/xfce-extra/xfce4-cpufreq-plugin/Manifest
+++ b/xfce-extra/xfce4-cpufreq-plugin/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-cpufreq-plugin-1.1.3.tar.bz2 369419 BLAKE2B 6c7f38773b0c7a1b6a814b4e3576d9ecd7a5a9f1e3a401a431b2a637eca7b4a1d99aa5fe5efc07435a739594edd8cd5ff6ae7726e4b3563a4b0e37925beb9387 SHA512 fe67abc120c0715b653258abbafab19386289ce0a373e5053e544484219c3b05aafe1e84a23721f6603043db5aac24dc1230f2e7d4974ec483d5120aca11ca25
DIST xfce4-cpufreq-plugin-1.1.90.tar.bz2 366569 BLAKE2B 784d19e0ae13d8c2fb9767a2322d79bbe3e5ea0a6dfc2e2061c76501e04ba51ea7d74e7d1aceace48f6f8c4d797adf41e0f56af0315feffc59ccf0a7d5fef9ce SHA512 23a70603181c69c25fd55d523f29526b88252203f087132f271cf47376d5d04c5b81615d2aba4c2641c886497323d88301ca0a285b9c0894b0051e913cc9a70e
+DIST xfce4-cpufreq-plugin-1.2.0.tar.bz2 388599 BLAKE2B 938aa17df367ca4da7cb07df732a413d5cd3da2867772808baf3c1377c80e8b7153f5e659911d48a03d9e292e33af8764b9434e016d7b7f0933898971440ae58 SHA512 594124808fffaed514719a50e05e75612f5c1b7a802df5bb7caf65814c2c7412b9575ce916c8cd0da1360987d198c61ab078efd4a462e756248012999e597072
diff --git a/xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.0.ebuild b/xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.0.ebuild
new file mode 100644
index 000000000000..9b5a1e034f11
--- /dev/null
+++ b/xfce-extra/xfce4-cpufreq-plugin/xfce4-cpufreq-plugin-1.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="A panel plugin for showing information about cpufreq settings"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-cpufreq-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.20:=
+ >=x11-libs/gtk+-3.20:3=
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}