summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-06-23 05:35:40 +0200
committerMichał Górny <mgorny@gentoo.org>2019-06-23 05:39:14 +0200
commit8e66bffdb4365c5ef15d8d335f15b0bd6b5bd8de (patch)
treec919dfd046a0ea4132b516c5d76d11f5591f57f9 /xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.91.ebuild
parentmedia-sound/xfmpc: Bump to 0.3.0 (diff)
downloadgentoo-8e66bffdb4365c5ef15d8d335f15b0bd6b5bd8de.tar.gz
gentoo-8e66bffdb4365c5ef15d8d335f15b0bd6b5bd8de.tar.bz2
gentoo-8e66bffdb4365c5ef15d8d335f15b0bd6b5bd8de.zip
xfce-extra/xfce4-cpugraph-plugin: Bump to 1.0.91
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.91.ebuild')
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.91.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.91.ebuild b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.91.ebuild
new file mode 100644
index 000000000000..684e97eec64f
--- /dev/null
+++ b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.91.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A system load plug-in for the Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+RDEPEND=">=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}