summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-02-27 09:20:31 +0100
committerMichał Górny <mgorny@gentoo.org>2018-02-27 09:25:04 +0100
commit7a22756ffaa5ca708073adbc629f31adf01b6b3c (patch)
treea6adaa9def709419b411bfdfa2e5b3d5d43f7b4d /xfce-extra/xfce4-pulseaudio-plugin
parentnet-libs/mbedtls: version bump to 2.7.1 (diff)
downloadgentoo-7a22756ffaa5ca708073adbc629f31adf01b6b3c.tar.gz
gentoo-7a22756ffaa5ca708073adbc629f31adf01b6b3c.tar.bz2
gentoo-7a22756ffaa5ca708073adbc629f31adf01b6b3c.zip
xfce-extra/xfce4-pulseaudio-plugin: Clean old up
Diffstat (limited to 'xfce-extra/xfce4-pulseaudio-plugin')
-rw-r--r--xfce-extra/xfce4-pulseaudio-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.2.4.ebuild37
-rw-r--r--xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.3.3.ebuild60
3 files changed, 0 insertions, 99 deletions
diff --git a/xfce-extra/xfce4-pulseaudio-plugin/Manifest b/xfce-extra/xfce4-pulseaudio-plugin/Manifest
index 8e062347c45..82af06ac8f9 100644
--- a/xfce-extra/xfce4-pulseaudio-plugin/Manifest
+++ b/xfce-extra/xfce4-pulseaudio-plugin/Manifest
@@ -1,3 +1 @@
-DIST xfce4-pulseaudio-plugin-0.2.4.tar.bz2 307315 BLAKE2B b806fb27e8f1d26b8c705bc875303304c5a19a537ff409c6c4f335676a103bc09fd6c6e339a90ebcd386aad72b636278f9a1bedc04f2f4c1c5d44d1dcd4e6684 SHA512 b53ab48e282a506fc7fe91fa70520f0db32f2f73653a0210681bf7389f13441d5af8f855604b59817b1fe7a3f41e2d4fe52b052ac0c3479f3f4e37b2afedb193
-DIST xfce4-pulseaudio-plugin-0.3.3.tar.bz2 397373 BLAKE2B 088847dfb7ce661340c5adc03e9aa11b235c58b829c0b0808cff00c92ef57c4f140c4955db613b341f8c78d6c71a694d2110e36c1df3f176d148fd1bb87917ea SHA512 1312a99e609897c446a980307b5c95941fa21b4dc62e920072212492d235e6a75fcf432656d2c035b18a58053cc943f5c680c314f78f5af1a7ae88586b39d1f9
DIST xfce4-pulseaudio-plugin-0.3.4.tar.bz2 400380 BLAKE2B b8cd4df84f3119d90a7671d8217eaeb83025206d9bfdc5aaae2281cd7c9b13ab03fa8a99ff1eb352f2fa01e889bcd3a505b558ce9884c46b1136bc75a6fb22e7 SHA512 2dfa6a4567caeb2f336b1d9e32cedb5f03e363253549810e768bb51746cd1db362ebd0990098e461a71b8206d81ff877291860a3568a288fe2010498ad486c78
diff --git a/xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.2.4.ebuild b/xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.2.4.ebuild
deleted file mode 100644
index 944ca914297..00000000000
--- a/xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.2.4.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-inherit xfconf
-
-DESCRIPTION="A panel plug-in for PulseAudio volume control"
-HOMEPAGE="https://github.com/andrzej-r/xfce4-pulseaudio-plugin"
-SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ppc ~ppc64 x86"
-IUSE="debug keybinder libnotify"
-
-RDEPEND=">=dev-libs/glib-2.24.0:=
- media-sound/pulseaudio:=
- >=x11-libs/gtk+-3.6.0:3=
- >=xfce-base/libxfce4ui-4.11.0:=[gtk3(+)]
- >=xfce-base/libxfce4util-4.9.0:=
- >=xfce-base/xfce4-panel-4.11.0:=
- >=xfce-base/xfconf-4.6.0:=
- keybinder? ( dev-libs/keybinder:3= )
- libnotify? ( x11-libs/libnotify:= )"
-DEPEND="${RDEPEND}
- dev-util/intltool
- virtual/pkgconfig"
-
-pkg_setup() {
- XFCONF=(
- $(use_enable keybinder)
- $(use_enable libnotify)
- $(xfconf_use_debug)
- )
-
- DOCS=( AUTHORS ChangeLog NEWS README )
-}
diff --git a/xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.3.3.ebuild b/xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.3.3.ebuild
deleted file mode 100644
index 4369047f01f..00000000000
--- a/xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.3.3.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit gnome2-utils
-
-DESCRIPTION="A panel plug-in for PulseAudio volume control"
-HOMEPAGE="https://git.xfce.org/panel-plugins/xfce4-pulseaudio-plugin/"
-SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
-IUSE="debug keybinder libnotify"
-
-RDEPEND=">=dev-libs/glib-2.42.0:=
- media-sound/pulseaudio:=
- >=x11-libs/gtk+-3.20.0:3=
- >=xfce-base/libxfce4ui-4.11.0:=[gtk3(+)]
- >=xfce-base/libxfce4util-4.9.0:=
- >=xfce-base/xfce4-panel-4.11.0:=
- >=xfce-base/xfconf-4.6.0:=
- keybinder? ( dev-libs/keybinder:3= )
- libnotify? ( x11-libs/libnotify:= )"
-DEPEND="${RDEPEND}
- dev-util/intltool
- virtual/pkgconfig"
-
-src_configure() {
- local myconf=(
- $(use_enable keybinder)
- $(use_enable libnotify)
- )
-
- econf "${myconf[@]}"
-}
-
-src_install() {
- default
-
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-
- if ! has_version media-sound/pavucontrol; then
- elog "For the 'audio mixer...' shortcut to work, you need to install"
- elog "an external mixer application. Please either install:"
- elog
- elog " media-sound/pavucontrol"
- elog
- elog "or specify another application to use in the 'Properties' dialog."
- fi
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}