summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Levitsky <kitsunenokenja@protonmail.ch>2018-01-01 00:27:03 -0500
committerMichał Górny <mgorny@gentoo.org>2018-01-01 11:09:55 +0100
commitbe9c46be54dc722a886d44f2076877f6f35c833f (patch)
treea9473f336793ac5251924e2746754f75a692e030 /xfce-extra/xfce4-weather-plugin
parentdev-python/sphinx: Move sphinxcontrib-websupport back to RDEP (diff)
downloadgentoo-be9c46be54dc722a886d44f2076877f6f35c833f.tar.gz
gentoo-be9c46be54dc722a886d44f2076877f6f35c833f.tar.bz2
gentoo-be9c46be54dc722a886d44f2076877f6f35c833f.zip
xfce-extra/xfce4-weather-plugin: Depend on net-libs/libsoup[ssl]
Norwegian data provider serves data over HTTPS. Upstream source code has hard-coded HTTPS URLs passed into libsoup functions. This could emerge without SSL support enabled in libsoup, but would not function without it. Explicitly requiring SSL USE on libsoup dependency. Closes: https://bugs.gentoo.org/593358 Closes: https://github.com/gentoo/gentoo/pull/6704 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'xfce-extra/xfce4-weather-plugin')
-rw-r--r--xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.10.ebuild4
-rw-r--r--xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.9.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.10.ebuild b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.10.ebuild
index 97a0bc7666e..4d48ca2c078 100644
--- a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.10.ebuild
+++ b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.10.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -16,7 +16,7 @@ IUSE="upower"
RDEPEND=">=dev-libs/glib-2.20:=
dev-libs/libxml2:=
- >=net-libs/libsoup-2.32:=
+ >=net-libs/libsoup-2.32:=[ssl]
>=x11-libs/gtk+-2.14:2=
>=xfce-base/libxfce4ui-4.10:=
>=xfce-base/libxfce4util-4.10:=
diff --git a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.9.ebuild b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.9.ebuild
index 26e6e4e51df..da90c786d10 100644
--- a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.9.ebuild
+++ b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.9.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -14,7 +14,7 @@ IUSE="upower"
RDEPEND=">=dev-libs/glib-2.20:=
dev-libs/libxml2:=
- >=net-libs/libsoup-2.32:=
+ >=net-libs/libsoup-2.32:=[ssl]
>=x11-libs/gtk+-2.14:2=
>=xfce-base/libxfce4ui-4.10:=
>=xfce-base/libxfce4util-4.10:=