summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /xfce-extra/xfce4-windowck-plugin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'xfce-extra/xfce4-windowck-plugin')
-rw-r--r--xfce-extra/xfce4-windowck-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-windowck-plugin/metadata.xml11
-rw-r--r--xfce-extra/xfce4-windowck-plugin/xfce4-windowck-plugin-0.2.4.ebuild44
3 files changed, 56 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-windowck-plugin/Manifest b/xfce-extra/xfce4-windowck-plugin/Manifest
new file mode 100644
index 000000000000..356a2a329c0a
--- /dev/null
+++ b/xfce-extra/xfce4-windowck-plugin/Manifest
@@ -0,0 +1 @@
+DIST xfce4-windowck-plugin-0.2.4.tar.gz 75442 SHA256 2ce551f16a1ec8ee847c36e0d3bd9a71b6b4945821f43d54dc91433cac0a5117 SHA512 43798a8714926eb03b2f92f8dd813572030965133b672bd07c485da77efef96114ed412dc7a5de730b2bc21da561ca34c44147147c75f266d8bc393f2550557c WHIRLPOOL 64cac071593b844a1ecbe19f207b52668754e869aa3299623060b63d8fbc02939b1c9d5a2c8a1559f0ba5177809c8fb0233463612bbd9d33f349e841b0406852
diff --git a/xfce-extra/xfce4-windowck-plugin/metadata.xml b/xfce-extra/xfce4-windowck-plugin/metadata.xml
new file mode 100644
index 000000000000..135ca289e4d4
--- /dev/null
+++ b/xfce-extra/xfce4-windowck-plugin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">cedl38/xfce4-windowck-plugin</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/xfce-extra/xfce4-windowck-plugin/xfce4-windowck-plugin-0.2.4.ebuild b/xfce-extra/xfce4-windowck-plugin/xfce4-windowck-plugin-0.2.4.ebuild
new file mode 100644
index 000000000000..cc5f13ec321e
--- /dev/null
+++ b/xfce-extra/xfce4-windowck-plugin/xfce4-windowck-plugin-0.2.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+EAUTORECONF=1
+inherit xfconf
+
+DESCRIPTION="Xfce panel plugin which allows to put the maximized window title and windows buttons on the panel"
+HOMEPAGE="http://github.com/cedl38/xfce4-windowck-plugin"
+SRC_URI="http://github.com/cedl38/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="debug"
+
+RDEPEND=">=x11-libs/gtk+-2.20:2
+ x11-libs/libX11
+ >=x11-libs/libwnck-2.30:1
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfce4-panel-4.10
+ >=xfce-base/xfconf-4.10"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS NEWS README TODO )
+}
+
+src_prepare() {
+ # run xdt-autogen from xfce4-dev-tools added as dependency by EAUTORECONF=1 to
+ # rename configure.ac.in to configure.ac while grabbing $LINGUAS and $REVISION values
+ NOCONFIGURE=1 xdt-autogen
+
+ xfconf_src_prepare
+}