summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-13 13:31:30 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-13 14:10:47 +0200
commitb6333cbd5e99118d3d0cb872808a8872774ebc75 (patch)
tree7055f138a507b42202a339047a68f51cbb6791c0 /xfce-extra
parentxfce-extra/xfce4-smartbookmark-plugin: Bump to 0.5.1 (diff)
downloadgentoo-b6333cbd5e99118d3d0cb872808a8872774ebc75.tar.gz
gentoo-b6333cbd5e99118d3d0cb872808a8872774ebc75.tar.bz2
gentoo-b6333cbd5e99118d3d0cb872808a8872774ebc75.zip
xfce-extra/xfce4-battery-plugin: Bump to 1.1.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-battery-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.3.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-battery-plugin/Manifest b/xfce-extra/xfce4-battery-plugin/Manifest
index 6ed6c3bd1eb4..782b77fc4cb4 100644
--- a/xfce-extra/xfce4-battery-plugin/Manifest
+++ b/xfce-extra/xfce4-battery-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-battery-plugin-1.1.2.tar.bz2 464077 BLAKE2B d3a8c661a96fae4992d89a9e0e7c313fc7a816bc6586443eb0490617f00a5afc81a2e4cdc0b7b3e3444ffb7342cc503f0fa1e84c967c0412ce287daaca41c950 SHA512 51778d00c34c41bdad234893c4a91f3bd562481df343d811e266719cb7903f60e1d56ba39f64f14ab882ce6419d0f0f4010aa112e9d0059133e7e4d30470f491
+DIST xfce4-battery-plugin-1.1.3.tar.bz2 431118 BLAKE2B 305255b4ea0f232f5dae29b47c4ec66b26a5848783d6aa6b3379b98fe9312b302cde8302aa3d2c8bd945b3b160cdf5b6e612f452f5595f61ddaf5659342e3480 SHA512 a591fb37855efbd54d18ae97e320fa4521da611c8ea107813bfd66fa570e8c84576fcf779c7b676ee9918709912de728b0fed490e64d3d2ad403baf719db4520
diff --git a/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.3.ebuild b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.3.ebuild
new file mode 100644
index 000000000000..4637bab90ff7
--- /dev/null
+++ b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info xdg-utils
+
+DESCRIPTION="A battery monitor panel plugin for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-battery-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~x86"
+IUSE="kernel_linux"
+
+RDEPEND=">=dev-libs/glib-2.24:2
+ >=x11-libs/gtk+-3.16:3
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.8:=
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~ACPI_BATTERY"
+ linux-info_pkg_setup
+ fi
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}