summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-11 22:14:36 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-11 22:16:57 +0200
commitce330da9083727d4dc6bb755142355a3db56ff34 (patch)
treef6730bd6de648d6751e7ad1d7e082ef1dd39c7f1 /xfce-extra
parentsys-apps/firejail: added live ebuild (diff)
downloadgentoo-ce330da9083727d4dc6bb755142355a3db56ff34.tar.gz
gentoo-ce330da9083727d4dc6bb755142355a3db56ff34.tar.bz2
gentoo-ce330da9083727d4dc6bb755142355a3db56ff34.zip
xfce-extra/xfce4-weather-plugin: Bump to 0.10.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-weather-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.10.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-weather-plugin/Manifest b/xfce-extra/xfce4-weather-plugin/Manifest
index 3fa531873c30..581977aef9e9 100644
--- a/xfce-extra/xfce4-weather-plugin/Manifest
+++ b/xfce-extra/xfce4-weather-plugin/Manifest
@@ -1 +1,2 @@
+DIST xfce4-weather-plugin-0.10.0.tar.bz2 3032575 BLAKE2B 2dc81c8d60ab63ff9adb90d53a5eb89e98c3e4b950d8b5943fb2b39b4944164470d7e10dcd096ef90665129d1aa59e052b3140d1462077a285afde4bcdcba047 SHA512 168a850c60f419f40f6c05dbedf24a4f3aea3be04e14c5eb2596a03a8dee5850a80d06b63bee54690b63385109d53ccf8ff2b97a2c879e196046308436a7d126
DIST xfce4-weather-plugin-0.9.1.tar.bz2 3018842 BLAKE2B d1fa1d3e1f99aff9f726fad13a40a6f288bddc32e3c06958a571a4526d1f4a7a9386cebc5ddac1c5132f591099e0f01507fab1d158b8f686f28d2d7c9e1d8c19 SHA512 f8f50ad629719193f18cf9106379a7de7ba4ba0824eca3ec3716031cd46f5631280ff446fe651326097e3fbe6703c1d29f2ce044b1eada1613b198d30d167d09
diff --git a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.10.0.ebuild b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.10.0.ebuild
new file mode 100644
index 000000000000..ac752365a953
--- /dev/null
+++ b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.10.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A weather plug-in for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="upower"
+
+RDEPEND=">=dev-libs/glib-2.42
+ dev-libs/libxml2:=
+ >=net-libs/libsoup-2.42:=[ssl]
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+ upower? ( >=sys-power/upower-0.9.23 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ # For GEONAMES_USERNAME, read README file and ask ssuominen@!
+ local myconf=(
+ $(use_enable upower)
+ GEONAMES_USERNAME=Gentoo
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}