summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-terms/terminator/files/terminator-1.92-make-tests-fail.patch25
-rw-r--r--x11-terms/terminator/terminator-1.92.ebuild10
2 files changed, 30 insertions, 5 deletions
diff --git a/x11-terms/terminator/files/terminator-1.92-make-tests-fail.patch b/x11-terms/terminator/files/terminator-1.92-make-tests-fail.patch
new file mode 100644
index 000000000000..ae722cb11685
--- /dev/null
+++ b/x11-terms/terminator/files/terminator-1.92-make-tests-fail.patch
@@ -0,0 +1,25 @@
+commit 9f855d41f3e6d610bd01df9688467fdbb341917c
+Author: Alexey Sokolov <sokolov@google.com>
+Date: Fri May 1 08:36:09 2020 +0100
+
+ Make failed tests fail the test
+
+diff --git a/run_tests b/run_tests
+index 3bf51e4a..cc7fb56a 100755
+--- a/run_tests
++++ b/run_tests
+@@ -4,10 +4,10 @@ for t in tests/test*; do
+ echo $t
+ file_type=$(file -b $t)
+ case ${file_type} in
+- *[Pp]ython*) python ${t} ;;
+- *Bourne*) bash ${t} ;;
+- *bash*) bash ${t} ;;
+- *perl*) perl ${t} ;;
++ *[Pp]ython*) python ${t} || exit 1 ;;
++ *Bourne*) bash ${t} || exit 1 ;;
++ *bash*) bash ${t} || exit 1 ;;
++ *perl*) perl ${t} || exit 1 ;;
+ *) echo "Unknown" ;;
+ esac
+ echo
diff --git a/x11-terms/terminator/terminator-1.92.ebuild b/x11-terms/terminator/terminator-1.92.ebuild
index 64edc13227e2..e0725520a7cd 100644
--- a/x11-terms/terminator/terminator-1.92.ebuild
+++ b/x11-terms/terminator/terminator-1.92.ebuild
@@ -13,8 +13,7 @@ SRC_URI="https://github.com/gnome-terminator/terminator/releases/download/v${PV}
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
-IUSE="dbus +libnotify test"
-RESTRICT="!test? ( test )"
+IUSE="dbus +libnotify"
RDEPEND="
>=dev-libs/glib-2.32:2
@@ -30,12 +29,13 @@ RDEPEND="
"
BDEPEND="
dev-util/intltool
- test? ( ${RDEPEND} )
"
+distutils_enable_tests setup.py
PATCHES=(
"${FILESDIR}"/terminator-1.91-without-icon-cache.patch
"${FILESDIR}"/terminator-1.91-desktop.patch
+ "${FILESDIR}"/terminator-1.92-make-tests-fail.patch
)
src_prepare() {
@@ -43,8 +43,8 @@ src_prepare() {
distutils-r1_src_prepare
}
-python_test() {
- virtx esetup.py test || die "tests fail with ${EPYTHON}"
+src_test() {
+ virtx distutils-r1_src_test
}
pkg_postinst() {