summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/thefuck/Manifest1
-rw-r--r--app-shells/thefuck/thefuck-3.8.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/app-shells/thefuck/Manifest b/app-shells/thefuck/Manifest
index b05b9b84633c..d45a3647937f 100644
--- a/app-shells/thefuck/Manifest
+++ b/app-shells/thefuck/Manifest
@@ -1 +1,2 @@
DIST thefuck-3.7.tar.gz 783470 SHA256 6e7efdc51baa5bfeecf38fc1e6ecdaf07b90168a6ced79cbf50fe6ff0e0adb1e SHA512 736a0656e9bce2efdfabdede6a3d4e11b9ced324ffe6435a16475c0d5e0a04b4240be66aebdd5512d04b32a2a6c91be929e36ddcf3a7d62e59f195df33505e6c WHIRLPOOL dd901df50c767f08b98d1a4e3fc1ef086a0961911976a7c1fb6f121ea0d4df9512955ee8c3c5106760045f60d7cbb168b07be0e348db53a584e876194630e574
+DIST thefuck-3.8.tar.gz 784189 SHA256 210605275f582eb6e3aa604f4e4909c0c350053fffd963ecedacfc5733cf9bd3 SHA512 4e324fd0044a7ca78a96a744583b2d1357db142ee3b5fd174a76db52e82e788e899be2dceb1184f903f663711dc8ce82298cbc3a5b8704b8bf1903692e05a962 WHIRLPOOL 65f6a05dcf4f03a8bf9f036a560a4200b58990e13c88fb5e4ba4fae733a1166f9dd65721cf1626044ae576526c57d58a3ba230a2ef1bff8186d9a0b47a691273
diff --git a/app-shells/thefuck/thefuck-3.8.ebuild b/app-shells/thefuck/thefuck-3.8.ebuild
new file mode 100644
index 000000000000..15c70cff400a
--- /dev/null
+++ b/app-shells/thefuck/thefuck-3.8.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_4})
+
+inherit distutils-r1
+
+DESCRIPTION="Magnificent app which corrects your previous console command"
+HOMEPAGE="https://github.com/nvbn/thefuck"
+SRC_URI="https://github.com/nvbn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/pathlib[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}] )
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ sed -i -e "/import pip/s/^/#/" -e "/pip.__version__/,+3 s/^/#/" setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ py.test || die
+}