summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-voip/homer/Manifest1
-rw-r--r--net-voip/homer/files/homer-0.24.1-libav-9.patch101
-rw-r--r--net-voip/homer/homer-0.24.1-r1.ebuild67
3 files changed, 0 insertions, 169 deletions
diff --git a/net-voip/homer/Manifest b/net-voip/homer/Manifest
index 2cae7746d133..225f21c32aab 100644
--- a/net-voip/homer/Manifest
+++ b/net-voip/homer/Manifest
@@ -1,3 +1,2 @@
-DIST homer-0.24.1.tar.gz 1297045 SHA256 738cd4a1e8b437936c904bdea649c0ee12ecca2caa1bef5c585925eabe84ff44 SHA512 ea2d1a5224048668e20a62f142370910f337b3b56b94c9a92a9b7530652ceed67a59223fac57ee0d835c31545d2d06c21329a0463680936d32a1455dbb2fac33 WHIRLPOOL b16ccdea6c5ea0845aca4f31a2d6258cf6a71258c531ee36a02b2844814df73b26229ffc96129532b4f9c1f2070a9cd279b720b7286e691e488bc7b524c47278
DIST homer-0.25-ffmpeg2.patch 65617 SHA256 ce1327a59dc20c2fbe23e968786ecce21126cdb2119916bf2227594dc8c0a229 SHA512 fb4ca0bd161c94999b54b86337220f3f018672e4a5031788d8292273515fe68d4364574645d96e04b19bdb64f1b032119503cf823c7604d625015ba0cdabf030 WHIRLPOOL 909069e830b9ef473a006f686a5e5e9f7279c5b0fc8fb8f212a30b767106055970441fa4fdbe2d443fce500024bc00494c112ebb3b95a65a475b2731e8d361c7
DIST homer-0.25.tar.gz 1404242 SHA256 1c3e67a7f7134a317bc32dfb691679a2997fbfa129c70d5d165ccfd0272a752d SHA512 92254f9cc133589760a4c3081e1636232ace8eb972f7800c4fb5aaeba52e22546c6772e4c93625aa31a5d7b366f441cf8155f52d85ca44dade60edebf98b6340 WHIRLPOOL 944277b8248a1037dd27881456b6fb304d19d2f12cc7bc4268ba3dbf876de668fde25749dfbfd424950fe641d7dc65f5f14a29e9d14d5c1e738dc555af201ffe
diff --git a/net-voip/homer/files/homer-0.24.1-libav-9.patch b/net-voip/homer/files/homer-0.24.1-libav-9.patch
deleted file mode 100644
index 985145e06540..000000000000
--- a/net-voip/homer/files/homer-0.24.1-libav-9.patch
+++ /dev/null
@@ -1,101 +0,0 @@
---- HomerMultimedia/include/Header_Ffmpeg.h
-+++ HomerMultimedia/include/Header_Ffmpeg.h
-@@ -173,4 +173,16 @@
- #endif
- }
-
-+inline AVStream *HM_avformat_new_stream(AVFormatContext *s, int id)
-+{
-+ #if LIBAVCODEC_VERSION_INT < AV_VERSION_INT(53, 10, 0)
-+ return av_new_stream(s, c);
-+ #else
-+ AVStream *st = avformat_new_stream(s, NULL);
-+ if (st)
-+ st->id = id;
-+ return st;
-+ #endif
-+}
-+
- #endif
---- HomerMultimedia/src/MediaSource.cpp
-+++ HomerMultimedia/src/MediaSource.cpp
-@@ -236,11 +236,19 @@
- {
- if (tCodec->type == AVMEDIA_TYPE_VIDEO)
- {
-+ #ifndef FF_API_OLD_ENCODE_AUDIO
- bool tEncode = (tCodec->encode != NULL);
-+ #else
-+ bool tEncode = (tCodec->encode2 != NULL);
-+ #endif
- bool tDecode = (tCodec->decode != NULL);
- if ((tNextCodec != NULL) && (strcmp(tCodec->name, tNextCodec->name) == 0))
- {
-+ #ifndef FF_API_OLD_ENCODE_AUDIO
- tEncode |= (tNextCodec->encode != NULL);
-+ #else
-+ tEncode |= (tNextCodec->encode2 != NULL);
-+ #endif
- tDecode |= (tNextCodec->decode != NULL);
- tCodec = tNextCodec;
- }
-@@ -296,11 +304,19 @@
- // tNextCodec->encode ? "E" : " ",
- // tNextCodec->name,
- // tNextCodec->long_name ? tCodec->long_name : "");
-+ #ifndef FF_API_OLD_ENCODE_AUDIO
- bool tEncode = (tCodec->encode != NULL);
-+ #else
-+ bool tEncode = (tCodec->encode2 != NULL);
-+ #endif
- bool tDecode = (tCodec->decode != NULL);
- if ((tNextCodec != NULL) && (strcmp(tCodec->name, tNextCodec->name) == 0))
- {
-+ #ifndef FF_API_OLD_ENCODE_AUDIO
- tEncode |= (tNextCodec->encode != NULL);
-+ #else
-+ tEncode |= (tNextCodec->encode2 != NULL);
-+ #endif
- tDecode |= (tNextCodec->decode != NULL);
- tCodec = tNextCodec;
- }
-@@ -1622,7 +1638,7 @@
- sprintf(mRecorderFormatContext->filename, "%s", pSaveFileName.c_str());
-
- // allocate new stream structure
-- tStream = av_new_stream(mRecorderFormatContext, 0);
-+ tStream = HM_avformat_new_stream(mRecorderFormatContext, 0);
- mRecorderCodecContext = tStream->codec;
-
- // put sample parameters
---- HomerMultimedia/src/MediaSourceMuxer.cpp
-+++ HomerMultimedia/src/MediaSourceMuxer.cpp
-@@ -377,7 +377,7 @@
-
- // allocate new stream structure
- LOG(LOG_VERBOSE, "..allocating new stream");
-- tStream = av_new_stream(mFormatContext, 0);
-+ tStream = HM_avformat_new_stream(mFormatContext, 0);
- mCodecContext = tStream->codec;
- mCodecContext->codec_id = tFormat->video_codec;
- mCodecContext->codec_type = AVMEDIA_TYPE_VIDEO;
-@@ -710,7 +710,7 @@
- }
-
- // allocate new stream structure
-- tStream = av_new_stream(mFormatContext, 0);
-+ tStream = HM_avformat_new_stream(mFormatContext, 0);
- mCodecContext = tStream->codec;
- mCodecContext->codec_id = tFormat->audio_codec;
- mCodecContext->codec_type = AVMEDIA_TYPE_AUDIO;
---- HomerMultimedia/src/RTP.cpp
-+++ HomerMultimedia/src/RTP.cpp
-@@ -512,7 +512,7 @@
- // verbose timestamp debugging mRtpFormatContext->debug = FF_FDEBUG_TS;
-
- // allocate new stream structure
-- tOuterStream = av_new_stream(mRtpFormatContext, 0);//(AVStream*)av_mallocz(sizeof(AVStream));
-+ tOuterStream = HM_avformat_new_stream(mRtpFormatContext, 0);//(AVStream*)av_mallocz(sizeof(AVStream));
- if (tOuterStream == NULL)
- {
- LOG(LOG_ERROR, "Memory allocation failed");
diff --git a/net-voip/homer/homer-0.24.1-r1.ebuild b/net-voip/homer/homer-0.24.1-r1.ebuild
deleted file mode 100644
index e5c5fb9e9820..000000000000
--- a/net-voip/homer/homer-0.24.1-r1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit eutils multilib toolchain-funcs
-
-DESCRIPTION="Homer Conferencing (short: Homer) is a free SIP softphone with advanced audio and video support"
-HOMEPAGE="http://www.homer-conferencing.com"
-
-MY_PN="Homer-Conferencing"
-MY_BIN="Homer"
-
-if [[ ${PV} == *9999* ]]; then
- inherit git-2
- EGIT_REPO_URI="git://github.com/${MY_PN}/${MY_PN}.git"
- KEYWORDS=""
-else
- SRC_URI="https://github.com/${MY_PN}/${MY_PN}/archive/V${PV}.tar.gz -> ${PN}-${PV}.tar.gz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE=""
-
-DEPEND=">=dev-libs/openssl-1.0
- media-libs/alsa-lib
- media-libs/libsdl[X,sound,video,alsa]
- media-libs/portaudio[alsa]
- media-libs/sdl-mixer
- media-libs/sdl-sound
- media-libs/x264:*
- net-libs/sofia-sip
- virtual/ffmpeg:0[X]
- || ( <media-video/ffmpeg-2 media-video/libav )
- dev-qt/qtcore:4
- dev-qt/qtgui:4
- dev-qt/qtmultimedia:4
- dev-qt/qtwebkit:4"
-RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-src_prepare() {
- epatch "${FILESDIR}/${P}-libav-9.patch"
-}
-
-src_compile() {
- tc-export CXX
- emake -C HomerBuild default \
- INSTALL_PREFIX=/usr/bin \
- INSTALL_LIBDIR=/usr/$(get_libdir) \
- INSTALL_DATADIR=/usr/share/${PN} \
- VERBOSE=1
-}
-
-src_install() {
- emake -C HomerBuild install \
- DESTDIR="${D}" \
- VERBOSE=1
-
- # Create .desktop entry
- doicon ${MY_BIN}/${MY_BIN}.png
- make_desktop_entry "${MY_BIN}" "${MY_PN}" "${MY_BIN}" "Network;InstantMessaging;Telephony;VideoConference"
-}