summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ros/imu_complementary_filter/Manifest1
-rw-r--r--dev-ros/imu_complementary_filter/imu_complementary_filter-1.1.5.ebuild26
-rw-r--r--dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild26
-rw-r--r--dev-ros/imu_complementary_filter/metadata.xml11
4 files changed, 64 insertions, 0 deletions
diff --git a/dev-ros/imu_complementary_filter/Manifest b/dev-ros/imu_complementary_filter/Manifest
new file mode 100644
index 000000000000..82f6f559d84a
--- /dev/null
+++ b/dev-ros/imu_complementary_filter/Manifest
@@ -0,0 +1 @@
+DIST imu_tools-1.1.5.tar.gz 1653083 SHA256 845d0c0dfa262223e7aeb5a4ed31c92865fd5fbc30eda04dd822a2c89e81e3e0 SHA512 5009884852c71d6bb1b6c2be2f30ed333eca2ac6a7f29d02cb8f0821c0b95a33dd3b09049c4c4eeb1416fb0eb5dc454b3c6d36c2c24303f37c0d1d2c0c2d906a WHIRLPOOL 2caf1b9cf671081051a2475d019802c8fb312a2e8ad668e0cda2a259778f0ef548e3967233daeefa14c5630c4b13fddde6e0ac4d42b5b7424bf156eac0443964
diff --git a/dev-ros/imu_complementary_filter/imu_complementary_filter-1.1.5.ebuild b/dev-ros/imu_complementary_filter/imu_complementary_filter-1.1.5.ebuild
new file mode 100644
index 000000000000..39e83a273230
--- /dev/null
+++ b/dev-ros/imu_complementary_filter/imu_complementary_filter-1.1.5.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ccny-ros-pkg/imu_tools"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Fuses angular velocities, accelerations, and (optionally) magnetic readings from an IMU device"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/message_filters
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+"
diff --git a/dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild b/dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild
new file mode 100644
index 000000000000..39e83a273230
--- /dev/null
+++ b/dev-ros/imu_complementary_filter/imu_complementary_filter-9999.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ccny-ros-pkg/imu_tools"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Fuses angular velocities, accelerations, and (optionally) magnetic readings from an IMU device"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/message_filters
+ dev-ros/roscpp
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/tf
+"
+DEPEND="${RDEPEND}
+ dev-ros/cmake_modules
+"
diff --git a/dev-ros/imu_complementary_filter/metadata.xml b/dev-ros/imu_complementary_filter/metadata.xml
new file mode 100644
index 000000000000..0be33667fd34
--- /dev/null
+++ b/dev-ros/imu_complementary_filter/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ccny-ros-pkg/imu_tools</remote-id>
+ </upstream>
+</pkgmetadata>