summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-util/joystick/joystick-1.4.8-r1.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/games-util/joystick/joystick-1.4.8-r1.ebuild b/games-util/joystick/joystick-1.4.8-r1.ebuild
deleted file mode 100644
index 7807583a2198..000000000000
--- a/games-util/joystick/joystick-1.4.8-r1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-inherit eutils toolchain-funcs
-
-MY_P="linuxconsoletools-${PV}"
-DESCRIPTION="joystick testing utilities"
-HOMEPAGE="https://sourceforge.net/projects/linuxconsole/ http://atrey.karlin.mff.cuni.cz/~vojtech/input/"
-SRC_URI="mirror://sourceforge/linuxconsole/files/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~ppc x86"
-IUSE="sdl udev"
-
-DEPEND="sdl? ( media-libs/libsdl:0[video] )
- !<x11-libs/tslib-1.0-r2"
-RDEPEND="${DEPEND}
- udev? ( virtual/udev )"
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch \
- "${FILESDIR}"/${P}-build.patch \
- "${FILESDIR}"/${P}-udev.patch
- export PREFIX=/usr
- tc-export CC PKG_CONFIG
- export USE_SDL=$(usex sdl)
-}
-
-src_install() {
- default
- if use !udev ; then
- rm -f "${D}"/usr/bin/jscal-{re,}store || die
- fi
-}