summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-terms/guake/guake-3.3.2-r1.ebuild (renamed from x11-terms/guake/guake-3.3.2.ebuild)11
-rw-r--r--x11-terms/guake/guake-3.4.0-r1.ebuild11
-rw-r--r--x11-terms/guake/guake-3.6.1-r1.ebuild11
-rw-r--r--x11-terms/guake/guake-3.6.3-r1.ebuild (renamed from x11-terms/guake/guake-3.6.3.ebuild)11
-rw-r--r--x11-terms/guake/guake-9999.ebuild11
5 files changed, 30 insertions, 25 deletions
diff --git a/x11-terms/guake/guake-3.3.2.ebuild b/x11-terms/guake/guake-3.3.2-r1.ebuild
index 1e1f6615a606..1426b793e688 100644
--- a/x11-terms/guake/guake-3.3.2.ebuild
+++ b/x11-terms/guake/guake-3.3.2-r1.ebuild
@@ -18,17 +18,18 @@ IUSE="utempter"
RDEPEND="
dev-libs/keybinder:3
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pbr[${PYTHON_USEDEP}]
- dev-python/pycairo[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pbr[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
x11-libs/libnotify
x11-libs/vte:2.91
utempter? ( sys-libs/libutempter )
"
DEPEND="
${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
gnome-base/gsettings-desktop-schemas
sys-devel/gettext
sys-devel/make
diff --git a/x11-terms/guake/guake-3.4.0-r1.ebuild b/x11-terms/guake/guake-3.4.0-r1.ebuild
index f4c8848b35df..204a40fe8f3b 100644
--- a/x11-terms/guake/guake-3.4.0-r1.ebuild
+++ b/x11-terms/guake/guake-3.4.0-r1.ebuild
@@ -19,17 +19,18 @@ IUSE="utempter"
RDEPEND="
dev-libs/glib
dev-libs/keybinder:3[introspection]
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pbr[${PYTHON_USEDEP}]
- dev-python/pycairo[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pbr[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
x11-libs/libnotify[introspection]
x11-libs/vte:2.91[introspection]
utempter? ( sys-libs/libutempter )
"
DEPEND="
${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
gnome-base/gsettings-desktop-schemas
sys-devel/gettext
sys-devel/make
diff --git a/x11-terms/guake/guake-3.6.1-r1.ebuild b/x11-terms/guake/guake-3.6.1-r1.ebuild
index 240b059d9fc3..9b8a60187706 100644
--- a/x11-terms/guake/guake-3.6.1-r1.ebuild
+++ b/x11-terms/guake/guake-3.6.1-r1.ebuild
@@ -19,10 +19,12 @@ IUSE="utempter"
RDEPEND="
dev-libs/glib
dev-libs/keybinder:3[introspection]
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pbr[${PYTHON_USEDEP}]
- dev-python/pycairo[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pbr[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
x11-libs/libnotify[introspection]
x11-libs/libwnck:3[introspection]
x11-libs/vte:2.91[introspection]
@@ -30,7 +32,6 @@ RDEPEND="
"
DEPEND="
${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
gnome-base/gsettings-desktop-schemas
sys-devel/gettext
sys-devel/make
diff --git a/x11-terms/guake/guake-3.6.3.ebuild b/x11-terms/guake/guake-3.6.3-r1.ebuild
index fc373929f91e..ccfa02f3d129 100644
--- a/x11-terms/guake/guake-3.6.3.ebuild
+++ b/x11-terms/guake/guake-3.6.3-r1.ebuild
@@ -19,10 +19,12 @@ IUSE="utempter"
RDEPEND="
dev-libs/glib
dev-libs/keybinder:3[introspection]
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pbr[${PYTHON_USEDEP}]
- dev-python/pycairo[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pbr[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
x11-libs/libnotify[introspection]
x11-libs/libwnck:3[introspection]
x11-libs/vte:2.91[introspection]
@@ -30,7 +32,6 @@ RDEPEND="
"
DEPEND="
${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
gnome-base/gsettings-desktop-schemas
sys-devel/gettext
sys-devel/make
diff --git a/x11-terms/guake/guake-9999.ebuild b/x11-terms/guake/guake-9999.ebuild
index e76390e51bc7..d062cfbe9bb9 100644
--- a/x11-terms/guake/guake-9999.ebuild
+++ b/x11-terms/guake/guake-9999.ebuild
@@ -19,10 +19,12 @@ IUSE="utempter"
RDEPEND="
dev-libs/glib
dev-libs/keybinder:3[introspection]
- dev-python/dbus-python[${PYTHON_USEDEP}]
- dev-python/pbr[${PYTHON_USEDEP}]
- dev-python/pycairo[${PYTHON_USEDEP}]
- dev-python/pygobject:3[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_MULTI_USEDEP}]
+ dev-python/pbr[${PYTHON_MULTI_USEDEP}]
+ dev-python/pycairo[${PYTHON_MULTI_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_MULTI_USEDEP}]
+ ')
x11-libs/libnotify[introspection]
x11-libs/libwnck:3[introspection]
x11-libs/vte:2.91[introspection]
@@ -30,7 +32,6 @@ RDEPEND="
"
DEPEND="
${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
gnome-base/gsettings-desktop-schemas
sys-devel/gettext
sys-devel/make