summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-devel/llvm/llvm-3.7.0-r1.ebuild4
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild4
2 files changed, 2 insertions, 6 deletions
diff --git a/sys-devel/llvm/llvm-3.7.0-r1.ebuild b/sys-devel/llvm/llvm-3.7.0-r1.ebuild
index c1ef867a7a80..068f1b80eaae 100644
--- a/sys-devel/llvm/llvm-3.7.0-r1.ebuild
+++ b/sys-devel/llvm/llvm-3.7.0-r1.ebuild
@@ -186,9 +186,6 @@ src_prepare() {
find "${S}"/projects/compiler-rt/lib/builtins -type f -name \*.S -exec sed \
-e '$a\\n#if defined(__linux__) && defined(__ELF__)\n.section .note.GNU-stack,"",%progbits\n#endif' \
-i {} \; || die
-
- # Workaround bug #553416 until upstream fixes it
- epatch "${FILESDIR}"/clang-3.7-strip_doc_refs.patch
fi
if use lldb; then
@@ -275,6 +272,7 @@ multilib_src_configure() {
-DLLVM_ENABLE_SPHINX=$(usex doc)
-DLLVM_ENABLE_DOXYGEN=OFF
-DLLVM_INSTALL_HTML="${EPREFIX}/usr/share/doc/${PF}/html"
+ -DSPHINX_WARNINGS_AS_ERRORS=OFF
-DLLVM_INSTALL_UTILS=ON
)
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 8776cf8ee05c..1d0a6e61a795 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -196,9 +196,6 @@ src_prepare() {
find "${S}"/projects/compiler-rt/lib/builtins -type f -name \*.S -exec sed \
-e '$a\\n#if defined(__linux__) && defined(__ELF__)\n.section .note.GNU-stack,"",%progbits\n#endif' \
-i {} \; || die
-
- # Workaround bug #553416 until upstream fixes it
- epatch "${FILESDIR}"/clang-3.7-strip_doc_refs.patch
fi
if use lldb; then
@@ -285,6 +282,7 @@ multilib_src_configure() {
-DLLVM_ENABLE_SPHINX=$(usex doc)
-DLLVM_ENABLE_DOXYGEN=OFF
-DLLVM_INSTALL_HTML="${EPREFIX}/usr/share/doc/${PF}/html"
+ -DSPHINX_WARNINGS_AS_ERRORS=OFF
-DLLVM_INSTALL_UTILS=ON
)