summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-p2p/i2p/Manifest1
-rw-r--r--net-p2p/i2p/files/i2p-0.9.23_fix-encoding.patch43
-rw-r--r--net-p2p/i2p/files/i2p-0.9.23_fix-paths.patch102
-rw-r--r--net-p2p/i2p/files/i2p-0.9.23_initd36
-rw-r--r--net-p2p/i2p/i2p-0.9.23.ebuild122
5 files changed, 304 insertions, 0 deletions
diff --git a/net-p2p/i2p/Manifest b/net-p2p/i2p/Manifest
index 7d3f2e208803..ffff7c12df2e 100644
--- a/net-p2p/i2p/Manifest
+++ b/net-p2p/i2p/Manifest
@@ -1,2 +1,3 @@
DIST i2psource_0.9.18.tar.bz2 24147960 SHA256 6f02f38c933662874c485cb52ca800a9e07c36e74a26fdfeece65e25979beb4b SHA512 6cc336f94f8e4331b26d6e42958808f193ad3709ab6098981077c9390749233fb3d20df5c8fea34ec7810bc8846fd2e11ed7a79bf7c1ec68402b1ccacae999d6 WHIRLPOOL 467285b189af69b300c56756992e53979aa049515cb89ce0d5cbff80b9270c4ab1188f419dd0206b2406780b36ddde73861b5e2e69c7b2e7d8ed00b7bcaaa7a7
DIST i2psource_0.9.22.tar.bz2 24338146 SHA256 91ac91f7a3e202d248f5294f4951f6b7d8b9bde32991adf7a813ae1bb9188898 SHA512 0fdcd0369f79cc143c449774cb205d2fb4fa5ad32e0b5bd3ed0dee5b24402cc21b1c5650d535518e68aaa98cee5380bf0af041df8b3e1724698aebf61cfb5583 WHIRLPOOL bd36ce760f7a7b942651de576662b3fadbf19bbdb84a020a16783689f3ae4919bf9441762f2d951ed1c02781e62131370b5cc36cd257c187185862901454e971
+DIST i2psource_0.9.23.tar.bz2 24427211 SHA256 24e303f2af1b7b14ed3a6e17cc7d1b6432ec99d8d00246a88486922941c72345 SHA512 1697ee03c5b09c7653f4e30e976062908e0c0ece7ee9651979384fce0d5c887d7cfbd841522d31203f23d7f5dc97d8f8ef238784199b22fe5452299587038f82 WHIRLPOOL a2141b8d9d5f8b552e354678294364bedde9cef5aa39aa95a06dbe19f5f7996b6d5eb0e1b43ad8ce5c2f9e20dc4dda792b994004a95ea1dc83c5541f46de5b89
diff --git a/net-p2p/i2p/files/i2p-0.9.23_fix-encoding.patch b/net-p2p/i2p/files/i2p-0.9.23_fix-encoding.patch
new file mode 100644
index 000000000000..4c542b5ad5bc
--- /dev/null
+++ b/net-p2p/i2p/files/i2p-0.9.23_fix-encoding.patch
@@ -0,0 +1,43 @@
+diff -Naur a/core/java/src/net/i2p/crypto/eddsa/math/GroupElement.java b/core/java/src/net/i2p/crypto/eddsa/math/GroupElement.java
+--- a/core/java/src/net/i2p/crypto/eddsa/math/GroupElement.java 2016-01-07 01:40:50.225460721 +0100
++++ b/core/java/src/net/i2p/crypto/eddsa/math/GroupElement.java 2016-01-07 01:41:19.960462373 +0100
+@@ -216,9 +216,9 @@
+ * x is recovered in the following way:
+ * <p><ul>
+ * <li>x = sign(x) * sqrt((y^2 - 1) / (d * y^2 + 1)) = sign(x) * sqrt(u / v) with u = y^2 - 1 and v = d * y^2 + 1.
+- * <li>Setting β = (u * v^3) * (u * v^7)^((q - 5) / 8) one has β^2 = +-(u / v).
+- * <li>If v * β = -u multiply β with i=sqrt(-1).
+- * <li>Set x := β.
++ * <li>Setting b = (u * v^3) * (u * v^7)^((q - 5) / 8) one has b^2 = +-(u / v).
++ * <li>If v * b = -u multiply b with i=sqrt(-1).
++ * <li>Set x := b.
+ * <li>If sign(x) != bit 255 of s then negate x.
+ *
+ * @param curve The curve.
+@@ -511,10 +511,10 @@
+ * Formula for the P^2 representation is in agreement with the formula given in [4] page 12 (with a = -1)
+ * up to a common factor -1 which does not matter:
+ * <p>
+- * B = (X + Y)^2; C = X^2; D = Y^2; E = -C = -X^2; F := E + D = Y^2 - X^2; H = Z^2; J = F − 2 * H;
+- * X3 = (B − C − D) · J = X' * (-T');
+- * Y3 = F · (E − D) = Z' * (-Y');
+- * Z3 = F · J = Z' * (-T').
++ * B = (X + Y)^2; C = X^2; D = Y^2; E = -C = -X^2; F := E + D = Y^2 - X^2; H = Z^2; J = F - 2 * H;
++ * X3 = (B - C - D) . J = X' * (-T');
++ * Y3 = F . (E - D) = Z' * (-Y');
++ * Z3 = F . J = Z' * (-T').
+ *
+ * @return The P1P1 representation
+ */
+diff -Naur a/core/java/src/net/i2p/data/DataHelper.java b/core/java/src/net/i2p/data/DataHelper.java
+--- a/core/java/src/net/i2p/data/DataHelper.java 2016-01-07 01:40:50.214460721 +0100
++++ b/core/java/src/net/i2p/data/DataHelper.java 2016-01-07 01:41:02.491461403 +0100
+@@ -1577,7 +1577,7 @@
+ } else if (adms < 0.001d) {
+ t = ngettext("1 ns", "{0,number,###} ns", (int) Math.round(ms * 1000000d));
+ } else if (adms < 1.0d) {
+- t = ngettext("1 μs", "{0,number,###} μs", (int) Math.round(ms * 1000d));
++ t = ngettext("1 us", "{0,number,###} us", (int) Math.round(ms * 1000d));
+ } else if (ams < 3 * 1000) {
+ t = ngettext("1 ms", "{0,number,####} ms", (int) Math.round(ms));
+ } else if (ams < 2 * 60 * 1000) {
diff --git a/net-p2p/i2p/files/i2p-0.9.23_fix-paths.patch b/net-p2p/i2p/files/i2p-0.9.23_fix-paths.patch
new file mode 100644
index 000000000000..c30e20875026
--- /dev/null
+++ b/net-p2p/i2p/files/i2p-0.9.23_fix-paths.patch
@@ -0,0 +1,102 @@
+diff -Naur a/clients.config b/clients.config
+--- a/clients.config 2016-01-07 00:44:46.721273819 +0100
++++ b/clients.config 2016-01-07 00:44:52.185274122 +0100
+@@ -60,7 +60,7 @@
+ clientApp.4.name=Open Router Console in web browser at startup
+ clientApp.4.args=http://127.0.0.1:7657/
+ clientApp.4.delay=3
+-clientApp.4.startOnLoad=true
++clientApp.4.startOnLoad=false
+
+ # BOB bridge
+ clientApp.5.args=
+diff -Naur a/eepget b/eepget
+--- a/eepget 2016-01-07 00:44:46.721273819 +0100
++++ b/eepget 2016-01-07 00:44:52.186274123 +0100
+@@ -1,3 +1,3 @@
+ #!/bin/sh
+-I2P="%INSTALL_PATH"
++I2P="/usr/share/i2p"
+ java -cp "$I2P/lib/i2p.jar" net.i2p.util.EepGet "$@"
+diff -Naur a/i2prouter b/i2prouter
+--- a/i2prouter 2016-01-07 00:44:46.721273819 +0100
++++ b/i2prouter 2016-01-07 00:44:52.188274123 +0100
+@@ -28,20 +28,22 @@
+ # Note that (percent)INSTALL_PATH, (percent)USER_HOME, and (percent)SYSTEM_java_io_tmpdir
+ # should have been replaced by the izpack installer.
+ # If you did not run the installer, replace them with the appropriate paths.
+-I2P="%INSTALL_PATH"
++USER_HOME="$HOME"
++SYSTEM_java_io_tmpdir="$USER_HOME/.i2p"
++I2P="/usr/share/i2p"
+ if [ "`uname -s`" = "Darwin" ]; then
+- if [ -d "%USER_HOME/Library/Application Support" ]; then
+- I2P_CONFIG_DIR="%USER_HOME/Library/Application Support/i2p"
++ if [ -d "$USER_HOME/Library/Application Support" ]; then
++ I2P_CONFIG_DIR="$USER_HOME/Library/Application Support/i2p"
+ else
+- I2P_CONFIG_DIR="%USER_HOME/.i2p"
++ I2P_CONFIG_DIR="$USER_HOME/.i2p"
+ fi
+ else
+- I2P_CONFIG_DIR="%USER_HOME/.i2p"
++ I2P_CONFIG_DIR="$USER_HOME/.i2p"
+ fi
+-I2PTEMP="%SYSTEM_java_io_tmpdir"
++I2PTEMP="$SYSTEM_java_io_tmpdir"
+ # PORTABLE installation:
+ # Use the following instead.
+-#I2PTEMP="%INSTALL_PATH"
++#I2PTEMP="/usr/share/i2p"
+
+ # Application
+ APP_NAME="i2p"
+diff -Naur a/runplain.sh b/runplain.sh
+--- a/runplain.sh 2016-01-07 00:44:46.721273819 +0100
++++ b/runplain.sh 2016-01-07 00:44:52.189274123 +0100
+@@ -11,8 +11,8 @@
+ # Note that (percent)INSTALL_PATH and (percent)SYSTEM_java_io_tmpdir
+ # should have been replaced by the izpack installer.
+ # If you did not run the installer, replace them with the appropriate path.
+-I2P="%INSTALL_PATH"
+-I2PTEMP="%SYSTEM_java_io_tmpdir"
++I2P="/usr/share/i2p"
++I2PTEMP="$SYSTEM_java_io_tmpdir"
+
+ # Having IPv6 enabled can cause problems with certain configurations. Changing the
+ # next value to true may help.
+diff -Naur a/wrapper.config b/wrapper.config
+--- a/wrapper.config 2016-01-07 00:44:46.714273818 +0100
++++ b/wrapper.config 2016-01-07 00:46:24.151279233 +0100
+@@ -60,13 +60,19 @@
+ # classes, or all the classes of i2p.jar, are in a different directory).
+ # Be sure there are no other duplicate classes.
+ #
+-wrapper.java.classpath.1=$INSTALL_PATH/lib/*.jar
++wrapper.java.classpath.1=/usr/share/i2p/lib/*.jar
++wrapper.java.classpath.2=/usr/share/tomcat-jstl-impl/lib/*.jar
++wrapper.java.classpath.3=/usr/share/tomcat-jstl-spec/lib/*.jar
++wrapper.java.classpath.4=/usr/share/java-service-wrapper/lib/*.jar
++wrapper.java.classpath.5=/usr/share/bcprov-1.50/lib/*.jar
++wrapper.java.classpath.6=/usr/share/jrobin/lib/*.jar
+ # uncomment this to use the system classpath as well (e.g. to get tools.jar)
+ # wrapper.java.classpath.2=%CLASSPATH%
+
+ # Java Library Path (location of Wrapper.DLL or libwrapper.so)
+-wrapper.java.library.path.1=$INSTALL_PATH
+-wrapper.java.library.path.2=$INSTALL_PATH/lib
++wrapper.java.library.path.1=/usr/share/i2p
++wrapper.java.library.path.2=/usr/share/i2p/lib
++wrapper.java.library.path.3=/usr/lib/java-service-wrapper
+
+ # Java Bits. On applicable platforms, tells the JVM to run in 32 or 64-bit mode.
+ wrapper.java.additional.auto_bits=TRUE
+@@ -74,7 +80,7 @@
+ # Java Additional Parameters
+ # Numbers must be consecutive (except for stripquotes)
+ wrapper.java.additional.1=-DloggerFilenameOverride=logs/log-router-@.txt
+-wrapper.java.additional.2=-Di2p.dir.base="$INSTALL_PATH"
++wrapper.java.additional.2=-Di2p.dir.base="/usr/share/i2p"
+ wrapper.java.additional.2.stripquotes=TRUE
+
+ # Prevent the JVM from exporting stats (and thereby causing hundreds of
diff --git a/net-p2p/i2p/files/i2p-0.9.23_initd b/net-p2p/i2p/files/i2p-0.9.23_initd
new file mode 100644
index 000000000000..ca39586113ed
--- /dev/null
+++ b/net-p2p/i2p/files/i2p-0.9.23_initd
@@ -0,0 +1,36 @@
+#!/sbin/runscript
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net
+}
+
+HOME="/var/lib/i2p"
+USER_HOME="$HOME"
+JAVABINARY="/etc/java-config-2/current-system-vm/bin/java"
+INSTALL_PATH="/usr/share/i2p"
+I2P="$INSTALL_PATH"
+I2P_CONFIG_DIR="$USER_HOME/.i2p"
+SYSTEM_java_io_tmpdir="$I2P_CONFIG_DIR"
+I2PTEMP="$SYSTEM_java_io_tmpdir"
+LOGFILE="$I2P_CONFIG_DIR/wrapper.log"
+PIDFILE="/var/run/i2p.pid"
+WRAPPER_CMD="$I2P/i2psvc"
+WRAPPER_CONF="$I2P/wrapper.config"
+
+start() {
+ ebegin "Starting I2P"
+ start-stop-daemon --start -b -m -u i2p --pidfile "$PIDFILE" --quiet --exec $WRAPPER_CMD -- -c $WRAPPER_CONF wrapper.daemonize=FALSE wrapper.syslog.ident=i2p wrapper.java.command="$JAVABINARY" wrapper.name=i2p wrapper.displayname="I2P Service" wrapper.statusfile="$I2P_CONFIG_DIR/i2p.status" wrapper.java.statusfile="$I2P_CONFIG_DIR/i2p.java.status" wrapper.logfile="$LOGFILE"
+ sleep 1
+ [ -e "$PIDFILE" -a -e /proc/$(cat "$PIDFILE") ]
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping I2P"
+ start-stop-daemon --stop -u i2p --pidfile "$PIDFILE" --quiet --exec $WRAPPER_CMD -R SIGTERM/20 SIGKILL/20 -P
+ eend $?
+}
+
diff --git a/net-p2p/i2p/i2p-0.9.23.ebuild b/net-p2p/i2p/i2p-0.9.23.ebuild
new file mode 100644
index 000000000000..52e9cc047811
--- /dev/null
+++ b/net-p2p/i2p/i2p-0.9.23.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils java-pkg-2 java-ant-2 systemd user
+
+DESCRIPTION="A privacy-centric, anonymous network."
+HOMEPAGE="https://geti2p.net"
+SRC_URI="https://download.i2p2.de/releases/${PV}/i2psource_${PV}.tar.bz2"
+
+LICENSE="Apache-2.0 Artistic BSD CC-BY-2.5 CC-BY-3.0 CC-BY-SA-3.0 EPL-1.0 GPL-2 GPL-3 LGPL-2.1 LGPL-3 MIT public-domain WTFPL-2"
+SLOT="0"
+
+# Until the deps reach other arches
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+# dev-java/ant-core is automatically added due to java-ant-2.eclass
+CDEPEND="dev-java/jrobin:0
+ dev-java/bcprov:1.50
+ dev-java/slf4j-api:0
+ dev-java/tomcat-jstl-impl:0
+ dev-java/tomcat-jstl-spec:0
+ dev-java/java-service-wrapper:0"
+
+DEPEND="${CDEPEND}
+ dev-java/eclipse-ecj:*
+ dev-libs/gmp:*
+ nls? ( sys-devel/gettext )
+ >=virtual/jdk-1.6"
+
+RDEPEND="${CDEPEND}
+ >=virtual/jre-1.6"
+
+EANT_BUILD_TARGET="pkg"
+EANT_GENTOO_CLASSPATH="java-service-wrapper,jrobin,slf4j-api,tomcat-jstl-impl,tomcat-jstl-spec,bcprov-1.50"
+
+pkg_setup() {
+ java-pkg-2_pkg_setup
+
+ enewgroup i2p
+ enewuser i2p -1 -1 /var/lib/i2p i2p -m
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ java-ant_rewrite-classpath
+}
+
+src_prepare() {
+ java-pkg-2_src_prepare
+
+ # We're on GNU/Linux, we don't need .exe files
+ echo "noExe=true" > override.properties
+ if ! use nls; then
+ echo "require.gettext=false" >> override.properties
+ fi
+
+ #epatch "${FILESDIR}/${P}_fix-encoding.patch"
+}
+
+src_install() {
+ # Cd into pkg-temp.
+ cd "${S}/pkg-temp" || die
+
+ # Apply patch.
+ epatch "${FILESDIR}/${P}_fix-paths.patch"
+
+ # Using ${D} here results in an error. Docs say use $ROOT
+ i2p_home="${ROOT}/usr/share/i2p"
+
+ # This is ugly, but to satisfy all non-system .jar dependencies, jetty and
+ # systray4j would need to be packaged. The former would be too large a task
+ # for an unseasoned developer and systray4j hasn't been touched in over 10
+ # years. This seems to be the most pragmatic solution
+ java-pkg_jarinto "${i2p_home}/lib"
+ for i in BOB commons-el commons-logging i2p i2psnark i2ptunnel \
+ jasper-compiler jasper-runtime javax.servlet jbigi jetty* mstreaming org.mortbay.* router* \
+ sam standard streaming systray systray4j; do
+ java-pkg_dojar lib/${i}.jar
+ done
+
+ # Set up symlinks for binaries
+ dosym /usr/bin/wrapper ${i2p_home}/i2psvc
+ dosym ${i2p_home}/i2prouter /usr/bin/i2prouter
+ dosym ${i2p_home}/eepget /usr/bin/eepget
+
+ # Install main files and basic documentation
+ exeinto ${i2p_home}
+ insinto ${i2p_home}
+ doins blocklist.txt hosts.txt *.config
+ doexe eepget i2prouter runplain.sh
+ dodoc history.txt INSTALL-headless.txt LICENSE.txt
+ doman man/*
+
+ # Install other directories
+ doins -r certificates docs eepsite geoip scripts
+ dodoc -r licenses
+ java-pkg_dowar webapps/*.war
+
+ # Install daemon files
+ newinitd "${FILESDIR}/${P}_initd" i2p
+ systemd_newunit "${FILESDIR}"/i2p.service i2p.service
+
+ # setup user
+ dodir /var/lib/i2p/.i2p
+ fowners -R i2p:i2p /var/lib/i2p/.i2p
+}
+
+pkg_postinst() {
+ elog "Custom configuration belongs in /var/lib/i2p/.i2p/ to avoid being overwritten."
+ elog "I2P can be configured through the web interface at http://localhost:7657/index.jsp"
+
+ ewarn 'Currently, the i2p team do not enforce to use ECDSA keys. But it is more and'
+ ewarn 'more pushed. To help the network, you are recommended to have either:'
+ ewarn ' dev-java/icedtea[-sunec,nss]'
+ ewarn ' dev-java/oracle-jre-bin'
+ ewarn ' dev-java/oracle-jdk-bin'
+}