summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-plugins/adobe-flash/Manifest4
-rw-r--r--www-plugins/adobe-flash/adobe-flash-28.0.0.126.ebuild140
2 files changed, 144 insertions, 0 deletions
diff --git a/www-plugins/adobe-flash/Manifest b/www-plugins/adobe-flash/Manifest
index 1f0ce18a99ea..08a5174a0a75 100644
--- a/www-plugins/adobe-flash/Manifest
+++ b/www-plugins/adobe-flash/Manifest
@@ -2,3 +2,7 @@ DIST adobe-flash-27.0.0.187-npapi.i386.tar.gz 8511242 BLAKE2B 4aad18b36e4c024f50
DIST adobe-flash-27.0.0.187-npapi.x86_64.tar.gz 9024091 BLAKE2B 229e699470abc5d3fee1c9698a69087ec637035d45553683feb939c3c5c6f7f7dae38a19bbe4dc5b0d45c8551c84735a35aef6b01376174793449647e0d8ac27 SHA512 f258df77ef447e216eaa39357750504980b3938cfa2c40ebe84f181c1df10c011011e9c34a13e89a1acc3667b201f52a455081f277386df062844df0026e4b61
DIST adobe-flash-27.0.0.187-ppapi.i386.tar.gz 8545784 BLAKE2B 3088c29721a87f043d871228e2b7e22cba80b31eaefa23e9906a03f1f7f6c3d3c847db5eb07a350cc2e541dc72e332e4d14f6dc0e89c7a46fdb490045f31e174 SHA512 e7f9e3f529c94b3d595a00a8f4ac40aa56c169f2c557300c20ff55f48b871df834e62626d88a79c3f07a08449e8599319ad0f385c25a97a1aa6109cf03c1e497
DIST adobe-flash-27.0.0.187-ppapi.x86_64.tar.gz 9463140 BLAKE2B def5b6d79351e58bc4aab441c36b61974ef4717a681e6f436ddc368cbbc72fbf45ddf2da9dbf8ad2266739a4df59c7179830022dccdf1dbbf49f7ad808e19c97 SHA512 4fb84cd352811b7e0d423b4f5970149f5265b6c729801b227f630c1145c64a54b770e24e253cc8a783aa9877ea0bdcf8314f37efca936f203a72de91178b8584
+DIST adobe-flash-28.0.0.126-npapi.i386.tar.gz 8510309 BLAKE2B 383e35d60cb0ff7c4a18c5d134a9999b0ebd19d9998fa724b4d1aa481531400bca4c52293c8e5be3069a0b7fb22add3100c572bc4cc8cd5bff67c635fc142102 SHA512 5dd398ab8f0134572728549634b4fcce6795047b276d365d707d8df1d7ff4ddb0b6551a6485f35dab0164d4a1bff069f592ae4e10d7e5a8661ca72f9e403b798
+DIST adobe-flash-28.0.0.126-npapi.x86_64.tar.gz 9027151 BLAKE2B 3f1371bf3ffbdf834a51cd7e00df387832fda565deed9cf3c46276e626c727d1fa66b4ab691c1e78b441842fc22adb6e2a84f5df2d928a3856a6e36a621e95ab SHA512 f8916cd3afa17536e3657232971b6363829b0434472884a8bef000c8ed64daa61fa0d6562eca34d6280c5dd3113e1713f5911d96d8d4bb2234855527a0145357
+DIST adobe-flash-28.0.0.126-ppapi.i386.tar.gz 8546535 BLAKE2B ff4e27158c3af0107c14f2c22299fc15572d88d2a4660b6905594e4cb00d70fa5c7e24b77ebe43553195b79db94df1232a58faa3d284576fa16355c555b30386 SHA512 aa8a5ccc53dfaa737f8dd0250f26484298cd5cb05dfa45db5fde2788534b5aa5e6d3e2a96dfc0f4ce38e7cc8b28ed16d9d3bea9176cfb9df609878b99dbce8b1
+DIST adobe-flash-28.0.0.126-ppapi.x86_64.tar.gz 9464135 BLAKE2B e0be3deb0454e0b0305993bc1922266d4ad0f3f10af69e955a2df76ee94f87173fcf590b9fbafb71fcd94968484bece3ce74219a72994ffedb36daf1be61f79d SHA512 9e7af54862a1dd5fa3ed059f5f64d44ae4c71b1c7d2104dc73b25d815b81e18db16b727810556f814b42e207fccdcc056044861b9ac48d59be5ff83b3e5183fa
diff --git a/www-plugins/adobe-flash/adobe-flash-28.0.0.126.ebuild b/www-plugins/adobe-flash/adobe-flash-28.0.0.126.ebuild
new file mode 100644
index 000000000000..eb6463c6e194
--- /dev/null
+++ b/www-plugins/adobe-flash/adobe-flash-28.0.0.126.ebuild
@@ -0,0 +1,140 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils nsplugins multilib multilib-minimal
+
+DESCRIPTION="Adobe Flash Player"
+HOMEPAGE="
+ https://www.adobe.com/products/flashplayer.html
+ https://get.adobe.com/flashplayer/
+ https://helpx.adobe.com/security/products/flash-player.html
+"
+
+AF_URI="https://fpdownload.adobe.com/pub/flashplayer/pdc/${PV}"
+AF_NP_32_URI="${AF_URI}/flash_player_npapi_linux.i386.tar.gz -> ${P}-npapi.i386.tar.gz"
+AF_NP_64_URI="${AF_URI}/flash_player_npapi_linux.x86_64.tar.gz -> ${P}-npapi.x86_64.tar.gz"
+AF_PP_32_URI="${AF_URI}/flash_player_ppapi_linux.i386.tar.gz -> ${P}-ppapi.i386.tar.gz"
+AF_PP_64_URI="${AF_URI}/flash_player_ppapi_linux.x86_64.tar.gz -> ${P}-ppapi.x86_64.tar.gz"
+
+IUSE="+nsplugin +ppapi"
+REQUIRED_USE="
+ || ( nsplugin ppapi )
+"
+
+SRC_URI="
+ nsplugin? (
+ abi_x86_32? ( ${AF_NP_32_URI} )
+ abi_x86_64? ( ${AF_NP_64_URI} )
+ )
+ ppapi? (
+ abi_x86_32? ( ${AF_PP_32_URI} )
+ abi_x86_64? ( ${AF_PP_64_URI} )
+ )
+"
+SLOT="22"
+
+KEYWORDS="-* ~amd64 ~x86"
+LICENSE="AdobeFlash-11.x"
+RESTRICT="strip mirror"
+
+NPAPI_RDEPEND="
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ media-libs/freetype[${MULTILIB_USEDEP}]
+ >=sys-libs/glibc-2.4
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:2[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXt[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]
+"
+RDEPEND="
+ !www-plugins/chrome-binary-plugins[flash(-)]
+ nsplugin? (
+ ${NPAPI_RDEPEND}
+ !www-plugins/adobe-flash:0
+ )
+"
+
+S="${WORKDIR}"
+
+# Ignore QA warnings in these closed-source binaries, since we can't fix them:
+QA_PREBUILT="usr/*"
+
+src_unpack() {
+ local files=( ${A} )
+
+ multilib_src_unpack() {
+ mkdir -p "${BUILD_DIR}" || die
+ cd "${BUILD_DIR}" || die
+
+ # we need to filter out the other archive(s)
+ local other_abi
+ [[ ${ABI} == amd64 ]] && other_abi=i386 || other_abi=x86_64
+ unpack ${files[@]//*${other_abi}*/}
+ }
+
+ multilib_parallel_foreach_abi multilib_src_unpack
+}
+
+multilib_src_install() {
+ local pkglibdir=lib
+ [[ -d usr/lib64 ]] && pkglibdir=lib64
+
+ if use nsplugin; then
+ # PLUGINS_DIR comes from nsplugins.eclass
+ exeinto /usr/$(get_libdir)/${PLUGINS_DIR}
+ doexe libflashplayer.so
+
+ if multilib_is_native_abi; then
+ # No KDE applet, so allow the GTK utility to show up in KDE:
+ sed \
+ -i usr/share/applications/flash-player-properties.desktop \
+ -e "/^NotShowIn=KDE;/d" || die
+
+ # The userland 'flash-player-properties' standalone app:
+ dobin usr/bin/flash-player-properties
+
+ # Icon and .desktop for 'flash-player-properties'
+ insinto /usr/share
+ doins -r usr/share/{icons,applications}
+ dosym ../icons/hicolor/48x48/apps/flash-player-properties.png \
+ /usr/share/pixmaps/flash-player-properties.png
+ fi
+
+ # The magic config file!
+ insinto "/etc/adobe"
+ doins "${FILESDIR}/mms.cfg"
+ fi
+
+ if use ppapi; then
+ exeinto /usr/$(get_libdir)/chromium/PepperFlash
+ doexe libpepflashplayer.so
+ insinto /usr/$(get_libdir)/chromium/PepperFlash
+ doins manifest.json
+
+ if multilib_is_native_abi; then
+ dodir /etc/chromium
+ sed "${FILESDIR}"/pepper-flash-r1 \
+ -e "s|@FP_LIBDIR@|$(get_libdir)|g" \
+ -e "s|@FP_PV@|${PV}|g" \
+ > "${D}"/etc/chromium/pepper-flash \
+ || die
+ fi
+ fi
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+pkg_postrm() {
+ gnome2_icon_cache_update
+}