summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-libs/libdrm/Manifest2
-rw-r--r--x11-libs/libdrm/libdrm-2.4.76.ebuild62
-rw-r--r--x11-libs/libdrm/libdrm-2.4.77.ebuild62
3 files changed, 0 insertions, 126 deletions
diff --git a/x11-libs/libdrm/Manifest b/x11-libs/libdrm/Manifest
index 6c42e67b3d2e..2bc1a0c38fdb 100644
--- a/x11-libs/libdrm/Manifest
+++ b/x11-libs/libdrm/Manifest
@@ -1,4 +1,2 @@
DIST libdrm-2.4.75.tar.bz2 774589 SHA256 2d5a500eef412cc287d12268eed79d571e262d4957a2ec9258073f305985054f SHA512 7d30029dfc384024eb6a82a04122064366572f5888ac4594fd9e02bc0a22ed2d154bef1840bd24f0543b77460d6359d7e424d424e10f4256ee3c898041be2292 WHIRLPOOL 24134409e59fe48bae02890b8153c063a49b114bcad9911487aa25ee594fe622ba04a3b2e486a2944ebe4177e205a8a970dd8d584550022780a70cb0447decf9
-DIST libdrm-2.4.76.tar.bz2 783155 SHA256 7cdfb83ea77def453299dd95332aa9257c9f3534ff5844f5c0ce87265c275f3a SHA512 29aa3085fe71f9adaca654e408e74b3f850b82c4af7035fe147d848ad038dac8749619dfa91b1ef24e2ab1d97719d91de4fa67684ef7582285ebc9802aa4d615 WHIRLPOOL 7ae06791574a768f6a01d0ef110fb5c1b1a1925d39e6918145b7b1004b4216e2c4efca980db80ad57c116ed28d47ed121fff8011f8fb52ff704f008b3908c627
-DIST libdrm-2.4.77.tar.bz2 782724 SHA256 e8d5e2ca3a42a4d02b4df97fde45a12eeeb34c158008361026f82c8bf6fb3b6d SHA512 df313bdd9186efdb0e60acdd55e0d5dba402b19011bc3899d56efb4d065f67b6e8c44108fbd8fd258120d4b5c1cc53090beaab732c763bf52f8b352d3c30d101 WHIRLPOOL 1c89ecea2888535e21c7d1a57aadfba932ce01e90edf50ccf4d7418888428541f3f9100e35635bdfce0a29a6880c869fe6bf23c312e18b8e2536ce87987cf9fb
DIST libdrm-2.4.79.tar.bz2 783711 SHA256 c6aaf319293bce38023e9a637471b0f45c93c807d2a279060d741fc7a2e5b197 SHA512 62d6dbdf5e4e73e948fcb128a3ee76c88843d0aabf0af5751526829e9b95cff151a121af88ba9625acc7f5bc4ecfa71f9a3762005d5da76cff1d91dfc8ea8ea7 WHIRLPOOL 38e64cad8cd49a44931b598896d9ced625560a0d9da4f095d4d76eff3b64d8ab80285a6df2ff3c27ab41946fa0dcc718960cf01ac662be891c0f561997058208
diff --git a/x11-libs/libdrm/libdrm-2.4.76.ebuild b/x11-libs/libdrm/libdrm-2.4.76.ebuild
deleted file mode 100644
index 595bd79fadcf..000000000000
--- a/x11-libs/libdrm/libdrm-2.4.76.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-XORG_MULTILIB=yes
-inherit xorg-2
-
-DESCRIPTION="X.Org libdrm library"
-HOMEPAGE="https://dri.freedesktop.org/"
-if [[ ${PV} = 9999* ]]; then
- EGIT_REPO_URI="git://anongit.freedesktop.org/git/mesa/drm"
-else
- SRC_URI="https://dri.freedesktop.org/${PN}/${P}.tar.bz2"
-fi
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
-VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vc4 vivante vmware"
-for card in ${VIDEO_CARDS}; do
- IUSE_VIDEO_CARDS+=" video_cards_${card}"
-done
-
-IUSE="${IUSE_VIDEO_CARDS} libkms valgrind"
-RESTRICT="test" # see bug #236845
-
-RDEPEND=">=dev-libs/libpthread-stubs-0.3-r1:=[${MULTILIB_USEDEP}]
- video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )
- abi_x86_32? ( !app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] )"
-DEPEND="${RDEPEND}
- valgrind? ( dev-util/valgrind )"
-
-src_prepare() {
- if [[ ${PV} = 9999* ]]; then
- # tests are restricted, no point in building them
- sed -ie 's/tests //' "${S}"/Makefile.am
- fi
- xorg-2_src_prepare
-}
-
-src_configure() {
- XORG_CONFIGURE_OPTIONS=(
- # Udev is only used by tests now.
- --disable-udev
- --disable-cairo-tests
- $(use_enable video_cards_amdgpu amdgpu)
- $(use_enable video_cards_exynos exynos-experimental-api)
- $(use_enable video_cards_freedreno freedreno)
- $(use_enable video_cards_intel intel)
- $(use_enable video_cards_nouveau nouveau)
- $(use_enable video_cards_omap omap-experimental-api)
- $(use_enable video_cards_radeon radeon)
- $(use_enable video_cards_tegra tegra-experimental-api)
- $(use_enable video_cards_vc4 vc4)
- $(use_enable video_cards_vivante etnaviv-experimental-api)
- $(use_enable video_cards_vmware vmwgfx)
- $(use_enable libkms)
- # valgrind installs its .pc file to the pkgconfig for the primary arch
- --enable-valgrind=$(usex valgrind auto no)
- )
-
- xorg-2_src_configure
-}
diff --git a/x11-libs/libdrm/libdrm-2.4.77.ebuild b/x11-libs/libdrm/libdrm-2.4.77.ebuild
deleted file mode 100644
index 595bd79fadcf..000000000000
--- a/x11-libs/libdrm/libdrm-2.4.77.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-XORG_MULTILIB=yes
-inherit xorg-2
-
-DESCRIPTION="X.Org libdrm library"
-HOMEPAGE="https://dri.freedesktop.org/"
-if [[ ${PV} = 9999* ]]; then
- EGIT_REPO_URI="git://anongit.freedesktop.org/git/mesa/drm"
-else
- SRC_URI="https://dri.freedesktop.org/${PN}/${P}.tar.bz2"
-fi
-
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
-VIDEO_CARDS="amdgpu exynos freedreno intel nouveau omap radeon tegra vc4 vivante vmware"
-for card in ${VIDEO_CARDS}; do
- IUSE_VIDEO_CARDS+=" video_cards_${card}"
-done
-
-IUSE="${IUSE_VIDEO_CARDS} libkms valgrind"
-RESTRICT="test" # see bug #236845
-
-RDEPEND=">=dev-libs/libpthread-stubs-0.3-r1:=[${MULTILIB_USEDEP}]
- video_cards_intel? ( >=x11-libs/libpciaccess-0.13.1-r1:=[${MULTILIB_USEDEP}] )
- abi_x86_32? ( !app-emulation/emul-linux-x86-opengl[-abi_x86_32(-)] )"
-DEPEND="${RDEPEND}
- valgrind? ( dev-util/valgrind )"
-
-src_prepare() {
- if [[ ${PV} = 9999* ]]; then
- # tests are restricted, no point in building them
- sed -ie 's/tests //' "${S}"/Makefile.am
- fi
- xorg-2_src_prepare
-}
-
-src_configure() {
- XORG_CONFIGURE_OPTIONS=(
- # Udev is only used by tests now.
- --disable-udev
- --disable-cairo-tests
- $(use_enable video_cards_amdgpu amdgpu)
- $(use_enable video_cards_exynos exynos-experimental-api)
- $(use_enable video_cards_freedreno freedreno)
- $(use_enable video_cards_intel intel)
- $(use_enable video_cards_nouveau nouveau)
- $(use_enable video_cards_omap omap-experimental-api)
- $(use_enable video_cards_radeon radeon)
- $(use_enable video_cards_tegra tegra-experimental-api)
- $(use_enable video_cards_vc4 vc4)
- $(use_enable video_cards_vivante etnaviv-experimental-api)
- $(use_enable video_cards_vmware vmwgfx)
- $(use_enable libkms)
- # valgrind installs its .pc file to the pkgconfig for the primary arch
- --enable-valgrind=$(usex valgrind auto no)
- )
-
- xorg-2_src_configure
-}