summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-electronics/kicad/Manifest3
-rw-r--r--sci-electronics/kicad/files/kicad-5.1.5-algorithm-header.patch11
-rw-r--r--sci-electronics/kicad/files/kicad-5.1.6-ninja-build.patch45
-rw-r--r--sci-electronics/kicad/kicad-5.1.6.ebuild159
-rw-r--r--sci-electronics/kicad/kicad-5.1.7.ebuild158
-rw-r--r--sci-electronics/kicad/kicad-5.1.8.ebuild158
6 files changed, 0 insertions, 534 deletions
diff --git a/sci-electronics/kicad/Manifest b/sci-electronics/kicad/Manifest
index aa0af793ab92..a3d6d27bf935 100644
--- a/sci-electronics/kicad/Manifest
+++ b/sci-electronics/kicad/Manifest
@@ -1,4 +1 @@
-DIST kicad-5.1.6.tar.bz2 18299367 BLAKE2B b5bfda025bb0be249f2ff334e8b82c49e4e4265fe4cf5daad8a01bfd6149f4c2d1c55d689f3033136ab904f45e8deb9ea12ccde43ea083b14d92e677adf39c0f SHA512 4fd3d0ac1524cc113210be8dc1b76ab4e02bf271f598943ecab73af98a9dc99009b2d3818c97b358498d2f98ee863f13b21e958fd2143356c2a1368601f0d48a
-DIST kicad-5.1.7.tar.bz2 18279204 BLAKE2B 9d12cf06282d2b8a5c5c4b0a387774ef90f8035bf0fafd9f5d939819f71edbb248d2b15fb4b3f35a80950fd41d140d93165ece61748076d7e2938cc0c9140e46 SHA512 f853eed50245d875b2443cc9accb3c75e8404d8fee12f129df68b3ab7052c31cda1eb0ad22fc10eb23b35250188973fb51a8c55fcb1560ea65d6e5e22b94a182
-DIST kicad-5.1.8.tar.bz2 18282857 BLAKE2B 07afa95853dae587293f71b4b6b5e888610439d39dd5bd715a1f424a837d46894771bf3eb4b447f7a70ea0bb0a810fee141a81bf56a4be50e81415b38552ff11 SHA512 6d40c5ce65c4350174412359d03a9c0c3a311de9ba57d92c1b053fefbb3e518cccb7a38a2a87e8f5b1950a3676514d25ae0e5e14a97b72a56cc0d401aeab3452
DIST kicad-5.1.9.tar.bz2 18597932 BLAKE2B bc91e1249378970188f968590f70f7f1e4226f9d5cf576da6b3e751332f3a6a2160f261e7a28587ac71bae2e03f77ba3d0aa703422515ea1bd24212de5efd108 SHA512 565226a1ce8d8af8011062f767366b60449d9ce5961f343e495d5b996fb66fbfc885ac3d383892879bdade9e4d374816a54b5eee754fbe5f257e8aaa8de8f739
diff --git a/sci-electronics/kicad/files/kicad-5.1.5-algorithm-header.patch b/sci-electronics/kicad/files/kicad-5.1.5-algorithm-header.patch
deleted file mode 100644
index aa118ea6f860..000000000000
--- a/sci-electronics/kicad/files/kicad-5.1.5-algorithm-header.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Naur kicad-5.1.5-orig/common/lib_tree_model.cpp kicad-5.1.5/common/lib_tree_model.cpp
---- kicad-5.1.5-orig/common/lib_tree_model.cpp 2020-05-11 00:36:36.568301297 +0200
-+++ kicad-5.1.5/common/lib_tree_model.cpp 2020-05-11 00:37:50.472359703 +0200
-@@ -21,6 +21,7 @@
-
- #include <lib_tree_model.h>
-
-+#include <algorithm>
- #include <eda_pattern_match.h>
- #include <lib_tree_item.h>
- #include <make_unique.h>
diff --git a/sci-electronics/kicad/files/kicad-5.1.6-ninja-build.patch b/sci-electronics/kicad/files/kicad-5.1.6-ninja-build.patch
deleted file mode 100644
index baff144fbd85..000000000000
--- a/sci-electronics/kicad/files/kicad-5.1.6-ninja-build.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff -Naur kicad-5.1.6-orig/pcbnew/CMakeLists.txt kicad-5.1.6/pcbnew/CMakeLists.txt
---- kicad-5.1.6-orig/pcbnew/CMakeLists.txt 2020-05-11 11:27:08.000000000 -0700
-+++ kicad-5.1.6/pcbnew/CMakeLists.txt 2020-05-25 20:57:03.387859088 -0700
-@@ -805,11 +805,7 @@
- add_dependencies( ScriptingModulesPcbnewSoCopy ScriptingPythonDirectoryCreation )
- set( PYMOD_EXT "so" )
- else() # only linux remains among supported platforms
-- add_library( pcbnew_python MODULE $<TARGET_OBJECTS:pcbnew_kiface_objects> )
-- target_link_libraries( pcbnew_python ${PCBNEW_KIFACE_LIBRARIES} )
-- set_target_properties( pcbnew_python PROPERTIES OUTPUT_NAME pcbnew PREFIX "_" SUFFIX ".so" )
-- install( TARGETS pcbnew_python DESTINATION ${PYTHON_DEST} COMPONENT binary )
--
-+ install( FILES ${CMAKE_CURRENT_BINARY_DIR}/_pcbnew.kiface DESTINATION ${PYTHON_DEST} COMPONENT binary RENAME "_pcbnew.so" )
- set( PYMOD_EXT "so" )
- endif()
-
-@@ -824,18 +820,16 @@
- DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/_pcbnew.${PYMOD_EXT}
- )
- else()
--
--
-- # For phase 1, copy _pcbnew.kiface to the python module.
-- add_custom_command( OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/_pcbnew.${PYMOD_EXT}
-- DEPENDS pcbnew_kiface
-- COMMAND ${CMAKE_COMMAND} -E copy _pcbnew.kiface _pcbnew.${PYMOD_EXT}
-- COMMENT "Creating python's pcbnew native module _pcbnew.${PYMOD_EXT} for command line use."
-- )
-- add_custom_target(
-- pcbnew_python_module ALL
-- DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/_pcbnew.${PYMOD_EXT}
-- )
-+ # For phase 1, copy _pcbnew.kiface to the python module.
-+ add_custom_command( OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/_pcbnew.${PYMOD_EXT}
-+ DEPENDS pcbnew_kiface
-+ COMMAND ${CMAKE_COMMAND} -E copy _pcbnew.kiface _pcbnew.${PYMOD_EXT}
-+ COMMENT "Creating python's pcbnew native module _pcbnew.${PYMOD_EXT} for command line use."
-+ )
-+ add_custom_target(
-+ pcbnew_python_module ALL
-+ DEPENDS ${CMAKE_CURRENT_BINARY_DIR}/_pcbnew.${PYMOD_EXT}
-+ )
- endif()
-
- endif()
diff --git a/sci-electronics/kicad/kicad-5.1.6.ebuild b/sci-electronics/kicad/kicad-5.1.6.ebuild
deleted file mode 100644
index 0eff75e7cb86..000000000000
--- a/sci-electronics/kicad/kicad-5.1.6.ebuild
+++ /dev/null
@@ -1,159 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9} )
-
-WX_GTK_VER="3.0-gtk3"
-
-inherit check-reqs cmake optfeature python-single-r1 toolchain-funcs wxwidgets xdg-utils
-
-DESCRIPTION="Electronic Schematic and PCB design tools"
-HOMEPAGE="https://www.kicad-pcb.org"
-SRC_URI="https://gitlab.com/kicad/code/${PN}/-/archive/${PV}/${P}.tar.bz2"
-
-LICENSE="GPL-2+ GPL-3+ Boost-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc examples github +ngspice occ +oce openmp +python"
-
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
- ?? ( occ oce )
-"
-
-COMMON_DEPEND="
- >=dev-libs/boost-1.61:=[context,nls,threads]
- media-libs/freeglut
- media-libs/glew:0=
- >=media-libs/glm-0.9.9.1
- media-libs/mesa[X(+)]
- >=x11-libs/cairo-1.8.8:=
- >=x11-libs/pixman-0.30
- x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
- github? ( net-misc/curl:=[ssl] )
- ngspice? (
- >sci-electronics/ngspice-27[shared]
- )
- occ? ( >=sci-libs/opencascade-6.8.0:= )
- oce? ( sci-libs/oce )
- python? (
- $(python_gen_cond_dep '
- >=dev-libs/boost-1.61:=[context,nls,threads,python,${PYTHON_MULTI_USEDEP}]
- dev-python/wxpython:4.0[${PYTHON_MULTI_USEDEP}]
- ')
- ${PYTHON_DEPS}
- )
-"
-DEPEND="${COMMON_DEPEND}
- python? ( >=dev-lang/swig-3.0:0 )"
-RDEPEND="${COMMON_DEPEND}
- sci-electronics/electronics-menu
-"
-BDEPEND="doc? ( app-doc/doxygen )"
-CHECKREQS_DISK_BUILD="800M"
-
-PATCHES=(
- "${FILESDIR}/${PN}-5.1.5-help.patch"
- "${FILESDIR}/${P}-ninja-build.patch"
- "${FILESDIR}/${PN}-5.1.5-strict-aliasing.patch"
- "${FILESDIR}/${PN}-5.1.5-algorithm-header.patch"
- "${FILESDIR}/${P}-metainfo.patch"
- "${FILESDIR}/${PN}-5.1.5-ldflags.patch"
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
- use openmp && tc-check-openmp
- setup-wxwidgets
- check-reqs_pkg_setup
-}
-
-src_unpack() {
- default_src_unpack
- # For the metainfo patch to work the kicad.appdata.xml has to be moved to
- # avoid QA issue. This is needed because /usr/share/appdata location is
- # deprecated, it should not be used anymore by new software.
- # Appdata/Metainfo files should be installed into /usr/share/metainfo
- # directory. as per
- # https://www.freedesktop.org/software/appstream/docs/chap-Metadata.html
- mv "${S}/resources/linux/appdata" "${S}/resources/linux/metainfo" || die "Appdata move failed"
-}
-
-src_configure() {
- xdg_environment_reset
-
- local mycmakeargs=(
- -DKICAD_DOCS="${EPREFIX}/usr/share/doc/${PF}"
- -DKICAD_HELP="${EPREFIX}/usr/share/doc/${PN}-doc-${PV}"
- -DBUILD_GITHUB_PLUGIN="$(usex github)"
- -DKICAD_SCRIPTING="$(usex python)"
- -DKICAD_SCRIPTING_MODULES="$(usex python)"
- -DKICAD_SCRIPTING_WXPYTHON="$(usex python)"
- -DKICAD_SCRIPTING_WXPYTHON_PHOENIX="$(usex python)"
- -DKICAD_SCRIPTING_PYTHON3="$(usex python)"
- -DKICAD_SCRIPTING_ACTION_MENU="$(usex python)"
- -DKICAD_SPICE="$(usex ngspice)"
- -DKICAD_USE_OCC="$(usex occ)"
- -DKICAD_USE_OCE="$(usex oce)"
- -DKICAD_INSTALL_DEMOS="$(usex examples)"
- -DCMAKE_SKIP_RPATH="ON"
- )
- use python && mycmakeargs+=(
- -DPYTHON_DEST="$(python_get_sitedir)"
- -DPYTHON_EXECUTABLE="${PYTHON}"
- -DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
- -DPYTHON_LIBRARY="$(python_get_library_path)"
- )
- use occ && mycmakeargs+=(
- -DOCC_INCLUDE_DIR="${CASROOT}"/include/opencascade
- -DOCC_LIBRARY_DIR="${CASROOT}"/lib
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- if use doc; then
- cmake_src_compile dev-docs doxygen-docs
- fi
-}
-
-src_install() {
- cmake_src_install
- use python && python_optimize
- if use doc ; then
- dodoc uncrustify.cfg
- cd Documentation || die
- dodoc -r *.txt kicad_doxygen_logo.png notes_about_pcbnew_new_file_format.odt doxygen/. development/doxygen/.
- fi
-}
-
-src_test() {
- # Test cannot find library in Portage's sandbox. Let's create a link so test can run.
- ln -s "${S}_build/eeschema/_eeschema.kiface" "${S}_build/qa/eeschema/_eeschema.kiface" || die
-
- default
-}
-
-pkg_postinst() {
- optfeature "Component symbols library" sci-electronics/kicad-symbols
- optfeature "Component footprints library" sci-electronics/kicad-footprints
- optfeature "3D models of components " sci-electronics/kicad-packages3d
- optfeature "Project templates" sci-electronics/kicad-templates
- optfeature "Different languages for GUI" sci-electronics/kicad-i18n
- optfeature "Extended documentation" app-doc/kicad-doc
- optfeature "Creating 3D models of components" media-gfx/wings
-
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
- xdg_icon_cache_update
-}
diff --git a/sci-electronics/kicad/kicad-5.1.7.ebuild b/sci-electronics/kicad/kicad-5.1.7.ebuild
deleted file mode 100644
index 4e39f2bdd57a..000000000000
--- a/sci-electronics/kicad/kicad-5.1.7.ebuild
+++ /dev/null
@@ -1,158 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9} )
-
-WX_GTK_VER="3.0-gtk3"
-
-inherit check-reqs cmake optfeature python-single-r1 toolchain-funcs wxwidgets xdg-utils
-
-DESCRIPTION="Electronic Schematic and PCB design tools"
-HOMEPAGE="https://www.kicad-pcb.org"
-SRC_URI="https://gitlab.com/kicad/code/${PN}/-/archive/${PV}/${P}.tar.bz2"
-
-LICENSE="GPL-2+ GPL-3+ Boost-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc examples github +ngspice occ +oce openmp +python"
-
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
- ?? ( occ oce )
-"
-
-COMMON_DEPEND="
- >=dev-libs/boost-1.61:=[context,nls,threads]
- media-libs/freeglut
- media-libs/glew:0=
- >=media-libs/glm-0.9.9.1
- media-libs/mesa[X(+)]
- >=x11-libs/cairo-1.8.8:=
- >=x11-libs/pixman-0.30
- x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
- github? ( net-misc/curl:=[ssl] )
- ngspice? (
- >sci-electronics/ngspice-27[shared]
- )
- occ? ( >=sci-libs/opencascade-6.8.0:= )
- oce? ( sci-libs/oce )
- python? (
- $(python_gen_cond_dep '
- >=dev-libs/boost-1.61:=[context,nls,threads,python,${PYTHON_MULTI_USEDEP}]
- dev-python/wxpython:4.0[${PYTHON_MULTI_USEDEP}]
- ')
- ${PYTHON_DEPS}
- )
-"
-DEPEND="${COMMON_DEPEND}
- python? ( >=dev-lang/swig-3.0:0 )"
-RDEPEND="${COMMON_DEPEND}
- sci-electronics/electronics-menu
-"
-BDEPEND="doc? ( app-doc/doxygen )"
-CHECKREQS_DISK_BUILD="800M"
-
-PATCHES=(
- "${FILESDIR}/${PN}-5.1.5-help.patch"
- "${FILESDIR}/${PN}-5.1.6-ninja-build.patch"
- "${FILESDIR}/${PN}-5.1.5-strict-aliasing.patch"
- "${FILESDIR}/${PN}-5.1.6-metainfo.patch"
- "${FILESDIR}/${PN}-5.1.5-ldflags.patch"
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
- use openmp && tc-check-openmp
- setup-wxwidgets
- check-reqs_pkg_setup
-}
-
-src_unpack() {
- default_src_unpack
- # For the metainfo patch to work the kicad.appdata.xml has to be moved to
- # avoid QA issue. This is needed because /usr/share/appdata location is
- # deprecated, it should not be used anymore by new software.
- # Appdata/Metainfo files should be installed into /usr/share/metainfo
- # directory. as per
- # https://www.freedesktop.org/software/appstream/docs/chap-Metadata.html
- mv "${S}/resources/linux/appdata" "${S}/resources/linux/metainfo" || die "Appdata move failed"
-}
-
-src_configure() {
- xdg_environment_reset
-
- local mycmakeargs=(
- -DKICAD_DOCS="${EPREFIX}/usr/share/doc/${PF}"
- -DKICAD_HELP="${EPREFIX}/usr/share/doc/${PN}-doc-${PV}"
- -DBUILD_GITHUB_PLUGIN="$(usex github)"
- -DKICAD_SCRIPTING="$(usex python)"
- -DKICAD_SCRIPTING_MODULES="$(usex python)"
- -DKICAD_SCRIPTING_WXPYTHON="$(usex python)"
- -DKICAD_SCRIPTING_WXPYTHON_PHOENIX="$(usex python)"
- -DKICAD_SCRIPTING_PYTHON3="$(usex python)"
- -DKICAD_SCRIPTING_ACTION_MENU="$(usex python)"
- -DKICAD_SPICE="$(usex ngspice)"
- -DKICAD_USE_OCC="$(usex occ)"
- -DKICAD_USE_OCE="$(usex oce)"
- -DKICAD_INSTALL_DEMOS="$(usex examples)"
- -DCMAKE_SKIP_RPATH="ON"
- )
- use python && mycmakeargs+=(
- -DPYTHON_DEST="$(python_get_sitedir)"
- -DPYTHON_EXECUTABLE="${PYTHON}"
- -DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
- -DPYTHON_LIBRARY="$(python_get_library_path)"
- )
- use occ && mycmakeargs+=(
- -DOCC_INCLUDE_DIR="${CASROOT}"/include/opencascade
- -DOCC_LIBRARY_DIR="${CASROOT}"/lib
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- if use doc; then
- cmake_src_compile dev-docs doxygen-docs
- fi
-}
-
-src_install() {
- cmake_src_install
- use python && python_optimize
- if use doc ; then
- dodoc uncrustify.cfg
- cd Documentation || die
- dodoc -r *.txt kicad_doxygen_logo.png notes_about_pcbnew_new_file_format.odt doxygen/. development/doxygen/.
- fi
-}
-
-src_test() {
- # Test cannot find library in Portage's sandbox. Let's create a link so test can run.
- ln -s "${S}_build/eeschema/_eeschema.kiface" "${S}_build/qa/eeschema/_eeschema.kiface" || die
-
- default
-}
-
-pkg_postinst() {
- optfeature "Component symbols library" sci-electronics/kicad-symbols
- optfeature "Component footprints library" sci-electronics/kicad-footprints
- optfeature "3D models of components " sci-electronics/kicad-packages3d
- optfeature "Project templates" sci-electronics/kicad-templates
- optfeature "Different languages for GUI" sci-electronics/kicad-i18n
- optfeature "Extended documentation" app-doc/kicad-doc
- optfeature "Creating 3D models of components" media-gfx/wings
-
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
- xdg_icon_cache_update
-}
diff --git a/sci-electronics/kicad/kicad-5.1.8.ebuild b/sci-electronics/kicad/kicad-5.1.8.ebuild
deleted file mode 100644
index eb9b3fb01986..000000000000
--- a/sci-electronics/kicad/kicad-5.1.8.ebuild
+++ /dev/null
@@ -1,158 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-
-WX_GTK_VER="3.0-gtk3"
-
-inherit check-reqs cmake optfeature python-single-r1 toolchain-funcs wxwidgets xdg-utils
-
-DESCRIPTION="Electronic Schematic and PCB design tools"
-HOMEPAGE="https://www.kicad.org"
-SRC_URI="https://gitlab.com/kicad/code/${PN}/-/archive/${PV}/${P}.tar.bz2"
-
-LICENSE="GPL-2+ GPL-3+ Boost-1.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc examples github +ngspice occ +oce openmp +python"
-
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
- ?? ( occ oce )
-"
-
-COMMON_DEPEND="
- >=dev-libs/boost-1.61:=[context,nls,threads]
- media-libs/freeglut
- media-libs/glew:0=
- >=media-libs/glm-0.9.9.1
- media-libs/mesa[X(+)]
- >=x11-libs/cairo-1.8.8:=
- >=x11-libs/pixman-0.30
- x11-libs/wxGTK:${WX_GTK_VER}[X,opengl]
- github? ( net-misc/curl:=[ssl] )
- ngspice? (
- >sci-electronics/ngspice-27[shared]
- )
- occ? ( >=sci-libs/opencascade-6.8.0:= )
- oce? ( sci-libs/oce )
- python? (
- $(python_gen_cond_dep '
- >=dev-libs/boost-1.61:=[context,nls,threads,python,${PYTHON_MULTI_USEDEP}]
- dev-python/wxpython:4.0[${PYTHON_MULTI_USEDEP}]
- ')
- ${PYTHON_DEPS}
- )
-"
-DEPEND="${COMMON_DEPEND}
- python? ( >=dev-lang/swig-3.0:0 )"
-RDEPEND="${COMMON_DEPEND}
- sci-electronics/electronics-menu
-"
-BDEPEND="doc? ( app-doc/doxygen )"
-CHECKREQS_DISK_BUILD="800M"
-
-PATCHES=(
- "${FILESDIR}/${PN}-5.1.5-help.patch"
- "${FILESDIR}/${PN}-5.1.6-ninja-build.patch"
- "${FILESDIR}/${PN}-5.1.5-strict-aliasing.patch"
- "${FILESDIR}/${PN}-5.1.6-metainfo.patch"
- "${FILESDIR}/${PN}-5.1.5-ldflags.patch"
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
- use openmp && tc-check-openmp
- setup-wxwidgets
- check-reqs_pkg_setup
-}
-
-src_unpack() {
- default_src_unpack
- # For the metainfo patch to work the kicad.appdata.xml has to be moved to
- # avoid QA issue. This is needed because /usr/share/appdata location is
- # deprecated, it should not be used anymore by new software.
- # Appdata/Metainfo files should be installed into /usr/share/metainfo
- # directory. as per
- # https://www.freedesktop.org/software/appstream/docs/chap-Metadata.html
- mv "${S}/resources/linux/appdata" "${S}/resources/linux/metainfo" || die "Appdata move failed"
-}
-
-src_configure() {
- xdg_environment_reset
-
- local mycmakeargs=(
- -DKICAD_DOCS="${EPREFIX}/usr/share/doc/${PF}"
- -DKICAD_HELP="${EPREFIX}/usr/share/doc/${PN}-doc-${PV}"
- -DBUILD_GITHUB_PLUGIN="$(usex github)"
- -DKICAD_SCRIPTING="$(usex python)"
- -DKICAD_SCRIPTING_MODULES="$(usex python)"
- -DKICAD_SCRIPTING_WXPYTHON="$(usex python)"
- -DKICAD_SCRIPTING_WXPYTHON_PHOENIX="$(usex python)"
- -DKICAD_SCRIPTING_PYTHON3="$(usex python)"
- -DKICAD_SCRIPTING_ACTION_MENU="$(usex python)"
- -DKICAD_SPICE="$(usex ngspice)"
- -DKICAD_USE_OCC="$(usex occ)"
- -DKICAD_USE_OCE="$(usex oce)"
- -DKICAD_INSTALL_DEMOS="$(usex examples)"
- -DCMAKE_SKIP_RPATH="ON"
- )
- use python && mycmakeargs+=(
- -DPYTHON_DEST="$(python_get_sitedir)"
- -DPYTHON_EXECUTABLE="${PYTHON}"
- -DPYTHON_INCLUDE_DIR="$(python_get_includedir)"
- -DPYTHON_LIBRARY="$(python_get_library_path)"
- )
- use occ && mycmakeargs+=(
- -DOCC_INCLUDE_DIR="${CASROOT}"/include/opencascade
- -DOCC_LIBRARY_DIR="${CASROOT}"/lib
- )
-
- cmake_src_configure
-}
-
-src_compile() {
- cmake_src_compile
- if use doc; then
- cmake_src_compile dev-docs doxygen-docs
- fi
-}
-
-src_install() {
- cmake_src_install
- use python && python_optimize
- if use doc ; then
- dodoc uncrustify.cfg
- cd Documentation || die
- dodoc -r *.txt kicad_doxygen_logo.png notes_about_pcbnew_new_file_format.odt doxygen/. development/doxygen/.
- fi
-}
-
-src_test() {
- # Test cannot find library in Portage's sandbox. Let's create a link so test can run.
- ln -s "${S}_build/eeschema/_eeschema.kiface" "${S}_build/qa/eeschema/_eeschema.kiface" || die
-
- default
-}
-
-pkg_postinst() {
- optfeature "Component symbols library" sci-electronics/kicad-symbols
- optfeature "Component footprints library" sci-electronics/kicad-footprints
- optfeature "3D models of components " sci-electronics/kicad-packages3d
- optfeature "Project templates" sci-electronics/kicad-templates
- optfeature "Different languages for GUI" sci-electronics/kicad-i18n
- optfeature "Extended documentation" app-doc/kicad-doc
- optfeature "Creating 3D models of components" media-gfx/wings
-
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
- xdg_icon_cache_update
-}
-
-pkg_postrm() {
- xdg_desktop_database_update
- xdg_mimeinfo_database_update
- xdg_icon_cache_update
-}