summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/wandio/Manifest1
-rw-r--r--net-libs/wandio/wandio-1.0.5.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/net-libs/wandio/Manifest b/net-libs/wandio/Manifest
index 31654a3304ed..ba43ec2187cc 100644
--- a/net-libs/wandio/Manifest
+++ b/net-libs/wandio/Manifest
@@ -1 +1,2 @@
DIST wandio-1.0.4.tar.gz 381793 BLAKE2B 904eebcbe9ac1a08ea8b2d62691f32adb2575e4b2f5329ea1fc3af9e5b92e4851198db221cee91138d6b529d44c438b278c7a5c905d7adee226ae78b7db16274 SHA512 247e3fe26ca0732acf50549284bdce34b3e0afd6b7bc7a44a2188c67a5fb38417feca23e9428acae903941c3d0a9f077e05aae879199deed64711615cd4174a2
+DIST wandio-1.0.5.tar.gz 385535 BLAKE2B a7911ab14ff9911ef19bf35b6e50d3f2e6dd0fa06f5689b6c353cc5ff2ee93175d7e758657f79fd35e7aff29fb1a4b4c343c30ab1e00a118ec3056ba9129cd60 SHA512 3bf2b4362355bb3db047ea12055b96cc6fdd759b4efbd9cf1caf05133ae9e7e1fab5f4a7e5eadda45d7c1b4dcf9aba1cf3a4c04bc23694934aa8aa67ec31e480
diff --git a/net-libs/wandio/wandio-1.0.5.ebuild b/net-libs/wandio/wandio-1.0.5.ebuild
new file mode 100644
index 000000000000..295c4fa7e4eb
--- /dev/null
+++ b/net-libs/wandio/wandio-1.0.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Library for transparent file I/O with compression"
+HOMEPAGE="https://research.wand.net.nz/software/libwandio.php"
+SRC_URI="https://research.wand.net.nz/software/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/2"
+KEYWORDS="~amd64 ~x86"
+IUSE="bzip2 http lzma lzo static-libs zlib"
+
+RDEPEND="
+ !<net-libs/libtrace-4
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ lzo? ( dev-libs/lzo )
+ http? ( net-misc/curl )
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="
+ ${RDEPEND}
+"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with bzip2) \
+ $(use_with http) \
+ $(use_with lzma) \
+ $(use_with lzo) \
+ $(use_with zlib)
+}