summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-vim/rust-mode/metadata.xml4
-rw-r--r--app-vim/rust-vim/Manifest (renamed from app-vim/rust-mode/Manifest)0
-rw-r--r--app-vim/rust-vim/metadata.xml12
-rw-r--r--app-vim/rust-vim/rust-vim-1_beta20150411.ebuild (renamed from app-vim/rust-mode/rust-mode-1_beta20150411.ebuild)8
-rw-r--r--dev-lang/rust-bin/rust-bin-1.2.0.ebuild2
-rw-r--r--dev-lang/rust-bin/rust-bin-1.3.0.ebuild2
-rw-r--r--dev-lang/rust-bin/rust-bin-1.5.0.ebuild2
-rw-r--r--dev-lang/rust-bin/rust-bin-1.6.0.ebuild2
-rw-r--r--dev-lang/rust-bin/rust-bin-1.7.0.ebuild2
-rw-r--r--dev-lang/rust-bin/rust-bin-1.8.0.ebuild2
-rw-r--r--dev-lang/rust/rust-1.10.0.ebuild2
-rw-r--r--dev-lang/rust/rust-1.11.0.ebuild2
-rw-r--r--dev-lang/rust/rust-1.9.0.ebuild2
-rw-r--r--profiles/updates/3Q-20161
14 files changed, 26 insertions, 17 deletions
diff --git a/app-vim/rust-mode/metadata.xml b/app-vim/rust-mode/metadata.xml
deleted file mode 100644
index 097975e3adc2..000000000000
--- a/app-vim/rust-mode/metadata.xml
+++ /dev/null
@@ -1,4 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
-</pkgmetadata>
diff --git a/app-vim/rust-mode/Manifest b/app-vim/rust-vim/Manifest
index 4b772f0ce0cb..4b772f0ce0cb 100644
--- a/app-vim/rust-mode/Manifest
+++ b/app-vim/rust-vim/Manifest
diff --git a/app-vim/rust-vim/metadata.xml b/app-vim/rust-vim/metadata.xml
new file mode 100644
index 000000000000..3554bdb770b5
--- /dev/null
+++ b/app-vim/rust-vim/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>hilobakho@gmail.com</email>
+ <name>Mykyta Holubakha</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Gentoo Proxy Maintainers Project</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-vim/rust-mode/rust-mode-1_beta20150411.ebuild b/app-vim/rust-vim/rust-vim-1_beta20150411.ebuild
index b997c339c69a..81d1f6355fad 100644
--- a/app-vim/rust-mode/rust-mode-1_beta20150411.ebuild
+++ b/app-vim/rust-vim/rust-vim-1_beta20150411.ebuild
@@ -1,14 +1,14 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
inherit vim-plugin
-MY_PN="${PN}-vim"
+MY_PN="rust-mode-vim"
MY_P="${MY_PN}-${PV}"
-DESCRIPTION="Rust mode for vim"
+DESCRIPTION="Vim configuration for Rust"
HOMEPAGE="http://www.rust-lang.org/"
SRC_URI="https://dev.gentoo.org/~jauhien/distfiles/${MY_P}.tar.gz"
diff --git a/dev-lang/rust-bin/rust-bin-1.2.0.ebuild b/dev-lang/rust-bin/rust-bin-1.2.0.ebuild
index 409a1b9f9253..f364f85d868c 100644
--- a/dev-lang/rust-bin/rust-bin-1.2.0.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.2.0.ebuild
@@ -80,7 +80,7 @@ pkg_postinst() {
fi
if has_version app-editors/gvim || has_version app-editors/vim; then
- elog "install app-vim/rust-mode to get vim support for rust."
+ elog "install app-vim/rust-vim to get vim support for rust."
fi
if has_version 'app-shells/zsh'; then
diff --git a/dev-lang/rust-bin/rust-bin-1.3.0.ebuild b/dev-lang/rust-bin/rust-bin-1.3.0.ebuild
index 409a1b9f9253..f364f85d868c 100644
--- a/dev-lang/rust-bin/rust-bin-1.3.0.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.3.0.ebuild
@@ -80,7 +80,7 @@ pkg_postinst() {
fi
if has_version app-editors/gvim || has_version app-editors/vim; then
- elog "install app-vim/rust-mode to get vim support for rust."
+ elog "install app-vim/rust-vim to get vim support for rust."
fi
if has_version 'app-shells/zsh'; then
diff --git a/dev-lang/rust-bin/rust-bin-1.5.0.ebuild b/dev-lang/rust-bin/rust-bin-1.5.0.ebuild
index aef5ebe7f123..444dc2795cb9 100644
--- a/dev-lang/rust-bin/rust-bin-1.5.0.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.5.0.ebuild
@@ -89,7 +89,7 @@ pkg_postinst() {
fi
if has_version app-editors/gvim || has_version app-editors/vim; then
- elog "install app-vim/rust-mode to get vim support for rust."
+ elog "install app-vim/rust-vim to get vim support for rust."
fi
if has_version 'app-shells/zsh'; then
diff --git a/dev-lang/rust-bin/rust-bin-1.6.0.ebuild b/dev-lang/rust-bin/rust-bin-1.6.0.ebuild
index aef5ebe7f123..444dc2795cb9 100644
--- a/dev-lang/rust-bin/rust-bin-1.6.0.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.6.0.ebuild
@@ -89,7 +89,7 @@ pkg_postinst() {
fi
if has_version app-editors/gvim || has_version app-editors/vim; then
- elog "install app-vim/rust-mode to get vim support for rust."
+ elog "install app-vim/rust-vim to get vim support for rust."
fi
if has_version 'app-shells/zsh'; then
diff --git a/dev-lang/rust-bin/rust-bin-1.7.0.ebuild b/dev-lang/rust-bin/rust-bin-1.7.0.ebuild
index aef5ebe7f123..444dc2795cb9 100644
--- a/dev-lang/rust-bin/rust-bin-1.7.0.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.7.0.ebuild
@@ -89,7 +89,7 @@ pkg_postinst() {
fi
if has_version app-editors/gvim || has_version app-editors/vim; then
- elog "install app-vim/rust-mode to get vim support for rust."
+ elog "install app-vim/rust-vim to get vim support for rust."
fi
if has_version 'app-shells/zsh'; then
diff --git a/dev-lang/rust-bin/rust-bin-1.8.0.ebuild b/dev-lang/rust-bin/rust-bin-1.8.0.ebuild
index aef5ebe7f123..444dc2795cb9 100644
--- a/dev-lang/rust-bin/rust-bin-1.8.0.ebuild
+++ b/dev-lang/rust-bin/rust-bin-1.8.0.ebuild
@@ -89,7 +89,7 @@ pkg_postinst() {
fi
if has_version app-editors/gvim || has_version app-editors/vim; then
- elog "install app-vim/rust-mode to get vim support for rust."
+ elog "install app-vim/rust-vim to get vim support for rust."
fi
if has_version 'app-shells/zsh'; then
diff --git a/dev-lang/rust/rust-1.10.0.ebuild b/dev-lang/rust/rust-1.10.0.ebuild
index f54624b77409..58775d26c059 100644
--- a/dev-lang/rust/rust-1.10.0.ebuild
+++ b/dev-lang/rust/rust-1.10.0.ebuild
@@ -141,7 +141,7 @@ pkg_postinst() {
fi
if has_version app-editors/gvim || has_version app-editors/vim; then
- elog "install app-vim/rust-mode to get vim support for rust."
+ elog "install app-vim/rust-vim to get vim support for rust."
fi
if has_version 'app-shells/zsh'; then
diff --git a/dev-lang/rust/rust-1.11.0.ebuild b/dev-lang/rust/rust-1.11.0.ebuild
index 81aa8d80eff3..ff5dd2d47456 100644
--- a/dev-lang/rust/rust-1.11.0.ebuild
+++ b/dev-lang/rust/rust-1.11.0.ebuild
@@ -141,7 +141,7 @@ pkg_postinst() {
fi
if has_version app-editors/gvim || has_version app-editors/vim; then
- elog "install app-vim/rust-mode to get vim support for rust."
+ elog "install app-vim/rust-vim to get vim support for rust."
fi
if has_version 'app-shells/zsh'; then
diff --git a/dev-lang/rust/rust-1.9.0.ebuild b/dev-lang/rust/rust-1.9.0.ebuild
index 5b791e858402..cf89a418158b 100644
--- a/dev-lang/rust/rust-1.9.0.ebuild
+++ b/dev-lang/rust/rust-1.9.0.ebuild
@@ -146,7 +146,7 @@ pkg_postinst() {
fi
if has_version app-editors/gvim || has_version app-editors/vim; then
- elog "install app-vim/rust-mode to get vim support for rust."
+ elog "install app-vim/rust-vim to get vim support for rust."
fi
if has_version 'app-shells/zsh'; then
diff --git a/profiles/updates/3Q-2016 b/profiles/updates/3Q-2016
index 2a289537fb6e..7dd7d35e3830 100644
--- a/profiles/updates/3Q-2016
+++ b/profiles/updates/3Q-2016
@@ -17,3 +17,4 @@ move sys-fs/s3fs net-fs/s3fs
move sys-fs/s3ql net-fs/s3ql
move sys-fs/s3backer net-fs/s3backer
move sys-fs/sshfs net-fs/sshfs
+move app-vim/rust-mode app-vim/rust-vim