summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/jira/files/jira-1.0.14-remove_pytest-runner.patch23
-rw-r--r--dev-python/jira/jira-1.0.14-r3.ebuild39
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/jira/files/jira-1.0.14-remove_pytest-runner.patch b/dev-python/jira/files/jira-1.0.14-remove_pytest-runner.patch
new file mode 100644
index 000000000000..6546818a8b76
--- /dev/null
+++ b/dev-python/jira/files/jira-1.0.14-remove_pytest-runner.patch
@@ -0,0 +1,23 @@
+From 5f813c35cde9655cabc562411ce82ba9d466193c Mon Sep 17 00:00:00 2001
+From: Denis Dupeyron <calchan@gentoo.org>
+Date: Wed, 25 Mar 2020 10:04:07 -0600
+Subject: [PATCH] Remove pytest-runner dependency
+
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 24f3bc5..fad4a54 100644
+--- a/setup.py
++++ b/setup.py
+@@ -12,5 +12,5 @@ except ImportError:
+
+
+ setuptools.setup(
+- setup_requires=['pbr>=3.0.0', 'setuptools>=17.1', 'pytest-runner'],
++ setup_requires=['pbr>=3.0.0', 'setuptools>=17.1'],
+ pbr=True)
+--
+2.25.1
+
diff --git a/dev-python/jira/jira-1.0.14-r3.ebuild b/dev-python/jira/jira-1.0.14-r3.ebuild
new file mode 100644
index 000000000000..ad25a4a62ba2
--- /dev/null
+++ b/dev-python/jira/jira-1.0.14-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_6 )
+inherit distutils-r1
+
+DESCRIPTION="Python library for interacting with the JIRA REST API"
+HOMEPAGE="https://jira.readthedocs.io/en/latest/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="magic jirashell kerberos oauth"
+
+DEPEND="
+ >=dev-python/pbr-3.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ "
+RDEPEND="
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-toolbelt[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ magic? ( dev-python/filemagic[${PYTHON_USEDEP}] )
+ jirashell? (
+ dev-python/ipython[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ )
+ kerberos? ( dev-python/requests-kerberos[${PYTHON_USEDEP}] )
+ oauth? (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ dev-python/requests-oauthlib[${PYTHON_USEDEP}]
+ )
+ "
+
+PATCHES=( "${FILESDIR}/${P}-remove_pytest-runner.patch" )