summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games-board/natch/files/natch-2.4-format.patch4
-rw-r--r--games-board/natch/natch-2.4-r1.ebuild30
2 files changed, 32 insertions, 2 deletions
diff --git a/games-board/natch/files/natch-2.4-format.patch b/games-board/natch/files/natch-2.4-format.patch
index cc2b3207c3b0..38e2b7939b4e 100644
--- a/games-board/natch/files/natch-2.4-format.patch
+++ b/games-board/natch/files/natch-2.4-format.patch
@@ -1,5 +1,5 @@
---- src/pcpjtool.c.old 2014-10-17 08:38:21.547119790 +0200
-+++ src/pcpjtool.c 2014-10-17 08:42:04.949035648 +0200
+--- a/src/pcpjtool.c 2014-10-17 08:38:21.547119790 +0200
++++ b/src/pcpjtool.c 2014-10-17 08:42:04.949035648 +0200
@@ -45,7 +45,7 @@
int nb_libre = 0;
const char* separation_line = "+---+---+---+---+---+---+---+---+\n";
diff --git a/games-board/natch/natch-2.4-r1.ebuild b/games-board/natch/natch-2.4-r1.ebuild
new file mode 100644
index 000000000000..239bac11836c
--- /dev/null
+++ b/games-board/natch/natch-2.4-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils
+
+MY_P="Natch-${PV}"
+DESCRIPTION="A program to solve chess proof games"
+HOMEPAGE="http://natch.free.fr/Natch.html"
+SRC_URI="http://natch.free.fr/Natch/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="sys-libs/ncurses:0"
+RDEPEND=${DEPEND}
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=(
+ "${FILESDIR}"/${P}-format.patch
+)
+
+src_install() {
+ newbin src/Natch natch
+ dodoc AUTHORS ChangeLog NEWS README THANKS example.txt
+}