summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-backup/snapper/Manifest2
-rw-r--r--app-backup/snapper/metadata.xml2
-rw-r--r--app-backup/snapper/snapper-0.5.0.ebuild74
-rw-r--r--app-backup/snapper/snapper-0.5.4.ebuild77
4 files changed, 0 insertions, 155 deletions
diff --git a/app-backup/snapper/Manifest b/app-backup/snapper/Manifest
index cbe50e52b3ce..d1c2368a868b 100644
--- a/app-backup/snapper/Manifest
+++ b/app-backup/snapper/Manifest
@@ -1,4 +1,2 @@
-DIST snapper-0.5.0.tar.bz2 571716 BLAKE2B 3eb1db265566d0129c3177dcf8d62848108df918eb705ae149672664e215a17b760279e35d1ac658b18bb6e6fa05f5102d05c3a00e45fbfe73093b073fc3f8f9 SHA512 37487a1230825dc5d533e5c864965d9d05c2a3f4e12e5ae910f2721ef2497be2dafedcd13148d7246896551eae11cbcb925e04b58f799ea3d644eea329d3da29
-DIST snapper-0.5.4.tar.bz2 579172 BLAKE2B ce23b56047b818946f1b885308abd21ce6df216b890f784c3b57d8bd44a0a26bebf992b4d2a8ff36e11e096b0d589197e81bf223dd018feb9dcbeaa04c03a904 SHA512 fed417ef817526ab8c2110a70f5e9750642d7f427619efa52c2ed2e3adb83ff47314cdd8843e6331ce1c37fca79367a0a5ff8c6ba394602b24399eb5e6b97cd0
DIST snapper-0.5.6.tar.bz2 580047 BLAKE2B 3b945acbf734db1925dad5515323a64a2c08ee8226a593025f9160e0d1b1140734b2b498d036256946159900b50fec8567147dc0a974c281be747e977bcbd05b SHA512 392427d097cbe221bf7ca0ae20bc065dffaa4d0017ed750c41748d71128fc7ce054bb4425d6dbed7308a530df71815f80f56e60d72aab17ef3e0a16f3b3ba47e
DIST snapper-0.8.1.tar.bz2 591061 BLAKE2B 5f9ae50469f43e930de4c4479428c94b24441832bd713847c6792ff583fb79badfa341b53cc63abfedb787367b22b715de9f83f9172dec945f7b3071c06137ba SHA512 9fa20311f346de54c4f5d1cabb42dce5c677eaac03b3fac2a6049f408553911f5a968b1920fd014f3318ebb6911f2e6bce06463e976b468927e250e16fe783a0
diff --git a/app-backup/snapper/metadata.xml b/app-backup/snapper/metadata.xml
index 4b63f78f6038..1aa9b1e774ab 100644
--- a/app-backup/snapper/metadata.xml
+++ b/app-backup/snapper/metadata.xml
@@ -32,8 +32,6 @@
Add support for getting and setting POSIX extended attributes, through
<pkg>sys-apps/attr</pkg>.
</flag>
- <flag name="btrfs">Include Btrfs support <pkg>sys-fs/btrfs-progs</pkg></flag>
- <flag name="ext4">Include Ext4 support <pkg>sys-fs/e2fsprogs</pkg></flag>
<flag name="lvm">Enable LVM thinprovisioned snapshots support <pkg>sys-fs/lvm2</pkg></flag>
</use>
</pkgmetadata>
diff --git a/app-backup/snapper/snapper-0.5.0.ebuild b/app-backup/snapper/snapper-0.5.0.ebuild
deleted file mode 100644
index 1b4ef13115e6..000000000000
--- a/app-backup/snapper/snapper-0.5.0.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils
-
-DESCRIPTION="Command-line program for btrfs and ext4 snapshot management"
-HOMEPAGE="http://snapper.io/"
-SRC_URI="ftp://ftp.suse.com/pub/projects/snapper/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+btrfs ext4 lvm pam xattr"
-
-RDEPEND="dev-libs/boost:=[threads]
- dev-libs/libxml2
- dev-libs/icu:=
- sys-apps/acl
- sys-apps/dbus
- sys-apps/util-linux
- sys-libs/zlib
- virtual/libintl
- btrfs? ( >=sys-fs/btrfs-progs-3.17.1 )
- ext4? ( sys-fs/e2fsprogs )
- lvm? ( sys-fs/lvm2 )
- pam? ( sys-libs/pam )
- xattr? ( sys-apps/attr )"
-
-DEPEND="${RDEPEND}
- sys-devel/gettext
- virtual/pkgconfig"
-
-REQUIRED_USE="|| ( btrfs ext4 lvm )"
-
-DOCS=( AUTHORS )
-
-src_prepare() {
- default
- epatch "${FILESDIR}"/cron-confd.patch
- epatch "${FILESDIR}/${P}"-gcc6.patch
-}
-
-src_configure() {
- local myeconfargs=(
- --with-conf="/etc/conf.d"
- --docdir="/usr/share/doc/${PF}"
- --disable-zypp
- --enable-rollback
- $(use_enable btrfs)
- $(use_enable ext4)
- $(use_enable lvm)
- $(use_enable pam)
- $(use_enable xattr xattrs)
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- # Existing configuration file required to function
- newconfd data/sysconfig.snapper snapper
- prune_libtool_files
-}
-
-pkg_postinst() {
- elog "In order to use Snapper, you need to set up"
- elog "at least one config first. To do this, run:"
- elog "snapper create-config <subvolume>"
- elog "For more information, see man (8) snapper or"
- elog "http://snapper.io/documentation.html"
-}
diff --git a/app-backup/snapper/snapper-0.5.4.ebuild b/app-backup/snapper/snapper-0.5.4.ebuild
deleted file mode 100644
index 0615011a39c3..000000000000
--- a/app-backup/snapper/snapper-0.5.4.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit systemd
-
-DESCRIPTION="Command-line program for btrfs and lvm snapshot management"
-HOMEPAGE="http://snapper.io/"
-SRC_URI="ftp://ftp.suse.com/pub/projects/snapper/${P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="lvm pam xattr"
-
-RDEPEND="dev-libs/boost:=[threads]
- dev-libs/libxml2
- dev-libs/icu:=
- sys-apps/acl
- sys-apps/dbus
- sys-apps/util-linux
- >=sys-fs/btrfs-progs-3.17.1
- sys-libs/zlib
- virtual/libintl
- lvm? ( sys-fs/lvm2 )
- pam? ( sys-libs/pam )
- xattr? ( sys-apps/attr )"
-
-DEPEND="${RDEPEND}
- sys-devel/gettext
- virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}"/cron-confd.patch
-)
-
-src_prepare() {
- default
-
- sed -e "s,/usr/lib/systemd/system,$(systemd_get_systemunitdir),g" \
- -i data/Makefile.* \
- || die "Failed to fix systemd services and timers installation path"
-}
-
-src_configure() {
- # ext4 code does not work anymore
- # snapper does not build without btrfs
- local myeconfargs=(
- --with-conf="/etc/conf.d"
- --docdir="/usr/share/doc/${PF}"
- --disable-zypp
- --enable-rollback
- --disable-ext4
- --enable-btrfs
- $(use_enable lvm)
- $(use_enable pam)
- $(use_enable xattr xattrs)
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
- # Existing configuration file required to function
- newconfd data/sysconfig.snapper snapper
- find "${D}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- elog "In order to use Snapper, you need to set up"
- elog "at least one config first. To do this, run:"
- elog "snapper create-config <subvolume>"
- elog "For more information, see man (8) snapper or"
- elog "http://snapper.io/documentation.html"
-}