summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-php/spdx-licenses/Manifest1
-rw-r--r--dev-php/spdx-licenses/files/spdx-licenses-change-res-path.patch22
-rw-r--r--dev-php/spdx-licenses/spdx-licenses-1.0.0.ebuild26
3 files changed, 0 insertions, 49 deletions
diff --git a/dev-php/spdx-licenses/Manifest b/dev-php/spdx-licenses/Manifest
index 2b44e60087c1..3ec326a1c0b9 100644
--- a/dev-php/spdx-licenses/Manifest
+++ b/dev-php/spdx-licenses/Manifest
@@ -1,2 +1 @@
-DIST spdx-licenses-1.0.0.tar.gz 8244 BLAKE2B 57ef1ccb7f4165293c8daca0fe3e04322658a06a10e82b10ee0603974572c51fd005de7a530fce280d8ab3fa78fe18ac3bd64babdf2565eacb1c61a3f3df9ce4 SHA512 1ef19555f252c5e03fe3b0376442f47bd50d894effa04bca58e7644e18fcc2a905239086d1aaf31277ce5928a7f9743e123c767e197c0fa063c015ad14851a14
DIST spdx-licenses-1.2.0.tar.gz 10974 BLAKE2B 52cba9837202b1ae598b6d3b36f4ef67ec27988fa5911f2dfff92d39515d0401f5636922a3d205413489d21fd1dfacbf68f72c907503807317c7c9e51392e016 SHA512 fdb63dd29a099afbc116b30d1deec3d2b46be998a55fd741126f1bc393c5037a9a7477e55f7e030585d826be7d72db26be5ce0b5bb57dd536137cc45890ea9c9
diff --git a/dev-php/spdx-licenses/files/spdx-licenses-change-res-path.patch b/dev-php/spdx-licenses/files/spdx-licenses-change-res-path.patch
deleted file mode 100644
index 284cdddda95e..000000000000
--- a/dev-php/spdx-licenses/files/spdx-licenses-change-res-path.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-# Fix the path of res/
-
---- ./src/SpdxLicenses.php 2015-07-15 19:38:14.000000000 +0200
-+++ ./src/SpdxLicenses.php 2016-11-13 19:24:17.659442468 +0100
-@@ -170,7 +170,7 @@
- private function loadLicenses()
- {
- if (null === $this->licenses) {
-- $jsonFile = file_get_contents(__DIR__ . '/../res/spdx-licenses.json');
-+ $jsonFile = file_get_contents(__DIR__ . '/res/spdx-licenses.json');
- $this->licenses = json_decode($jsonFile, true);
- }
- }
-@@ -178,7 +178,7 @@
- private function loadExceptions()
- {
- if (null === $this->exceptions) {
-- $jsonFile = file_get_contents(__DIR__ . '/../res/spdx-exceptions.json');
-+ $jsonFile = file_get_contents(__DIR__ . '/res/spdx-exceptions.json');
- $this->exceptions = json_decode($jsonFile, true);
- }
- }
diff --git a/dev-php/spdx-licenses/spdx-licenses-1.0.0.ebuild b/dev-php/spdx-licenses/spdx-licenses-1.0.0.ebuild
deleted file mode 100644
index 099ed89b2b7e..000000000000
--- a/dev-php/spdx-licenses/spdx-licenses-1.0.0.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DESCRIPTION="Tools for working with and validating SPDX licenses"
-HOMEPAGE="https://github.com/composer/spdx-licenses"
-SRC_URI="https://github.com/composer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-lang/php:*
- dev-php/fedora-autoloader"
-
-PATCHES=(
- "${FILESDIR}/${PN}-change-res-path.patch"
-)
-
-src_install() {
- insinto "/usr/share/php/Composer/Spdx"
- doins -r src/. res "${FILESDIR}"/autoload.php
- dodoc README.md
-}